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Il file esiste già un errore durante la configurazione di Microsoft Dynamics CRM per Microsoft Office Outlook

Questo articolo fornisce una soluzione a un errore che si verifica quando si configura Microsoft Dynamics CRM per Microsoft Office Outlook.

Si applica a: Microsoft Dynamics CRM Online, Microsoft Dynamics CRM 2016, Microsoft Dynamics CRM 2015, Microsoft Dynamics CRM 2013, client Microsoft CRM per Microsoft Office Outlook
Numero KB originale: 3183053

Sintomi

Quando si tenta di configurare Microsoft Dynamics CRM per Microsoft Office Outlook, viene visualizzato l'errore seguente:

"Si è verificato un problema durante la comunicazione con il server Microsoft Dynamics CRM. È possibile che il server non sia disponibile. Riprovare. Se il problema persiste, contattare l'amministratore di sistema.

File già esistente. Provare a usare un nome di database diverso. [ Nome file = C:\Users\<USER>\AppData\Local\Microsoft\MSCRM\Client\MetadataCache-5243bc89-09f7-4d12-b578-8efd890f5d7c.sdf ]..."

Causa

Questo errore può verificarsi se esiste già un file di database di una configurazione precedente per l'istanza di CRM.

Risoluzione

Opzione 1 (CRM Online)

  1. Se si usa CRM Online, è possibile eseguire il supporto tecnico Microsoft e Assistente ripristino, che può risolvere questo problema automaticamente.
  2. Scegliere l'opzione Dynamics CRM Online e quindi selezionare Problemi durante l'installazione, la connessione o l'abilitazione di CRM per Outlook (Client Outlook).
  3. Continuare la procedura guidata. Verrà visualizzata l'azione Rimuovi file della cache utilizzati da CRM per Outlook e verrà rimosso il file esistente a cui si fa riferimento nell'errore.
  4. Eseguire di nuovo la configurazione guidata di Microsoft Dynamics CRM.

Opzione 2 (manuale)

Se non si usa CRM Online o si preferisce risolvere manualmente il problema, completare la procedura seguente.

  1. Chiudi Outlook.

  2. Aprire Esplora risorse e passare a <install directory>:\Users\<Your User>\AppData\Local\Microsoft\MSCRM\Client.

    Esempio: C:\Users\<username>\AppData\Local\Microsoft\MSCRM\Client

    Note

    La cartella AppData è nascosta per impostazione predefinita. È possibile modificare le impostazioni di Visualizzazione per visualizzare Elementi nascosti oppure copiare e incollare il percorso seguente nel percorso della cartella:
    %localappdata%\Microsoft\MSCRM\Client

  3. Eliminare il file a cui si fa riferimento nei dettagli dell'errore.

  4. Eseguire di nuovo la configurazione guidata di Microsoft Dynamics CRM.