Nota
L'accesso a questa pagina richiede l'autorizzazione. È possibile provare ad accedere o modificare le directory.
L'accesso a questa pagina richiede l'autorizzazione. È possibile provare a modificare le directory.
Questo articolo fornisce una soluzione a un errore che si verifica quando si tenta di stampare qualsiasi report in Microsoft Dynamics SL 2011.
Si applica a: Microsoft Dynamics SL 2011, Microsoft Dynamics SL 2011 Service Pack 1
Numero KB originale: 2721084
Sintomi
Quando si tenta di stampare qualsiasi report in Microsoft Dynamics SL 2011, viene visualizzato l'errore seguente:
ROI.EXE ha smesso di funzionare
Causa
Il valore RI_ID nella tabella RPTRUNTIME ha superato il limite di 32.767.
Risoluzione
Cancellare i record nella tabella RPTRUNTIME per reimpostare il valore RI_ID su 1. Per effettuare questa operazione, seguire questi passaggi:
Verificare che tutti gli utenti abbiano effettuato il logout da Microsoft Dynamics SL.
Avvia Microsoft SQL Server Management Studio.
Eseguire l'istruzione seguente sul database di sistema SL e sui database dell'applicazione SL.
delete from rptruntime
Ulteriori informazioni
La tabella RPTRUNTIME contiene informazioni temporanee correlate a un processo di stampa attivo. In genere, questa tabella è vuota quando non sono presenti utenti che eseguono un report. In alcuni casi, un record può rimanere bloccato in questa tabella, il che può aumentare le probabilità di massimizzare i valori RI_ID.