Condividi tramite


Rollback dell'aggiornamento del cluster v82

Esegue il rollback dell'aggiornamento di un cluster di Service Fabric.

Esegue il rollback dell'aggiornamento di codici o configurazioni di un cluster di Service Fabric.

Richiesta

Metodo URI richiesta
POST /$/RollbackUpgrade?api-version=6.0&timeout={timeout}

Parametri

Nome Tipo Necessario Posizione
api-version string Query
timeout integer (int64) No Query

api-version

Tipo: string
Obbligatorio: Sì
Impostazione predefinita: 6.0

Versione dell'API. Questo parametro è obbligatorio e il relativo valore deve essere '6.0'.

La versione dell'API REST di Service Fabric è basata sulla versione di runtime in cui è stata introdotta o modificata l'API. Il runtime di Service Fabric supporta più versioni dell'API. Questa è la versione più recente supportata dell'API. Se viene passata una versione precedente dell'API, la risposta restituita può essere diversa da quella documentata in questa specifica.

Inoltre, il runtime accetta qualsiasi versione superiore alla versione supportata più recente fino alla versione corrente del runtime. Se quindi la versione più recente dell'API è 6.0, ma se il runtime è 6.1, per semplificare la scrittura dei client, il runtime accetterà la versione 6.1 per tale API. Tuttavia, il comportamento dell'API sarà in base alla versione 6.0 documentata.


timeout

Tipo: integer (int64)
Obbligatorio: No
Impostazione predefinita: 60
InclusiveMaximum: 4294967295
InclusiveMinimum: 1

Timeout del server per l'esecuzione dell'operazione in secondi. Questo timeout specifica la durata di attesa che il client è disposto a attendere il completamento dell'operazione richiesta. Il valore predefinito per questo parametro è 60 secondi.

Risposte

Codice di stato HTTP Descrizione Schema di risposta
202 (Accettato) Una risposta riuscita indica che il rollback di un aggiornamento del cluster è stato avviato.
Tutti gli altri codici di stato Risposta dettagliata all'errore.
FabricError