Errore "Errore durante l'accesso" con Microsoft Dynamics 365 App per Outlook
Questo articolo consente di risolvere un problema in cui si verifica l'errore "Qualcosa è andato storto durante l'accesso" quando si usa Microsoft Dynamics 365 App per Outlook.
Si applica a: Microsoft Dynamics 365
Numero KB originale: 4035750
Sintomi
Quando si usa l'app Dynamics 365 per Outlook all'interno del desktop Outlook, si verifica l'errore seguente:
Problemi di accesso?
Si è verificato un problema durante l'accesso. Provare ad aggiungere gli URL seguenti ai siti attendibili:
https://*.dynamics.com
https://login.microsoftonline.com
Se il problema persiste, contattare l'amministratore di sistema."
Causa
Alcuni degli URL necessari per usare l'app Dynamics 365 per Outlook si trovano in aree di sicurezza di Internet Explorer diverse, ad esempio Internet, Siti attendibili o Intranet locale.
Quando si usa Dynamics 365'app per Outlook all'interno del desktop Outlook, Internet Explorer viene usato per visualizzare il contenuto e reindirizzare l'utente all'autenticazione in base alle esigenze. Le diverse zone di sicurezza possono usare livelli di integrità diversi a seconda che la modalità protetta sia abilitata per l'area. Se i diversi URL vengono caricati con livelli di integrità diversi, l'autenticazione non verrà passata correttamente dagli URL di autenticazione a Dynamics 365.
Risoluzione
Assicurarsi che gli URL usati da Dynamics 365 e anche gli URL di autenticazione utilizzino lo stesso livello di integrità. Usare una delle soluzioni seguenti:
Opzione 1: aggiungere ognuno degli URL di Dynamics 365 e degli URL di autenticazione alla stessa area di sicurezza in Internet Explorer
In Internet Explorer scegliere Opzioni Internet dal menu Strumenti.
Fare clic sulla scheda Sicurezza , sull'area Siti attendibili e quindi su Siti.
In Aggiungi questo sito Web alla zona digitare gli URL seguenti uno alla volta:
*.dynamics.com
*.microsoftonline.com
https://login.windows.net
Importante
Se si usa l'autenticazione federata per accedere a Dynamics 365 usando le credenziali aziendali, è anche necessario aggiungere gli URL di autenticazione usati dall'azienda. Ad esempio: se la società usa Active Directory Federation Services (ADFS) con un URL di autenticazione di
https://adfs.contoso.com/...
, aggiungere questo URL alla stessa zona o assicurarsi che entrambe le zone abbiano la stessa impostazione di modalità protetta.Fare clic su Aggiungi, fare clic su Chiudi e quindi su OK.
Fare clic su OK per chiudere la finestra di dialogo Opzioni Internet.
Opzione 2- Abilitare la modalità protetta in ogni area di sicurezza di Internet Explorer
Abilitando la modalità protetta in ogni area di sicurezza di Internet Explorer, ogni URL verrà caricato nello stesso livello di integrità.
- In Internet Explorer scegliere Opzioni Internet dal menu Strumenti.
- Fare clic sulla scheda Sicurezza.
- Selezionare ognuna delle zone (Internet, Intranet locale e Siti attendibili).
- Durante la selezione di ogni zona, verificare che la casella di controllo Abilita modalità protetta sia selezionata.
- Fare clic su OK per chiudere la finestra di dialogo Opzioni Internet.
Ulteriori informazioni
Quando la modalità protetta è abilitata per un'area di sicurezza, gli URL verranno caricati nel livello di integrità basso (più sicuro). Quando la modalità protetta è disabilitata per un'area di sicurezza, gli URL verranno caricati nel livello di integrità medio. Se un URL non viene aggiunto ai siti attendibili o alle zone Intranet locale , per impostazione predefinita verrà caricato nell'area Internet, in cui la modalità protetta è abilitata per impostazione predefinita.