La connessione di test non riesce dal profilo del server Email in Microsoft Dynamics 365
Questo articolo fornisce una soluzione a un problema per cui la connessione di test non riesce dal profilo del server Email in Microsoft Dynamics 365.
Si applica a: Microsoft Dynamics 365 Customer Engagement Online
Numero KB originale: 4493267
Sintomi
Quando si usa l'opzione Test connessione da un profilo server Email in Dynamics 365, il test ha esito negativo e potrebbe essere visualizzato un errore simile all'esempio seguente:
"Errore del server remoto: (401) Non autorizzato. Verificare che il nome utente e la password immessi siano corretti e riprovare." o
"System.Net.WebException: timeout dell'operazione in System.Net.HttpWebRequest.GetResponse()
in Microsoft.Crm.Asynchronous.EmailConnector.ExchangeConnectivityDiscoverer.ValidateServerUrl(EmailDirectionCode emailDirection)"
Causa
Causa 1: Il nome utente o la password non è corretto.
Causa 2: Se si usa Dynamics 365 (online) per connettersi a Exchange locale, questo errore può verificarsi se il firewall non consente la connettività da Dynamics 365 al server Exchange.
Causa 3: In alcuni casi, la connessione di test potrebbe non riuscire anche se le credenziali sono corrette e la connettività non è un problema. Vedere Risoluzione 3 nella sezione Risoluzione.
Risoluzione
Risoluzione 1: Verificare che il nome utente e la password siano corretti.
Nota
Il valore nome utente deve essere in formato UPN (Nome entità utente). Esempio
username@contoso.com
contoso\username
anziché .Risoluzione 2: se si usa Dynamics 365 (online) con Exchange locale, verificare che il firewall consenta la connettività dall'elenco di intervalli IP documentati in Microsoft Dynamics CRM Online intervalli di indirizzi IP, inclusi gli intervalli IP di Azure a cui si fa riferimento.
Risoluzione 3: I risultati della connessione di test non sono sempre affidabili. Se lo stesso nome utente e la stessa password funzionano quando si esegue una connessione di test da Microsoft Remote Connectivity Analyzer, usare l'opzione Test & Abilita cassette postali in Dynamics 365 anziché l'opzione Test connessione. Se il test & abilita ha esito positivo per le cassette postali, è possibile ignorare i risultati della finestra di dialogo Test connessione .
Nota
Se si verificano errori usando il pulsante Test & Abilita cassette postali, vedere la scheda Avvisi all'interno del record della cassetta postale ed esaminare i collegamenti della Guida inclusi.