Non è possibile connettersi al server Microsoft Dynamics 365 quando si usa Microsoft Dynamics 365 App per Outlook
Questo articolo fornisce una risoluzione del problema che non è possibile usare Microsoft Dynamics 365 App for Outlook a causa dell'errore Non è possibile connettersi al server Microsoft Dynamics 365.
Si applica a: Microsoft Dynamics 365
Numero KB originale: 4341413
Sintomi
Quando si tenta di usare Microsoft Dynamics 365 App for Outlook, viene visualizzato il messaggio seguente:
"Non è possibile connettersi al server Microsoft Dynamics 365. Provare a chiudere e riaprire l'app."
Se si seleziona Mostra altro, è possibile che venga visualizzato il messaggio seguente:
"Timeout del caricatore client"
Se si usa l'app in Outlook Web Access (OWA), è possibile che venga visualizzata la richiesta seguente nella parte inferiore della schermata:
"Si vuole consentire
dynamics.com
l'uso di spazio di archiviazione aggiuntivo nel computer?"
Se si cancella la cache del browser Internet Explorer, questo errore potrebbe sembrare risolto ma alla fine restituisce.
Causa
Microsoft è a conoscenza di un problema per cui questo errore può verificarsi perché Internet Explorer è configurato per limitare la quantità di dati che possono essere memorizzati nella cache. Se stai visualizzando l'app con Internet Explorer, questa potrebbe essere la causa dell'errore. Se si verifica questo errore utilizzando Outlook Desktop, Outlook usa sempre Internet Explorer per visualizzare l'app.
Risoluzione
Microsoft sta lavorando a una modifica per evitare questo problema. Nel frattempo, è possibile usare la procedura seguente come potenziale soluzione alternativa:
Opzione 1 - Aumentare il limite di database all'interno delle opzioni di Internet Explorer
A seconda della versione del sistema operativo, è possibile modificare il limite all'interno delle impostazioni di Internet Explorer. Se usi Windows 10, questa opzione non viene visualizzata e puoi invece usare l'opzione 2.
- Aprire Internet Explorer.
- Nell'angolo superiore destro selezionare l'icona a forma di ingranaggio e quindi selezionare Opzioni Internet.
- Nella scheda Generale nella sezione Cronologia esplorazioni selezionare Impostazioni.
- Selezionare la scheda Cache e database .
- Se viene visualizzata un'opzione Invia una notifica quando una cache o un database del sito Web supera l'opzione, modificare il valore su 200 e selezionare OK. In alternativa, è possibile selezionare
dynamics.com
dall'elenco dei siti Web e quindi selezionare Supera limite. Se queste opzioni non vengono visualizzate, continuare con l'opzione 2. - Cancellare la cronologia e la cache di Internet Explorer. Per i passaggi dettagliati, vedere Visualizzare ed eliminare la cronologia di esplorazione in Internet Explorer.
Opzione 2 - Aumentare il limite di database all'interno del Registro di sistema
Importante
Questa sezione contiene i passaggi che illustrano come modificare il Registro di sistema. Se, tuttavia, si modifica il Registro di sistema in modo errato, possono verificarsi gravi problemi. Pertanto, assicurarsi di osservare attentamente la procedura seguente. Per una maggiore protezione, eseguire il backup del Registro di sistema prima di modificarlo. Successivamente, è possibile ripristinare il Registro di sistema se si verifica un problema. Per ulteriori informazioni su come eseguire il backup e il ripristino del Registro di sistema, vedi Come eseguire il backup e il ripristino del Registro di sistema in Windows.
Per aumentare il limite di memorizzazione nella cache consentito, creare la voce del Registro di sistema seguente:
Sottochiave: HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Internet Explorer\BrowserStorage\IndexedDBValue
Nome: MaxTrustedDomainLimitInMB
Digitare: REG_DWORD
Dati: 200
Per creare questa voce del Registro di sistema, seguire questa procedura:
Selezionare Start e quindi Esegui, digitare regedit e premere OK.
Individuare e quindi selezionare la seguente sottochiave del Registro di sistema. Se il percorso di questa posizione non esiste, potrebbe essere necessario creare le chiavi indicate:
HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Internet Explorer\BrowserStorage\IndexedDBValue
Fare clic con il pulsante destro del mouse su IndexedDBValue, scegliere Nuovo e quindi selezionare Valore DWORD.
Nella casella Nuovo valore 1 digitare MaxTrustedDomainLimitInMB e quindi premere INVIO.
Fare clic con il pulsante destro del mouse su MaxTrustedDomainLimitInMB e quindi scegliere Modifica.
Selezionare Decimale, digitare 200 e quindi selezionare OK.
Uscire dall'editor del Registro di sistema e quindi riavviare il computer.
Cancellare la cronologia e la cache di Internet Explorer. Per i passaggi dettagliati, vedere Visualizzare ed eliminare la cronologia di esplorazione in Internet Explorer.
Ulteriori informazioni
Esistono più possibili cause per questo errore. Se il problema non viene risolto, fare riferimento all'articolo seguente per altre soluzioni potenziali: