Condividi tramite


Errore "Non è possibile completare questa azione per questo componente" durante l'importazione di una soluzione

Questo articolo fornisce una risoluzione per l'errore Non è possibile completare questa azione per questo componente a causa della configurazione delle relative proprietà gestite che possono verificarsi durante l'importazione di una soluzione in Microsoft Dynamics 365.

Si applica a: Microsoft Dynamics 365
Numero KB originale: 4464328

Sintomi

Quando si tenta di importare una soluzione in Microsoft Dynamics 365, l'importazione della soluzione non riesce con il messaggio seguente:

Importazione della soluzione: [nome soluzione] non riuscita

Nella finestra di dialogo di errore verrà visualizzato uno stato di errore e nella colonna Dettagli verrà visualizzato il messaggio seguente:

Non è possibile completare questa azione per questo componente a causa della configurazione delle relative proprietà gestite

Se si seleziona Scarica file di log e si visualizza la scheda Componenti in Excel, viene visualizzato un messaggio simile al seguente:

Colonna stato: errore
ErrorCode: 0x8004F026
ErrorText: la valutazione del componente corrente(name=Entity, id=[GUID] nell'operazione corrente (Aggiornamento) non è riuscita durante la valutazione della condizione della proprietà gestita: la valutazione del componente corrente(name=Entity, id=[GUID] nell'operazione corrente (Aggiornamento) non è riuscita durante la valutazione della proprietà gestita della condizione: Nome proprietà gestita: [ManagedPropertyLogicalName]; Nome componente: entità; Nome attributo: [ManagedPropertyLogicalName];

Causa

Microsoft è a conoscenza di un problema a causa del quale questo errore può verificarsi durante l'importazione di una soluzione contenente alcune entità, ad esempio Elenco marketing, SystemUser, Team, CustomerAddress, Posizione, entità TransactionCurrency. Se la soluzione contiene una di queste entità, vedere la sezione Risoluzione di questo articolo.

Questo errore indica che esiste una mancata corrispondenza nelle proprietà gestite per un'entità che si sta tentando di importare con la stessa entità nell'organizzazione di destinazione. La mancata corrispondenza tra l'attributo dell'entità di destinazione e l'attributo dell'entità di origine può essere correlata alla versione dell'organizzazione di origine che è una versione precedente rispetto all'organizzazione di destinazione (ad esempio da 8.2 a 9.0). Se un aggiornamento di sistema è stato eseguito nell'organizzazione di destinazione e ha aggiornato un attributo di entità gestita, la soluzione avrà esito negativo se contiene una definizione diversa dell'attributo per questa entità.

Esempio: in Microsoft Dynamics 365 versione 8.2 viene creata un'entità personalizzata con una relazione con l'entità Marketing List. In Microsoft Dynamics 365 versione 9.0 è stato applicato un aggiornamento di sistema per modificare l'attributo gestito dell'entità Marketing List per renderlo visibile nell'app per dispositivi mobili Microsoft Dynamics 365 (nome: IsVisibleInMobileClient, nome logico: canmodifymobileclientvisibility) su true. Una soluzione gestita viene esportata dall'organizzazione 8.2 contenente l'entità personalizzata e per impostazione predefinita la definizione dell'entità Elenco marketing viene inclusa come dipendenza nella soluzione. Quando la soluzione gestita viene importata nell'organizzazione di Microsoft Dynamics CRM 9.0, esiste una mancata corrispondenza della definizione dell'attributo. Poiché l'entità nell'organizzazione di destinazione è gestita e l'attributo gestito non è aggiornabile e da un server di pubblicazione diverso, non può essere modificato nella versione nella soluzione e viene visualizzato l'errore.

Risoluzione

Microsoft sta rilasciando una correzione per questo problema per le entità indicate nella sezione Causa. Se una di queste entità fa parte della soluzione, è possibile usare una soluzione alternativa nel frattempo. Il file della soluzione può essere modificato per modificare il valore dell'attributo dell'entità dell'organizzazione di origine in modo che corrisponda all'attributo dell'entità dell'organizzazione di destinazione.

Note

Questa risoluzione funzionerà solo per l'importazione di questa soluzione. Se la soluzione viene esportata nuovamente dall'organizzazione di origine, questa modifica dovrà essere completata di nuovo. Deve trattarsi di una risoluzione temporanea fino al rilascio della correzione.

  1. Decomprimere il file della soluzione.

  2. Aprire il file customizations.xml in un editor di testo

  3. Cercare LogicalCollectionName ,ad esempio elenchi, team e così via.

    <EntitySetName>lists</EntitySetName>

  4. Scorrere verso il basso e trovare il nome dell'attributo menzionato nel messaggio di errore. Per l'entità Marketing List, l'attributo sarà probabilmente IsVisibleInMobileClient. Per le altre entità indicate nella sezione Causa, il campo sarà IsReadOnlyInMobileClient.

    <IsVisibleInMobileClient>0</IsVisibleInMobileClient>

  5. Modificare il valore sull'opposto dell'impostazione corrente (ad esempio: da 0 a 1.

    <IsVisibleInMobileClient>1</IsVisibleInMobileClient>

  6. Comprimere tutti i file in una nuova soluzione modificata e usare questa soluzione per l'importazione.

Ulteriori informazioni

L'entità nell'organizzazione di destinazione con la mancata corrispondenza viene identificata nella finestra di dialogo di errore. Per recuperare i valori dell'attributo [ManagedPropertyLogicalName] non corrispondenti, usare l'API Web per recuperare l'entità identificata dal GUID:

  1. Aprire un Web browser per accedere all'applicazione Web Microsoft Dynamics 365 per l'organizzazione di destinazione in cui si sta tentando di importare la soluzione.

  2. Duplicare la scheda (fare clic con il pulsante destro del mouse e quindi selezionare Duplica) in modo da poter usare la sessione del browser autenticata.

  3. Nella nuova scheda eseguire il comando seguente sostituendo [GUID] con il valore GUID dei dettagli dell'errore e sostituendo [organizationURL] con l'URL per l'organizzazione: https://[organizationURL]/api/data/v8.2/EntityDefinitions([GUID])

  4. Cercare nell'output la stringa in [ManagedPropertyLogicalName].

  5. Eseguire la stessa procedura nell'organizzazione di origine e confrontare i valori dell'attributo indicato nel messaggio di errore.

Esempio:

Messaggio di errore:

Valutazione del componente corrente(name=Entity, id=efd3a52d-04ca-4d36-a54c-2a26a64f5571) nell'operazione corrente (aggiornamento) non riuscita durante la valutazione della condizione della proprietà gestita: valutazione del componente corrente(name=Entity, id=efd3a52d-04ca-4d36-a54c-2a26a64f5571) nell'operazione corrente (Aggiornamento) non riuscita durante la valutazione della proprietà gestita della condizione: Nome proprietà gestita: canmodifymobileclientvisibility; Nome componente: entità; Nome attributo: canmodifymobileclientvisibility;

Quando si usa la query https://[organizationURL]/api/data/v8.2/EntityDefinitions(efd3a52d-04ca-4d36-a54c-2a26a64f5571), le entità DisplayName sono Marketing List:

 "DisplayName":{
 "LocalizedLabels": [
 {
 "Label": "Marketing List",
 "LanguageCode": 1033,
 "IsManaged": true,
 "MetadataId": "<ID>",
 "HasChanged": null
 }
 ],
 The entities LogicalName is "list":
 "LogicalName": "list",
 And the entitiesLogicalCollectionName is "lists"
 "LogicalCollectionName": "lists",
 t.