Condividi tramite


Messaggio di errore se si tenta di modificare la password quando si accede a Microsoft Dynamics GP 9.0: "La modifica della password non è riuscita per un motivo sconosciuto. Immettere una password diversa o contattare l'amministratore di sistema"

Questo articolo fornisce una soluzione a un errore che si verifica quando si modifica la password quando si accede a Microsoft Dynamics GP.

Si applica a: Microsoft Dynamics GP
Numero KB originale: 913823

Sintomi

Si consideri il seguente scenario. Usare la funzionalità Imponi modifica password in Microsoft Dynamics GP 9.0. Si tenta di modificare la password quando si accede a Microsoft Dynamics GP 10.0 o a Microsoft Dynamics GP 9.0. In questo scenario è possibile che venga visualizzato il messaggio di errore seguente:

La modifica della password non è riuscita per un motivo sconosciuto. Immettere una password diversa o contattare l'amministratore di sistema

Causa

Questo problema si verifica perché non si usa una connessione ODBC (Open Database Connectivity). È necessario configurare la connessione ODBC usando il driver SQL Native Client per Microsoft SQL Server 2005.

Risoluzione

Per risolvere questo problema, usare il driver SQL Native Client per configurare una nuova connessione ODBC.

Per ottenere il driver SQL Native Client, usare uno dei metodi seguenti:

  • Scarica *SQL Native Client*.
  • Eseguire il programma Sqlncli.msi dal CD di Microsoft SQL Server 2005.

Ulteriori informazioni

La funzionalità Applica modifica password funziona solo in Microsoft Dynamics GP 9.0 quando sono soddisfatte le condizioni seguenti:

  • Si è in un dominio di Microsoft Windows Server 2003.
  • Si usa SQL Server 2005.

Se non si usa questa funzionalità password, non è necessario installare il driver SQL Native Client per connettersi ai database di Microsoft Dynamics GP 9.0.

Riferimenti