Condividi tramite


L'interfaccia di amministrazione di Exchange è lenta nel visualizzare i destinatari se la trascrizione di PowerShell è attivata

Numero KB originale: 4505746

Sintomi

Nell'interfaccia di amministrazione di Exchange potrebbe essere necessario alcuni minuti per visualizzare l'elenco Destinatari se contiene un numero elevato di cassette postali o gruppi.

Motivo

Il problema è causato da una latenza che si verifica quando viene eseguita la trascrizione di PowerShell. Quando la trascrizione di PowerShell registra un cmdlet eseguito, invia l'output del comando a un file di testo nel file system. La latenza è causata dall'I/O necessaria per completare questi passaggi ed è più evidente quando il numero di cassette postali o gruppi è elevato.

Risoluzione

Per risolvere questo problema, è possibile disabilitare la trascrizione di PowerShell. Per fare questo, segui questi passaggi:

  1. Aprire una finestra del Prompt dei Comandi o PowerShell, e quindi digitare gpedit.msc per aprire l'Editor Criteri di gruppo locali.

  2. Passare a Configurazione computer e selezionare Modelli amministrativi.

  3. Selezionare Componenti di Windows e quindi Windows PowerShell.

  4. Fare doppio clic su Attiva trascrizione di PowerShell, selezionare Disabilita, quindi selezionare OK.

    Screenshot della selezione di Disabilitato per attivare la finestra di registrazione di PowerShell.

  5. Al prompt dei comandi eseguire gpupdate /force per assicurarsi che le impostazioni siano applicate.

Maggiori informazioni

Se la trascrizione di PowerShell è abilitata e la registrazione dei comandi è visibile in EAC, viene visualizzato Out-Default -Transcript:$true -OutVariable $null dopo ogni cmdlet che viene chiamato da EAC.

Potrebbero esserci altri motivi per cui è necessario analizzare le prestazioni lente se questa soluzione non risolve il problema.