Nota
L'accesso a questa pagina richiede l'autorizzazione. È possibile provare ad accedere o modificare le directory.
L'accesso a questa pagina richiede l'autorizzazione. È possibile provare a modificare le directory.
Sintomi
Si usa l'API REST di Microsoft Graph per richiedere tutti i calendari da una cassetta postale utente in Exchange Online. La risposta restituisce il codice 200 OKdi stato HTTP, ma l'elenco di calendari nel corpo della risposta omette il calendario predefinito (denominato "Calendario"). Se la cassetta postale contiene calendari non predefiniti, vengono elencati solo quelli.
Motivo
Il problema si verifica perché la cache dell'oggetto calendario nella cassetta postale è danneggiata.
Risoluzione
Annotazioni
Per usare la procedura seguente, è necessario essere l'utente cloud o disporre delle autorizzazioni di accesso completo per la cassetta postale cloud. Eseguire la procedura in un computer basato su Microsoft Windows in cui è installato il client desktop di Outlook e un profilo di Outlook per la cassetta postale.
Per risolvere il problema, rimuovere e ricreare la cache degli oggetti del calendario nella cassetta postale. Segui questi passaggi:
In Microsoft Outlook selezionare File>Office account>About Outlook (Informazioni su Outlook ) per determinare se il client desktop è la versione a 32 bit o a 64 bit .
Scaricare ed estrarre la versione più recente a 32 bit o a 64 bit di MFCMAPI in modo che corrisponda al livello di bit dell'installazione di Outlook.
Importante
Anche se l'editor MFCMAPI è supportato, prestare attenzione quando viene usato per modificare le impostazioni della cassetta postale. L'uso errato dell'editor MFCMAPI può danneggiare definitivamente una cassetta postale.
Chiudere Outlook (e Outlook sul Web, se è aperto) e quindi eseguire MFCMapi.exe. Se viene visualizzata la schermata di avvio MFCMAPI, chiuderla.
Selezionare Opzioni strumenti> per aprire la finestra Opzioni.
Selezionare entrambe le opzioni seguenti e quindi selezionare OK:
Usare il flag MDB_ONLINE quando si chiama OpenMsgStore
"Usare il flag MAPI_NO_CACHE quando si chiama OpenEntry"
Selezionare Sessione>Logon per aprire la finestra Scegli profilo.
Selezionare il nome del profilo di Outlook per la cassetta postale e quindi selezionare OK.
Fare doppio clic sulla cassetta postale applicabile nella colonna Nome visualizzato per aprirla.
Nel riquadro sinistro, vai su Root Container>Common Views.
Fare clic con il pulsante destro del mouse su Visualizzazioni comuni e quindi scegliere Apri tabella sommario associata.
Per ogni voce di tabella con il valore
Calendarnella colonna Oggetto , eseguire il backup della cache degli oggetti del calendario:Fare clic con il pulsante destro del mouse sulla voce e quindi scegliere Esporta messaggio per aprire la finestra di dialogo Salva messaggio in file .
Selezionare OK per aprire la finestra di dialogo Salva con nome .
Scegliere una cartella di backup e quindi selezionare Salva.
Per ogni voce di tabella con il valore
Calendarnella colonna Oggetto , rimuovere la cache degli oggetti del calendario:Fare clic con il pulsante destro del mouse sulla voce e quindi scegliere Elimina messaggio per aprire la finestra di dialogo Elimina elemento .
Seleziona OK.
Dopo aver completato questo passaggio, verificare che nella colonna Subject non siano presenti voci di tabella con il valore
Calendar.Aprire Outlook sul Web, accedere alla cassetta postale applicabile e quindi visualizzare il calendario predefinito. Questo passaggio ricrea la cache degli oggetti del calendario nella cassetta postale.
In MFCMAPI verificare che una o più voci di tabella abbiano il valore
Calendarnella colonna Subject .Chiudere tutte le finestre MFCMAPI per uscire dall'applicazione.
Attendere cinque minuti prima che la cache degli oggetti del calendario venga aggiornata completamente nella cassetta postale e quindi ripetere la richiesta di calendario.