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Il proprietario non può creare cartelle pubbliche moderne utilizzando Outlook in Exchange Server 2013 o Exchange Server 2016

Sintomi

Si supponga di essere il proprietario di una cassetta postale di cartelle pubbliche o di disporre di autorizzazioni di accesso sufficienti per creare una cartella pubblica in un ambiente Microsoft Exchange Server 2013 o Microsoft Exchange Server 2016. La cassetta postale usa la gerarchia secondaria come cassetta postale di cartelle pubbliche predefinita. In questo caso, quando si tenta di creare una cartella pubblica utilizzando Microsoft Outlook, viene visualizzato il messaggio di errore seguente:

Impossibile creare la cartella. Non si dispone di autorizzazioni sufficienti per eseguire questa operazione su questo oggetto. Consultare i contatti della cartella o l'amministratore di sistema.

Annotazioni

Se la cassetta postale della cartella pubblica predefinita viene modificata in una cassetta postale di cartelle pubbliche contenente la gerarchia primaria, è possibile creare cartelle pubbliche utilizzando Outlook.

Vedere Altre informazioni su come risolvere il problema in questo articolo.

Motivo

Questo problema si verifica perché la LmCompatibilityLevel voce del Registro di sistema nel ruolo Server cassette postali di Exchange Server è configurata su un valore minore di 2.

Soluzione

Importante

Seguire attentamente i passaggi in questa sezione. Se le modifiche al Registro di sistema vengono apportate in modo non corretto, possono verificarsi problemi gravi. Prima di apportare le modifiche, eseguire il backup del Registro di sistema per il ripristino nel caso si verifichino dei problemi.

Per risolvere questo problema, seguire questa procedura nel ruolo del Server delle cassette postali di Exchange che ospita la cassetta postale della gerarchia secondaria delle cartelle pubbliche:

  1. Cambiare il valore della voce del LmCompatibilityLevel Registro di sistema a 2 o superiore.

    Annotazioni

    La voce si trova nel percorso del registro riportato di seguito:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

  2. Riavviare i seguenti servizi:

    • Archivio informazioni di Microsoft Exchange
    • Accesso client RPC di Microsoft Exchange
    • Microsoft Exchange Health Manager

Maggiori informazioni

Per altre informazioni sull'impostazione LmCompatibilityLevel, vedere gli articoli seguenti:

Informazioni generali sulla voce del Registro di sistema LmCompatibilityLevel

Controllo di sicurezza: l'impostazione di sicurezza di Windows più incomprensibile di tutti i tempi

Altre informazioni per risolvere il problema

Quando si verifica questo problema, diverso dal messaggio di errore, è anche possibile trovare le informazioni seguenti che possono aiutare a risolvere questo problema.

  • Il messaggio seguente viene registrato nel log "Accesso client RPC" nel Visualizzatore eventi:

    Client=MSExchangeRPC,,,,-2147024891 (rop::AccessDenied),00:00:00.0310000,,"RopHandler:
    CreateFolder: [AccessDeniedException] Cannot open mailbox /o=Contoso/ou=Exchange Administrative Group
    (FYDIBOHF23SPDLT)/cn=Recipients/cn=9f049c7972fb4d8ebe9f5ece73e136fe-PFHierarchy. ->
    [MapiExceptionNoAccess] Unable to make connection to the server. (hr=0x80070005, ec=-2147024891)
    [diag::AAAGAgAA/wAAAAAAAAAAA/gBAACYMvAvAQAAACwQAsAAAAAA6PIAEHA5FpCYP/AvBQAAAG4vYQBwORaQmCHwH/Q1AACYMfAvcDkWkAk00AEsEALAmCnwHw0AAACYOfAfLBACwJgl8B95BQAAmDXwHwAAAACYLfAfAAAAAOjyABBwORaQmD/wLwUAAABuL2EAcDkWkJgh8B/0NQAAmDHwL3A5FpAJNNABkQEAAJgp8B8NAAAAmDnwH5EBAACYJfAfiQUAAJg18B8AAAAAmC3wHwEAAACYIvA/AAAAAFVuYXV0aG9yaXplZAAAAADo8gAQcDkWkJg/8C8FAAAAbi9hAHA5FpCYIfAf9DUAAJgx8C9wORaQCTTQAQAAAACYKfAfDQAAAJg58B8AAAAAmCXwH+ELAACYNfAfAAAAAJgt8B8AAAAA6PIAEHA5FpCYP/AvBQAAAG4vYQBwORaQmCHwH/Q1AACYMfAvcDkWkAk00AHhCwAAmCnwHw0AAACYOfAfAAAAAJgl8B/hCwAAmDXwHwAAAACYLfAfAAAAAHHoQBAFAAeAcMVAIQAPFIQZAPAvBQAAAHDLQBAFAAeA0McAEPQ1AADxzEAQBQAHgKHqABAFAAAA8YNAEAUAB4Cd6QAQBQAAAAfNQBAFAAeAQk0AEAAAAABCbUAQBQAHgEJFABAAAAAAQmVAEAUAB4A=] 
    at M.E.D.S.RPCPrimaryHierarchyProvider.GetHierarchyStore() 
    at M.E.D.S.RPCPrimaryHierarchyProvider.CreateFolder(String folderName, String folderDescription, StoreId parentFolderId, CreateMode mode, Guid& contentMailboxGuid) 
     at M.E.R.H.PublicFolderOperations.<>c__DisplayClass1.<CreateFolder>b__0(StoreId& folderIdToSync, Guid& contentMailboxGuid) 
    at M.E.R.H.PublicFolderOperations.InvokeOnPrimaryHierarchyAndSync[T](Boolean isCompleteSync, PublicLogon publicLogon, PrimaryHierarchy",,,admin@contoso.com,
    
  • Se si esegue il comando Get-ServerHealth -Identity ServerIdParameter -HealthSet "Outlook.Protocol" in Exchange Management Shell (EMS), il set di integrità Outlook.Protocol segnala problemi di integrità, in particolare per i seguenti monitor correlati alla chiamata di routine remota di Outlook (RPC):

    • OutlookRpcDeepTestMonitor
    • OutlookRpcSelfTestMonitor
  • L'errore del probe OutlookRpcDeepTestProbe registra il messaggio seguente:

    Microsoft.Exchange.Rpc.RpcException: Error 0x5 (Access is denied) from ClientAsyncCallState.CheckCompletion: RpcAsyncCompleteCall