Condividi tramite


Errore in Outlook Web App dopo un aggiornamento a Exchange Server 2013 CU 11 o versione successiva: La richiesta non può essere completata al momento

Numero KB originale: 3191636

Sintomi

In un ambiente Microsoft Exchange Server 2013 aggiornato all'aggiornamento cumulativo (CU) 11 o versione successiva, si verificano uno o più dei sintomi seguenti in Outlook Web App (OWA):

  • Ricevi un messaggio di errore "Non è possibile completare la richiesta in questo momento. Riprovare più tardi" quando tenti di aprire, rispondere o inoltrare elementi in Outlook Web App.
  • Quando si tenta di accedere a Outlook Web App o selezionare cartelle diverse, viene visualizzato anche questo errore.

Inoltre, l'evento seguente viene registrato ripetutamente nel registro applicazioni di Windows:

Time:     7/05/2016 2:20:24 PM
ID:       4999
Level:    Error
Source: MSExchange Common
Machine:  MBX1.contoso.com
Message:  Watson report about to be sent for process id: 10472, with parameters: E12IIS, c-RTL-AMD64, 15.00.1178.004, w3wp#MSExchangeOWAAppPool, m.exchange.services, M.E.S.C.T.IdConverter.ConvertId, System.MissingMethodException, a16f, 15.00.1104.003.
ErrorReportingEnabled: False

Motivo

Quando viene applicato un aggiornamento cumulativo, i bit di installazione per qualsiasi aggiornamento cumulativo precedente esistono nella sottodirectory Bin della directory di installazione di Exchange. Ad esempio: in C:\Programmi\Microsoft\Exchange Server\V15\Bin\Setup.

Quando si esegue il processo di installazione in questo scenario, il file SharedWebConfig.config che si trova in C:\Programmi\Microsoft\Exchange Server\V15\ClientAccess (ruolo Cassetta postale) o C:\Programmi\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy (ruolo Accesso client) punta a C:\Programmi\Microsoft\Exchange Server\V15\Bin\Setup. Questi file non vengono aggiornati dal processo di installazione.

Risoluzione

Per risolvere il problema, seguire questa procedura per rimuovere i file da C:\Programmi\Microsoft\Exchange Server\V15\Bin\Setup e aggiornare i file SharedWebConfig.config in modo che puntino ai percorsi corretti:

  1. Al prompt dei comandi con privilegi elevati eseguire il comando seguente per arrestare i servizi IIS per consentire l'accesso ai file:

    iisreset /stop
    
  2. Spostare la cartella C:\Programmi\Microsoft\Exchange Server\V15\Bin\Setup in un'altra directory all'esterno del percorso di installazione di Exchange. Ad esempio, spostarlo in C:\TEMP\Setup.

  3. Eseguire una copia di backup del file SharedWebConfig.config in C:\Programmi\Microsoft\Exchange Server\V15\ClientAccess e C:\Programmi\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy in un percorso alternativo.

  4. Al prompt dei comandi con privilegi elevati eseguire cd %ExchangeInstallPath%\bin per passare alla directory corretta. Eseguire quindi il comando seguente per ricompilare il file SharedWebConfig.config in C:\Programmi\Microsoft\Exchange Server\V15\ClientAccess:

    DependentAssemblyGenerator.exe -exchangePath "%ExchangeInstallPath%\bin" -exchangePath "%ExchangeInstallPath%\ClientAccess" -configFile "%ExchangeInstallPath%\ClientAccess\SharedWebConfig.config"
    
  5. Al prompt dei comandi con privilegi elevati eseguire il comando seguente per ricompilare il file SharedWebConfig.config in C:\Programmi\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy:

    DependentAssemblyGenerator.exe -exchangePath "%ExchangeInstallPath%\bin" -exchangePath "%ExchangeInstallPath%\FrontEnd\HttpProxy" -configFile "%ExchangeInstallPath%\FrontEnd\HttpProxy\SharedWebConfig.config"
    
  6. Al prompt dei comandi con privilegi elevati eseguire il comando seguente per riavviare i servizi IIS:

    iisreset /start