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Risolvere i problemi di accesso condizionale per i dispositivi Android di Teams

Sintomi

L'accesso condizionale è una funzionalità di Microsoft Entra che consente di assicurarsi che i dispositivi che accedono alle risorse aziendali siano gestiti e protetti correttamente. Se i criteri di accesso condizionale vengono applicati al servizio Microsoft Teams, i dispositivi Android che accedono a Teams devono essere conformi ai criteri. Tali dispositivi includono telefoni Teams, visualizzazioni di Teams, pannelli di Teams e Teams Rooms nei dispositivi Android. In caso contrario, l'accesso condizionale impedisce agli utenti di accedere o usare l'app Teams nei dispositivi.

Se questi criteri vengono applicati, è possibile che si verifichino uno o più dei problemi seguenti nei dispositivi non conformi:

  • I dispositivi non possono accedere a Teams o si bloccano nei cicli di accesso.
  • I dispositivi si disconnetteno automaticamente da Teams in modo casuale.
  • Microsoft Teams smette di rispondere (blocca).

Motivo

Questi problemi possono verificarsi per i motivi seguenti:

  • Criteri di accesso condizionale non supportati o impostazioni dei criteri di conformità dei dispositivi di Intune

    Se un dispositivo è contrassegnato come non conforme, il servizio di emissione dei token di Microsoft Entra smette di rinnovare i token per l'oggetto dispositivo o anche revoca il token. In questo caso, il dispositivo non riesce a ottenere un token di autenticazione aggiornato ed è costretto a disconnettersi.

    Per controllare lo stato di conformità dei dispositivi, usare il dashboard conformità dei dispositivi di Intune.

  • Impostazione della Frequenza di accesso

    Questa impostazione forza la riautenticazione periodica. Questa azione potrebbe causare la disconnessione casuale dei dispositivi, a seconda di quanti dei suoi criteri di accesso condizionale sono impostati su frequenze di accesso diverse. Ogni volta che si verifica la riautenticazione, il token viene revocato e viene creato un nuovo oggetto dispositivo con l'account utente. Se il numero di oggetti dispositivo supera il limite di dispositivi Microsoft Entra o il limite di dispositivi di Intune, l'utente non può accedere al dispositivo.

  • Condizioni per l'utilizzo (ToU) e criteri di accesso condizionale MFA, se vengono usati entrambi

    Per altre informazioni, vedere Problemi noti con i telefoni teams.

Risoluzione

Quando si risolvono i problemi di accesso condizionale, iniziare controllando i dettagli di accesso dell'utente interessato. Verificare che il dispositivo soddisfi i requisiti dei criteri. Questi controlli possono essere eseguiti tramite strumenti automatizzati o manualmente, come descritto nelle sezioni seguenti.

Quando i dispositivi Android di Microsoft Teams passano alla gestione dei dispositivi AOSP di Intune, gli amministratori possono sfruttare i vantaggi degli attributi dei dispositivi (ad esempio device.displayName) nei filtri di accesso condizionale. Questa procedura consente di specificare i criteri in modo più preciso, in base al modo in cui vengono denominati i dispositivi.

L'attributo device.displayName è particolarmente utile perché include le informazioni sul produttore del dispositivo all'inizio del processo di accesso, anche prima che Intune completi la registrazione completa. Al termine della registrazione del dispositivo, Intune segnala anche proprietà aggiuntive, come il nome visualizzato aggiornato, la marca, il modello e lo stato di conformità, a Microsoft Entra. Poiché questa segnalazione può richiedere tempo, l'uso displayName delle regole di filtro consente di assicurarsi che i dispositivi corrispondano correttamente all'inizio del processo.

Controlli automatizzati

Per usare l'opzione automatica, eseguire il test di connettività di Accedi a Microsoft Teams Rooms nello strumento Microsoft Remote Connectivity Analyzer. Questo strumento consente di risolvere i problemi di connettività che interessano Teams. Il test di connettività esegue controlli per verificare le autorizzazioni di un utente specifico per accedere a Teams usando un dispositivo Teams Rooms.

Annotazioni

  • Per eseguire il test di connettività di accesso di Microsoft Teams Rooms è necessario un account amministratore globale.
  • Lo strumento Microsoft Remote Connectivity Analyzer non è disponibile per gli ambienti GCC e GCC High Microsoft 365 Government.

Per eseguire il test di connettività, seguire questa procedura:

  1. In un browser web, passare al test di connettività di Microsoft Teams Rooms Sign in.
  2. Accedere usando le credenziali di un account amministratore globale.
  3. Specificare il nome utente per l'account che non può accedere all'app Teams Rooms.
  4. Nel campo Selezione dispositivo selezionare un tipo per il dispositivo dell'utente interessato.
  5. Immettere il codice di verifica visualizzato, quindi selezionare Verifica.
  6. Selezionare la casella di controllo per accettare i termini del contratto, quindi selezionare Esegui test.

Al termine del test, nella schermata vengono visualizzati i dettagli relativi a tutti i controlli eseguiti e se il test è riuscito, non è riuscito o ha avuto esito positivo ma visualizza alcuni avvisi. Per altre informazioni sugli avvisi e sugli errori e su come risolverli, selezionare il collegamento fornito.

Controlli manuali

Per controllare manualmente l'accesso utente all'app Teams, seguire questa procedura:

  1. Vai ai log di accesso nel portale di Azure.

  2. Selezionare la scheda Accessi utente (non interattivo).

  3. Selezionare Aggiungi filtri per aggiungere i filtri seguenti:

    • Stato: selezionare Errore e quindi selezionare Applica.
    • Applicazione: immettere Teams e quindi selezionare Applica.

    I filtri Stato e Applicazione sono disponibili per eseguire un controllo manuale sull'accesso utente all'app Teams.

  4. Per i nomi utente interessati, cercare gli elementi con i valori dell'applicazione seguenti:

    • Microsoft Teams
    • Servizio Microsoft Teams
    • Microsoft Teams - Agente di amministrazione del dispositivo
  5. Selezionare ogni elemento per visualizzare i dettagli sull'accesso non riuscito. In genere, è possibile ottenere altre informazioni dai campi seguenti nella scheda Informazioni di base :

    • Codice errore di accesso
    • Motivo dell'errore
    • Dettagli aggiuntivi

    La pagina Informazioni di base della pagina di accesso mostra i dettagli dell'attività.

  6. Se il codice di errore di accesso sembri correlato alla conformità, selezionare la scheda Accesso condizionale e poi cerca i criteri che mostrano un risultato di fallimento.

    La pagina Accesso condizionale dei dettagli dell'attività di accesso mostra i risultati di conformità dei criteri.

  7. Esaminare i dettagli dei criteri.

    La pagina dei dettagli dei criteri di accesso condizionale mostra i dettagli dell'errore di conformità per ogni criterio.

Dopo aver identificato i criteri di accesso condizionale specifici che causano il problema, è possibile usare i filtri dei dispositivi per escludere il dispositivo interessato dai criteri. Alcune delle proprietà dei dispositivi comunemente usate nei filtri dei dispositivi sono produttore e modello. Queste proprietà vengono usate insieme agli operatori Contains, StartsWith e In .

Annotazioni

  • I filtri dei dispositivi si applicano solo agli oggetti dispositivo, non agli account utente.
  • Alcuni attributi, ad esempio modello e produttore, possono essere impostati solo se i dispositivi sono registrati in Intune. Se i dispositivi non sono registrati in Intune, usare gli attributi dell'estensione.
  • Verificare le impostazioni dei criteri per identificare quelle non supportate sui dispositivi Teams.

Lo screenshot seguente mostra un filtro del dispositivo di esempio.

Esempio di filtro del dispositivo per un oggetto dispositivo.

Riferimenti