Nota
L'accesso a questa pagina richiede l'autorizzazione. È possibile provare ad accedere o modificare le directory.
L'accesso a questa pagina richiede l'autorizzazione. È possibile provare a modificare le directory.
Numero KB originale: 3115602
Sintomi
Quando si tenta di accedere alle cartelle in una cassetta postale secondaria di Microsoft Exchange Server aggiunta al profilo di Microsoft Outlook, è possibile che si verifichino problemi di prestazioni casuali. Ad esempio, è possibile che si verifichino i sintomi seguenti:
Quando si visualizzano gli elementi nella cassetta postale secondaria, i nuovi elementi potrebbero non essere visualizzati o gli elementi sembrano mancanti.
Gli elementi eliminati vengono comunque visualizzati nella cassetta postale secondaria.
Rallentamento delle prestazioni di Outlook o blocchi casuali.
In un server che esegue Microsoft Exchange Server, viene registrato un evento simile all'evento seguente nel registro applicazioni:
Event Type: Error Event Source: MSExchangeIS Event Category: General Event ID: 9646 Description: Closing Mapi session "/o=Organization/ou=Administrative Group/cn=Recipients/cn=recipient" because it exceeded the maximum of 500 objects of type "objtFolder".
Inoltre, è possibile trovare errori simili ai seguenti nei messaggi del log di sincronizzazione nella cartella Problemi di sincronizzazione di Outlook:
13:22:28 Synchronizer Version 12.0.6529
13:22:28 Synchronizing Mailbox 'TeamShared'
13:22:28 Synchronizing Hierarchy
13:22:28 Error Synchronizing Hierarchy for Mailbox 'TeamShared'
13:22:28 [80040305-54A-4DE-1900]
13:22:28 Your server administrator has limited the number of items you can open simultaneously. Try closing messages you have opened or removing attachments and images from unsent messages you are composing.
13:22:28 Microsoft Exchange Information Store
13:22:28 For more information on this failure, click the URL below:
13:22:28 http://www.microsoft.com/support/prodredirect/outlook2000_us.asp?err=80040305-54a-4de-1900
13:22:28 Error synchronizing folder
13:22:31 Synchronizing local changes in folder 'TeamShared - Level1'
13:22:31 Error synchronizing folder
13:22:31 [80040305-54A-4DE-421]
13:22:31 Your server administrator has limited the number of items you can open simultaneously. Try closing messages you have opened or removing attachments and images from unsent messages you are composing.
13:22:31 Microsoft Exchange Information Store
13:22:31 For more information on this failure, click the URL below:
13:22:31 http://www.microsoft.com/support/prodredirect/outlook2000_us.asp?err=80040305-54a-4de-421 When this issue occurred, the following synchronization error numbers have also been seen in synchronization messages in the Sync Issues folder:80040305-54A-4DE-822
80004005-501-0-1380
Annotazioni
È necessario selezionare il modulo Elenco cartelle nel riquadro di spostamento per visualizzare la cartella Problemi di sincronizzazione nella cassetta postale.
Motivo
Questo problema può verificarsi se le condizioni seguenti sono vere:
La cassetta postale secondaria a cui si sta tentando di accedere viene aggiunta al profilo di Outlook in modo che venga visualizzata nel riquadro di spostamento.
Annotazioni
È possibile aggiungere manualmente le cassette postali secondarie al profilo tramite la scheda Avanzate nella finestra di dialogo di Microsoft Exchange oppure automaticamente utilizzando la funzionalità "Mapping automatico" in Exchange.
Questa cassetta postale secondaria contiene molte cartelle.
Il profilo è configurato in modalità cache.
L'opzione predefinita Scarica cartelle condivise è abilitata nel profilo.
Questo problema si verifica perché Outlook 2010 e versioni successive memorizzano nella cache locale (nel file di dati di Outlook [.ost]) tutte le cartelle a cui si ha accesso nella cassetta postale secondaria. Si tratta di una modifica rispetto alle versioni precedenti di Outlook. Outlook 2003 non memorizza nella cache le cartelle condivise. Per impostazione predefinita, Outlook 2007 memorizza nella cache solo le cartelle condivise che non contengono messaggi di posta elettronica, ad esempio Calendario, Contatti e Attività.
Annotazioni
In Outlook 2007, questo problema è più probabile che si verifichi se nel client Outlook sono configurati anche i seguenti dati del Registro di sistema.
Sottochiave:
HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\Cached Mode
oppure
HKEY_CURRENT_USER\Software\Policies \Microsoft\Office\12.0\Outlook\Modalità memorizzata nella cache
DWORD: CacheOthersMail
Valore: 1
Risoluzione
Per Outlook di Office 365
Rimuovere la limitazione delle 500 cartelle condivise in Outlook
La sincronizzazione delle cartelle condivise è migliorata in modo che Outlook non incontrerà più la limitazione di 500 cartelle condivise e Outlook dovrebbe essere in grado di contenere fino a 5.000 cartelle condivise. Il nuovo limite funzionale varia in base alle risorse e alla configurazione di sistema disponibili di Outlook. Queste modifiche sono state rilasciate al Canale mensile mirato di Office con la versione 1904 e al Canale mensile di Office con la versione 1905 (Build 11629.20196) e versioni successive. E sono inclusi nelle versioni del Semi-Annual Channel secondo la normale pianificazione del Semi-Annual Channel (settembre 2019 per Semi-Annual Channel (mirato) e gennaio 2020 per la versione generale). Per altre informazioni, vedere Lifting the 500 Folder Limit in Outlook.
Per Outlook 2019, Outlook 2016, Outlook 2013, Outlook 2010 e Outlook 2007
Per risolvere il problema, utilizzare uno dei metodi seguenti.
Importante
Questa sezione, metodo o attività contiene passaggi che ti spiegano come modificare il registro. Tuttavia, potrebbero verificarsi gravi problemi se si modifica il registro in modo errato. Pertanto, assicurati che segui questi passaggi con attenzione. Al fine di protezione, eseguire il backup del registro di sistema prima di modificarlo, in modo da poterlo ripristinare in caso di problemi. Per ulteriori informazioni su come eseguire il backup e ripristinare il registro, consulta Come eseguire il backup e ripristinare il registro in Windows.
Metodo 1: Ridurre il numero di cartelle nella cassetta postale condivisa
La soluzione migliore per questo problema consiste nel ridurre il numero di cartelle di posta nella cassetta postale condivisa, soprattutto se le cassette postali si trovano nell'ambiente di Office 365. Altri metodi 2 e 3 in questo articolo consigliano di disattivare la memorizzazione nella cache delle cartelle di posta o di tutte le cartelle nella cassetta postale condivisa. Queste soluzioni funzionano, ma è consigliabile mantenere la memorizzazione nella cache abilitata per le cassette postali di Office 365 e quelle su una rete lenta. Per maggiori informazioni, consultare l'articolo seguente:
Procedure consigliate per l'uso di Office 365 in una rete lenta
Metodo 2: Disabilitare la memorizzazione nella cache di tutte le cartelle condivise
Outlook 2010 e versioni successive
Per disabilitare la memorizzazione nella cache di tutte le cartelle condivise in Outlook 2010 e versioni successive, seguire questa procedura:
Nella scheda File selezionare Impostazioni account nell'elenco Impostazioni account .
Nella finestra di dialogo Impostazioni account selezionare la scheda Posta elettronica e quindi fare doppio clic sull'account di Microsoft Exchange Server.
Nella finestra di dialogo Cambia account selezionare Altre impostazioni.
Nella finestra di dialogo Microsoft Exchange selezionare la scheda Avanzate .
Selezionare questa opzione per deselezionare la casella di controllo Scarica cartelle condivise .
Selezionare OK due volte.
Selezionare Avanti, fare clic su Fine e quindi selezionare Chiudi.
Riavvia Outlook.
Outlook 2007
Per disabilitare la memorizzazione nella cache di tutte le cartelle condivise in Outlook 2007, seguire questa procedura:
Scegliere Impostazioni account dal menu Strumenti.
Nella finestra di dialogo Impostazioni account selezionare la scheda Posta elettronica e quindi fare doppio clic sull'account di Microsoft Exchange Server.
Nella finestra di dialogo Cambia account selezionare Altre impostazioni.
Nella finestra di dialogo Microsoft Exchange selezionare la scheda Avanzate .
Selezionare questa opzione per deselezionare la casella di controllo Scarica cartelle condivise .
Selezionare OK due volte.
Selezionare Avanti, fare clic su Fine e quindi selezionare Chiudi.
Riavvia Outlook.
Dopo aver apportato questa modifica, nessuna delle cartelle condivise nella cassetta postale secondaria sarà disponibile in Outlook quando si lavora offline. Tuttavia, tutte le cartelle nella cassetta postale primaria saranno comunque disponibili quando si lavora offline.
Per altre informazioni su come disabilitare il download delle cartelle condivise tramite un'impostazione di Criteri di gruppo, selezionare il numero di articolo seguente per passare all'articolo della Microsoft Knowledge Base:
982697 Per impostazione predefinita, le cartelle di posta condivisa vengono scaricate in modalità cache in Outlook 2010 e Outlook 2013
Metodo 3: Modificare la configurazione della cassetta postale di Exchange secondaria in un secondo account di Exchange nel profilo
Solo Outlook 2010 e versioni successive
Se si desidera memorizzare nella cache tutte le cartelle nella cassetta postale di Exchange secondaria, seguire questa procedura per modificare il profilo di Outlook in modo che la cassetta postale secondaria venga aggiunta come secondo account di Exchange.
Annotazioni
Per seguire questa procedura, è necessario conoscere la password dell'account della cassetta postale secondaria oppure disporre delle autorizzazioni complete per l'account della cassetta postale secondaria. Per informazioni o autorizzazioni, vedere l'amministratore di Exchange Server.
Verificare che la mappatura automatica sia disabilitata per la cassetta postale secondaria. Per altre informazioni, vedere l'articolo della Microsoft Knowledge Base seguente:
2646504 Come rimuovere il mapping automatico per una cassetta postale condivisa in Office 365
Nella scheda File selezionare Impostazioni account nell'elenco Impostazioni account .
Nella finestra di dialogo Impostazioni account selezionare la scheda Posta elettronica e quindi fare doppio clic sull'account di Microsoft Exchange Server.
Nella finestra di dialogo Cambia account selezionare Altre impostazioni.
Nella finestra di dialogo Microsoft Exchange selezionare la scheda Avanzate .
Selezionare la scheda Avanzate . Nella sezione Cassette postali selezionare la cassetta postale secondaria e quindi selezionare Rimuovi.
Selezionare Sì quando viene richiesto di confermare la rimozione della cassetta postale.
Selezionare OK, selezionare Avanti, selezionare Fine e quindi selezionare Chiudi.
Annotazioni
A questo punto, la cassetta postale di Exchange secondaria non è più associata al profilo di Outlook.
Uscire da Outlook.
Aprire l'elemento Mail nel Pannello di controllo.
Seleziona il profilo, quindi seleziona Proprietà.
Selezionare Account di posta elettronica.
Nella scheda Posta elettronica della finestra di dialogo Impostazioni account selezionare Nuovo.
Nella sezione Scegli servizio della finestra di dialogo Aggiungi nuovo account selezionare Account di posta elettronica e quindi selezionare Avanti.
Se si conosce la password per l'account della cassetta postale secondaria, andare al passaggio 14.
Se non si conosce la password per l'account della cassetta postale secondaria, ma il proprio account dispone delle autorizzazioni complete per questa cassetta postale, andare al passaggio 18.
Nella sezione Configurazione automatica account della finestra di dialogo Aggiungi nuovo account immettere le informazioni sull'account seguenti per la cassetta postale secondaria e quindi selezionare Avanti.
- Nome
- Indirizzo di posta elettronica
- Parola chiave
Dopo aver configurato correttamente l'account, selezionare Fine.
Selezionare Chiudi, chiudi e quindi ok.
Andare al passaggio 22.
Nella sezione Configurazione automatica account della finestra di dialogo Aggiungi nuovo accountselezionare Configura manualmente le impostazioni del server o altri tipi di server e quindi selezionare Avanti.
Nella sezione Scegli servizio della finestra di dialogo Aggiungi nuovo account selezionare Microsoft Exchange o il servizio compatibile e quindi selezionare Avanti.
Nella sezione Impostazioni server della finestra di dialogo Aggiungi nuovo account immettere le informazioni seguenti per la cassetta postale secondaria e quindi selezionare Avanti.
- Server (nome del server Exchange)
- Usare la Modalità cache di Exchange (abilitata per consentire la memorizzazione nella cache locale della cassetta postale secondaria nel file .ost)
- Nome utente
Selezionare Fine, chiudi, chiudi e quindi ok.
Avviare Outlook.
Annotazioni
Se l'account non dispone delle autorizzazioni complete per la cassetta postale secondaria, vengono richieste le credenziali dell'account per la cassetta postale secondaria. È possibile che si verifichino i seguenti problemi specifici quando si utilizza Outlook dopo aver apportato le modifiche di configurazione specificate in questo metodo.
- Vengono visualizzati nuovi avvisi di posta elettronica per entrambe le cassette postali di Exchange.
- I messaggi contrassegnati come privati possono essere visualizzati nella seconda cassetta postale di Exchange anche se l'account della prima cassetta postale di Exchange non è configurato specificamente per consentire la visualizzazione di messaggi privati.
Altre informazioni
Quando si aggiungono altre cassette postali al profilo di Outlook e si abilita la memorizzazione nella cache delle cartelle delle cassette postali condivise, Outlook registra singolarmente ogni cartella in ogni cassetta postale memorizzata nella cache. Ognuna di queste cartelle registrate viene conteggiata rispetto al limite del tipo objtFolder nel server che esegue Exchange Server. Si tratta di un limite per cassetta postale.
Come indicato nell'evento 9646 visualizzato nella sezione "Sintomi", il limite predefinito per gli oggetti objtFolder per ogni cassetta postale è 500.
Se si memorizza nella cache una cassetta postale condivisa contenente più di 500 cartelle, questo limite viene esaurito e si potrebbero riscontrare i problemi indicati nella sezione "Sintomi".
Inoltre, un numero elevato di preferiti delle cartelle pubbliche può contribuire all'esaurimento del limite di oggetti objtFolder.
Per altre informazioni sulla condivisione massima consentita delle risorse del server in Microsoft Exchange Server 2007, vedere Un utente sta utilizzando la condivisione massima consentita del server.
Per ulteriori informazioni sui limiti di sessione dell'archivio cassette postali di Exchange Server 2010, visitare i siti Web Microsoft seguenti:
Per determinare il numero di cartelle e sottocartelle presenti in una cassetta postale o in una cartella, eseguire il cmdlet Get-MailboxFolderStatistics .