Errore "Non è possibile inviare messaggi di posta elettronica come utente selezionato" quando si invia un messaggio di posta elettronica come un altro utente
Questo articolo presenta possibili cause e una risoluzione per l'errore "Non è possibile inviare messaggi di posta elettronica come utente selezionato" che si verifica quando si invia un messaggio di posta elettronica per conto di un altro utente in Microsoft Dynamics 365.
Si applica a: Microsoft Dynamics 365
Numero KB originale: 3184980
Sintomi
Quando si tenta di inviare un messaggio di posta elettronica impostando il campo Da a un altro utente in Dynamics 365, viene visualizzato il messaggio di errore seguente:
Non è possibile inviare messaggi di posta elettronica come utente selezionato. L'utente selezionato non ha consentito questa operazione o non si dispone di privilegi sufficienti per farlo. Per assistenza, contattare l'amministratore di sistema.
Quando si seleziona il pulsante Scarica log , nella sezione Messaggio vengono visualizzate le informazioni seguenti:
<L'utente del messaggio>non dispone del privilegio send-as.</Messaggio>
Causa
Questo problema si verifica se esiste una delle condizioni seguenti:
Il ruolo di sicurezza in Dynamics 365 non ha il privilegio Invia messaggio di posta elettronica come altro utente .
Note
Se si usa una regola flusso di lavoro per inviare il messaggio di posta elettronica, il proprietario della regola flusso di lavoro richiede questo privilegio.
L'utente che si tenta di inviare come non ha abilitato l'opzione che consente ad altri utenti di inviare un messaggio di posta elettronica per loro conto.
Risoluzione
Per risolvere questo problema:
Un amministratore deve verificare che l'utente abbia un ruolo in Dynamics 365 che includa il privilegio Invia messaggio di posta elettronica come altro utente .
Accedere a Microsoft Dynamics 365.
Selezionare Impostazioni>impostazioni avanzate>Impostazioni Impostazioni>Ruoli di sicurezza della sicurezza.>
Aprire il ruolo di sicurezza assegnato all'utente che riceve il messaggio di errore.
Selezionare Gestione>aziendale Privilegi vari.
Verificare che l'utente disponga del privilegio Invia messaggio di posta elettronica come altro utente . Se l'utente non ha il privilegio, assegnarlo e quindi selezionare Salva.
Note
Il privilegio Send Email as Another User (Invia messaggio di posta elettronica come altro utente ) ha livelli di profondità diversi. Un utente ha bisogno di una profondità sufficiente in questo privilegio per corrispondere all'utente che sta tentando di inviare come. Ad esempio, se si tenta di inviare come utente che si trova in una business unit diversa in Dynamics 365, l'accesso a livello di business unit per questo privilegio non sarebbe sufficiente perché consente solo di inviare come altri utenti nella stessa business unit.
L'altro utente impostato come mittente nel messaggio di posta elettronica deve selezionare la casella di controllo Consenti ad altri utenti di Microsoft Dynamics 365 di inviare messaggi di posta elettronica per conto dell'utente nelle opzioni personali.
- Accedere a Dynamics 365 come utente che si tenta di inviare un messaggio di posta elettronica come.
- Selezionare l'icona a forma di ingranaggio nell'angolo in alto a destra e quindi selezionare Opzioni>Impostazioni>personalizzazione>Posta elettronica.
- Verificare che l'opzione Consenti ad altri utenti di Microsoft Dynamics 365 di inviare messaggi di posta elettronica per conto dell'utente è selezionata. In caso contrario, selezionare l'opzione e quindi selezionare OK.