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Errore "Il percorso del server di posta elettronica o la porta di posta elettronica in arrivo specificata non è corretta" in Dynamics 365

Questo articolo fornisce una soluzione a un errore che si verifica quando si tenta di testare e abilitare una cassetta postale in Microsoft Dynamics 365.

Si applica a: Microsoft Dynamics 365
Numero KB originale: 4463808

Sintomi

Quando si tenta di testare e abilitare una cassetta postale in Dynamics 365, viene visualizzato l'errore seguente:

Impossibile ricevere messaggi di posta elettronica per il nome> della cassetta postale <perché il percorso del server di posta elettronica o la porta di posta elettronica in arrivo specificata nel nome> del profilo del profilo <del server di posta elettronica associato non è corretta. La cassetta postale non è stata sincronizzata. Una notifica è stata inviata al proprietario del profilo del server e-mail.

Codice errore del server di posta elettronica: eccezione restituita dal socket InvalidIncomingEmailServerProfileConfiguration HostNotFound.

Se si seleziona Dettagli, vengono visualizzate le informazioni aggiuntive seguenti:

ActivityId: <GUID>
>Errore: System.Net.Sockets.SocketException (0x80004005): nessun host di questo tipo è noto
in System.Net.Dns.GetAddrInfo(String name)
in System.Net.Dns.InternalGetHostByName (String hostName, Boolean includeIPv6)
in System.Net.Dns.GetHostAddresses(String hostNameOrAddress)
in System.Net.Sockets.TcpClient.Connect(String hostname, Int32 port)
in Microsoft.Crm.Asynchronous.EmailConnector.Pop3Client.Connect()

Causa

Questo errore può verificarsi se il percorso o la porta del server nel profilo del server di posta elettronica non è corretto.

Risoluzione

Note

Per gestire i ruoli di sicurezza e le impostazioni delle cassette postali, è necessario accedere all'organizzazione di Dynamics 365 come utente con il ruolo "Amministratore di sistema".

  1. Passare a Impostazioni>Configurazione posta elettronica e quindi selezionare Profili server di posta elettronica.

  2. Aprire il profilo del server di posta elettronica usato dalla cassetta postale che ha riscontrato questo errore.

    Suggerimento

    È anche possibile selezionare il nome del profilo del server di posta elettronica nel messaggio di errore. Viene visualizzato come collegamento ipertestuale che aprirà il record corretto del profilo del server di posta elettronica.

  3. Verificare che il valore Percorso server in ingresso sia corretto.

    Note

    Per gli indirizzi corretti, vedere la documentazione del provider di posta elettronica. Ad esempio, per Gmail, usare pop.gmail.com come percorso del server in ingresso e smtp.gmail.com come percorso del server in uscita.

  4. Seleziona Avanzate.

  5. Verificare che il valore porta in ingresso sia corretto e quindi selezionare Salva.

    Note

    Fare riferimento alla documentazione del provider di posta elettronica per le porte corrette durante la connessione al servizio SMTP. Per Gmail, usare la porta 995 per le connessioni POP3 in ingresso e la porta 587 per le connessioni SMTP in uscita.

  6. Selezionare Cassette postali e quindi selezionare la cassetta postale che ha ricevuto l'errore.

  7. Selezionare il pulsante Test e Abilita cassette postali .

  8. Al termine del test, aprire il record della cassetta postale e visualizzare la sezione Avvisi se i risultati non vengono visualizzati come Operazione riuscita.

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