"Si è verificato un errore sconosciuto durante l'invio del messaggio di posta elettronica" durante il test di una cassetta postale in Dynamics 365
Questo articolo fornisce una soluzione a un errore che si verifica quando si tenta di testare e abilitare una cassetta postale in Microsoft Dynamics 365.
Si applica a: Microsoft Dynamics 365
Numero KB originale: 4092733
Sintomi
Quando si tenta di testare e abilitare una cassetta postale in Microsoft Dynamics 365, viene visualizzato l'errore seguente:
Si è verificato un errore sconosciuto durante l'invio del messaggio di posta elettronica "La cassetta postale è ora connessa a Dynamics 365". La cassetta postale <Nome cassetta postale> non è stata sincronizzata. Il proprietario del profilo del server <di posta elettronica associato è> stato informato.
Se si seleziona la sezione Dettagli , è possibile trovare i dettagli seguenti:
Errore: System.Net.Mail.SmtpException: errore di sintassi, comando non riconosciuto. Risposta del server:
in System.Net.Mail.SmtpConnection.ConnectAndHandshakeAsyncResult.End(IAsyncResult result)
in System.Net.Mail.SmtpTransport.EndGetConnection(IAsyncResult result)
in System.Net.Mail.SmtpClient.ConnectCallback(IAsyncResult result)
Causa
Questo errore può verificarsi se il valore Porta in uscita nella sezione Avanzate del profilo del server di posta elettronica non è corretto.
Risoluzione
Per risolvere il problema, seguire questa procedura:
Accedere all'organizzazione di Dynamics 365 con un account utente con il ruolo "Amministratore sistema".
Passare a Impostazioni>Configurazione posta elettronica e quindi selezionare Profili server di posta elettronica.
Aprire il profilo del server di posta elettronica usato dalla cassetta postale che riceve questo errore.
Note
È anche possibile selezionare il nome del profilo del server di posta elettronica nel messaggio di errore. Viene visualizzato come collegamento ipertestuale che aprirà il record corretto del profilo del server di posta elettronica.
Seleziona Avanzate.
Correggere il valore porta in uscita e quindi selezionare Salva.
Note
Fare riferimento alla documentazione del provider di posta elettronica per le porte corrette durante la connessione al servizio SMTP. Ad esempio, per Gmail, usare la porta 587 per le connessioni TLS/STARTTLS.
Selezionare Cassette postali e quindi selezionare la cassetta postale che ha ricevuto l'errore.
Selezionare il pulsante Test e Abilita cassette postali .
Al termine del test, aprire il record della cassetta postale e visualizzare la sezione Avvisi se i risultati non vengono visualizzati come Operazione riuscita.