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La ricerca non filtra i record come previsto per una particolare entità in Dynamics 365

Questo articolo fornisce soluzioni alternative a un problema in cui la ricerca visualizza tutti i record anziché solo i record correlati a ciò che è stato digitato.

Si applica a: Power Apps
Numero KB originale: 4603850

Sintomi

Quando si digita in un controllo di ricerca, la ricerca visualizza tutti i record nella visualizzazione anziché solo i record correlati a ciò che è stato digitato. Se si scorre i record, il testo del record viene visualizzato in grassetto come di consueto quando il testo corrisponde al testo di ricerca.

Screenshot che mostra il testo del record in grassetto come di consueto quando il testo corrisponde al testo di ricerca.

Causa

Esistono due possibili cause di questo problema:

Causa 1

Il problema si verifica perché non sono presenti colonne "find" nella visualizzazione Ricerca rapida dell'entità.

La visualizzazione Ricerca determina le colonne visualizzate all'interno del controllo di ricerca, ma lecolonne Ricercarapida determinano - le colonne in cui viene eseguita la ricerca all'interno del controllo di ricerca. In pratica, quando si digita un valore in un controllo di ricerca, cerca una corrispondenza all'interno delle colonne di ricerca. Seleziona quindi i record con una corrispondenza e visualizza le informazioni determinate dalla visualizzazione Ricerca. Il motivo per cui mostra tutti i record è che non sono impostate colonne "find" nella visualizzazione Ricerca rapida.

Nota

Le colonne visualizzazione Ricerca rapida non sono le stesse dellecolonne di Ricerca - rapida. Possono essere presenti molte colonne all'interno della visualizzazione Ricerca rapida, ma se nessuna è contrassegnata come colonne "trova", la ricerca non funzionerà come previsto.

Il motivo per cui le colonne visualizzate e ricercate possono essere diverse è rappresentato dalle prestazioni. Minore è il numero di colonne ricercate, maggiore sarà la velocità di esecuzione della ricerca. Tuttavia, è possibile visualizzare molte informazioni nel controllo di ricerca per assicurarsi di selezionare il record corretto.

Per i passaggi per aggiungere colonne "trova", vedere Soluzione alternativa 1.

Causa 2

Il problema si verifica perché non sono presenti colonne di tipo stringa nella visualizzazione utilizzata dal controllo di ricerca.

Il controllo di ricerca non può filtrare le colonne di tipo non stringa. La visualizzazione usata deve avere almeno una colonna di tipo stringa, ad esempio testo, posta elettronica, telefono, URL e così via.

Per i passaggi per aggiungere una colonna di tipo stringa, vedere Soluzione alternativa 2.

Soluzioni alternative

Per risolvere questo problema, usare una delle soluzioni alternative seguenti:

Soluzione alternativa 1

  1. In Personalizzazioni passare alla visualizzazione Ricerca rapida per l'entità del controllo di ricerca.

  2. Selezionare Aggiungi colonne di ricerca.

    Screenshot per selezionare l'elemento Aggiungi colonne di ricerca.

  3. Aggiungere tutte le colonne di cui si vuole eseguire la ricerca e la corrispondenza all'interno del controllo di ricerca.

    Screenshot per aggiungere tutte le colonne di cui si vuole eseguire la ricerca e la corrispondenza all'interno del controllo di ricerca.

  4. Salvare e pubblicare le modifiche.

Soluzione alternativa 2

È necessario aggiungere una colonna di tipo stringa alla visualizzazione usata dal controllo di ricerca.

  1. In Personalizzazioni passare alla visualizzazione usata dal controllo di ricerca in cui il filtro è interrotto.

  2. Selezionare Aggiungi colonne.

    Screenshot per selezionare l'elemento Aggiungi colonne nella visualizzazione di test.

  3. Aggiungere almeno una colonna di tipo stringa.