IMAP 移行後にExchange ActiveSyncまたは Outlook クライアント上のメールボックス フォルダーを表示できない
元の KB 番号: 3050475
現象
ユーザーのメールボックスをインターネット メール アクセス プロトコル (IMAP) メッセージング システムから Microsoft 365 またはオンプレミスのMicrosoft Exchange Serverに移行した後、Microsoft Exchange ActiveSync クライアントまたは Microsoft Outlook 上のユーザーのメールボックス内の 1 つ以上のフォルダーを表示することはできません。
原因
この問題は、Exchange メールボックス内のフォルダーが認識されない種類のクラスを使用して作成された場合に発生します IPF.Imap
。 フォルダーのプロパティを分析すると、次の結果が表示されます。
<property tag = "0x3613001E" type = "PT_STRING8">
<ExactNames>PR_CONTAINER_CLASS, PR_CONTAINER_CLASS_A, ptagContainerClass</ExactNames>
<PartialNames>PR_CONTAINER_CLASS_W, PidTagContainerClass</PartialNames>
<Value><![CDATA[IPF.Imap]]></Value>
<AltValue>cb: 8 lpb: 4950462E496D6170</AltValue>
</property>
解決方法
MICROSOFT EXCHANGE SERVER MAPI エディター (MFCMAPI) を使用して、フォルダーのプロパティを PR_CONTAINER_CLASS
IPF に変更します。注: それには、以下の手順を実行します。
注:
MFCMAPI エディターはサポートされていますが、このツールを使用してメールボックスを変更する場合は注意が必要です。 MFCMAPI エディターを正しく使用しないと、メールボックスが永続的に破損する可能性があります。
- MFCMAPI をダウンロードし、実行します。
- [ツール] メニューの [オプション] を選択します。
- [ OpenMsgStore を呼び出すときにMDB_ONLINEフラグを使用 する] チェック ボックスと [OpenEntry を呼び出すとき にMAPI_NO_CACHEフラグを使用 する] チェック ボックスをオンにします。
- [セッション] メニューの [ログオン] を選択します。
- メールボックスの Outlook プロファイルを選択します。
- メールボックスをダブルクリックして開きます。
- ルート コンテナーを展開し、[情報ストアの上部] を展開して、見つからないフォルダーを見つけます。
- Exchange ActiveSync クライアントから見つからないフォルダーを選択して、プロパティを表示します。
- 0x3613001E タグ値を含むプロパティをダブルクリックします。
- IPF から値を変更 します。 適切なクラスに Imap を設定します。 (たとえば、値を IPF に変更します。 電子メール フォルダーに注意してください。)
- MFCMAPI を終了します。
- Exchange ActiveSync クライアントにプロファイルを作成します。