OUTLOOK が RPC 接続または HTTPS 接続を使用してサーバーに接続しようとするとエラーが発生する: プロキシ サーバーのセキュリティ証明書に問題があります

元の KB 番号: 923575

現象

Microsoft Outlook がリモート プロシージャ コール (RPC) 接続またはセキュリティで保護された HTTP (HTTPS) 接続を使用してサーバーに接続しようとすると、次のいずれかのエラー メッセージが表示されます。

  • エラー メッセージ 1

    プロキシ サーバーのセキュリティ証明書 %s に問題があります。 Outlook はこのサーバーに接続できません。 (%s)

  • エラー メッセージ 2

    プロキシ サーバーのセキュリティ証明書 %s に問題があります。 セキュリティ証明書の名前が無効であるか、サイトの名前と一致しません。 Outlook はこのサーバーに接続できません。 (%s)

  • エラー メッセージ 3

    プロキシ サーバーのセキュリティ証明書 %s に問題があります。 セキュリティ証明書は、信頼された証明機関からのものではありません。 Outlook はこのサーバーに接続できません。(%s)"

  • エラー メッセージ 4

    プロキシ サーバーのセキュリティ証明書に問題があります。 セキュリティ証明書の名前が無効であるか、ターゲット サイトの outlook.office365.com の名前と一致しません。 Outlook がプロキシ サーバーに接続できません (エラー コード 0)

エラー メッセージに関する注意事項

  • %s プレースホルダーは、Outlook プロファイル プロパティ 001f6622 です。 これは、MICROSOFT EXCHANGE SERVER RPC プロキシ サーバー名です。

  • (%s) プレースホルダーはエラー コードです。

    エラー メッセージ 1 とエラー メッセージ 2 の場合、返されるエラー コードは、すべてのビットマスク証明書の問題コードの合計です。 ビットマスク証明書の問題コードについては、「詳細情報」セクションを参照してください。

    エラー メッセージ 3 の場合、エラー コードは常に0x00000008されることが予想されます。

原因

この問題は、次の条件の 1 つ以上が当てはまる場合に発生する可能性があります。

  • サーバーへの接続には、証明機関 (CA) が必要です。
  • ルートで証明機関を信頼していません。
  • 証明書が無効または失効している可能性があります。
  • 証明書がサイトの名前と一致しません。
  • サード パーティ製アドインまたはサード パーティ製ブラウザー アドインがアクセスを妨げている。

解決策 1: エラー メッセージ 1 または 2 の証明書を調べる

証明書を調べます。 次に、システム管理者に問い合わせてこの問題を解決します。

証明書を調べるには、次の手順に従います。

  1. Microsoft Internet エクスプローラーで、RPC サーバーまたはセキュリティで保護されたサーバーに接続します。 たとえば、Web ブラウザーのアドレス バーに「server_name.com/rpc」と入力https://www.し、Enter キーを押します。

    注:

    server_name プレースホルダーは、RPC サーバー名またはセキュリティで保護されたサーバー名を参照します。

  2. Web ブラウザーの右下隅にある南京錠アイコンをダブルクリックします。

  3. [ 詳細] タブをクリックします。

  4. 次のフィールドの情報に注意してください。

    • 有効です。
      [有効] フィールドは、証明書が有効になるまでの日付を示します。
    • 件名
      [件名] フィールドのデータはサイト名と一致する必要があります。

解決策 2: エラー メッセージ 3 の信頼されたルート証明書をインストールする

信頼されたルート証明書をクライアントにインストールするには、次の手順に従います。

  1. [ 証明書 ] ダイアログ ボックスが表示されたら、[ 証明書 のインストール] をクリックします。
  2. [次へ] をクリックします。
  3. [次のストアにすべての証明書を配置する] チェックボックスをクリックして選択します。
  4. [ 参照] をクリックします。
  5. [ 信頼されたルート証明機関>] [OK] をクリックします
  6. [次へ] をクリックします。
  7. [完了] をクリックします。
  8. [OK] をクリックします。

参照については、「 信頼されたルート証明書のインストール」を参照してください。

解決策 3: サード パーティ製アドインまたはサード パーティ製ブラウザー アドインを無効にして、エラー メッセージ 4 を表示する

サード パーティのアドインを無効にする

  1. 問題の特定に役立つセーフ モードで Outlook を起動します。 これを行うには、[Start Run]\(実行の開始\)> をクリックし、「/safeoutlook.exe」と入力し、[OK] をクリックします

    Outlook がセーフ モードで正常に起動した場合、発生している問題はサード パーティのアドインによって発生する可能性があります。

  2. サード パーティの COM アドインを確認し、無効にします。 これを行うには、次の手順を実行します。

    1. [ ファイル ] メニューの [ オプション>アドイン] をクリックします。
    2. [管理] ボックスで>、[COM アドインの移動] をクリックします。
    3. をクリックして、無効にするサード パーティ製アドインの横にある [チェック] ボックスをオフにします。
    4. Outlook を再起動します。

詳細については、次の Microsoft サポート技術情報記事の「手順 6: セーフ モードで Outlook を起動する」セクションを参照してください。

2632425 Outlook 2010 および Outlook 2013 でのクラッシュのトラブルシューティング方法

サード パーティ製ブラウザー アドインを無効にする

Outlook では、HTTP 要求にインターネット エクスプローラー設定が使用されます。 サードパーティのブラウザー アドインがこの問題の原因となっている場合は、インターネット エクスプローラーで無効にします。 これを行う手順については、次の Microsoft サポート技術情報の「インターネット エクスプローラーでアドオンを無効にする」セクションを参照してください。

956196 "インターネット エクスプローラー web ページを表示できません" エラー

詳細

ビットマスク証明書の問題コードを次の表に示します。

説明 エラー コード
FLAG_CERT_REV_FAILED 0x00000001
FLAG_INVALID_CERT 0x00000002
FLAG_CERT_REVOKED 0x00000004
FLAG_INVALID_CA 0x00000008
FLAG_CERT_CN_INVALID 0x00000010
FLAG_CERT_DATE_INVALID 0x00000020
FLAG_CERT_WRONG_USAGE 0x00000040
FLAG_SECURITY_CHANNEL_ERROR 0x80000000