RPC 接続または HTTPS 接続を使用して Outlook がサーバーに接続しようとしたときにエラーが発生しました:プロキシ サーバーのセキュリティ証明書に問題があります

元の KB 番号: 923575

現象

Microsoft Outlook がリモート プロシージャ コール (RPC) 接続またはセキュリティで保護された HTTP (HTTPS) 接続を使用してサーバーに接続しようとすると、次のいずれかのエラー メッセージが表示されます。

  • エラー メッセージ 1

    プロキシ サーバーのセキュリティ証明書 %s に問題があります。 Outlook はこのサーバーに接続できません。 (%s)

  • エラー メッセージ 2

    プロキシ サーバーのセキュリティ証明書 %s に問題があります。 セキュリティ証明書の名前が無効であるか、サイトの名前と一致しません。 Outlook はこのサーバーに接続できません。 (%s)

  • エラー メッセージ 3

    プロキシ サーバーのセキュリティ証明書 %s に問題があります。 セキュリティ証明書は、信頼された証明機関からのものではありません。 Outlook はこのサーバーに接続できません。(%s)"

  • エラー メッセージ 4

    プロキシ サーバーのセキュリティ証明書に問題があります。 セキュリティ証明書の名前が無効であるか、ターゲット サイト outlook.office365.com の名前と一致しません。 Outlook がプロキシ サーバーに接続できない (エラー コード 0)

エラー メッセージに関する注意事項

  • %s プレースホルダーは、Outlook プロファイル プロパティ 001f6622 です。 これは、MICROSOFT EXCHANGE SERVER RPC プロキシ サーバー名です。

  • (%s) プレースホルダーはエラー コードです。

    エラー メッセージ 1 とエラー メッセージ 2 の場合、返されるエラー コードは、すべてのビットマスク証明書の問題コードの合計です。 ビットマスク証明書の問題コードの詳細については、「詳細情報」セクションを参照してください。

    エラー メッセージ 3 の場合、エラー コードは常に0x00000008される必要があります。

原因

この問題は、次のいずれかの条件に該当する場合に発生する可能性があります。

  • サーバーへの接続には証明機関 (CA) が必要です。
  • ルートで証明機関を信頼していません。
  • 証明書が無効であるか、失効している可能性があります。
  • 証明書がサイトの名前と一致しません。
  • サード パーティのアドインまたはサード パーティのブラウザー アドインがアクセスを妨げている。

解決策 1: 証明書でエラー メッセージ 1 または 2 を確認する

証明書を調べます。 次に、システム管理者に問い合わせてこの問題を解決します。

証明書を調べるには、次の手順に従います。

  1. Microsoft Internet Explorer で、RPC サーバーまたはセキュリティで保護されたサーバーに接続します。 たとえば、Web ブラウザーのアドレス バーに「server_name.com/rpc」と入力https://www.し、Enter キーを押します。

    注:

    server_name プレースホルダーは、RPC サーバー名またはセキュリティで保護されたサーバー名を参照します。

  2. Web ブラウザーの右下隅にある南京錠アイコンをダブルクリックします。

  3. [ 詳細] タブをクリックします。

  4. 次のフィールドの情報に注意してください。

    • 有効な対象
      [有効先] フィールドは、証明書が有効になるまでの日付を示します。
    • 件名
      [件名] フィールドのデータは、サイト名と一致する必要があります。

解決策 2: エラー メッセージ 3 の信頼されたルート証明書をインストールする

クライアントに信頼されたルート証明書をインストールするには、次の手順に従います。

  1. [証明書] ダイアログ ボックスでメッセージが表示されたら、[証明書のインストール] をクリックします。
  2. [次へ] をクリックします。
  3. [ 次のストアにすべての証明書を配置 する] チェック ボックスをオンにします。
  4. [ 参照] をクリックします。
  5. [信頼されたルート証明機関 OK>]をクリックします
  6. [次へ] をクリックします。
  7. [完了] をクリックします。
  8. [OK] をクリックします。

参照については、「 信頼されたルート証明書のインストール」を参照してください。

解決策 3: エラー メッセージ 4 のサード パーティ アドインまたはサード パーティのブラウザー アドインを無効にする

サード パーティアドインを無効にする

  1. Outlook をセーフ モードで起動して、問題を特定します。 これを行うには、[実行の開始>] をクリックし、outlook.exe /safe と入力して、[OK] をクリックします。

    Outlook がセーフ モードで正常に起動した場合、発生している問題はサード パーティアドインによって発生する可能性があります。

  2. サード パーティの COM アドインを確認し、無効にします。 これを行うには、次の手順を実行します。

    1. [ ファイル ] メニューの [ オプション>アドイン] をクリックします。
    2. [管理] ボックスで>、[COM アドイン移動] をクリックします。
    3. 無効にするサード パーティアドインの横にあるチェック ボックスをオフにします。
    4. Outlook を再起動します。

詳細については、次の Microsoft サポート技術情報記事の「手順 6: Outlook をセーフ モードで起動する」セクションを参照してください。

2632425 Outlook 2010 および Outlook 2013 でのクラッシュのトラブルシューティング方法

サード パーティのブラウザー アドインを無効にする

Outlook では、HTTP 要求に Internet Explorer の設定が使用されます。 サード パーティのブラウザー アドインがこの問題を引き起こしている場合は、Internet Explorer で無効にします。 これを行う手順については、次のマイクロソフト サポート技術情報記事の「Internet Explorer でアドオンを無効にする」セクションを参照してください。

956196 "Internet Explorer が Web ページを表示できません" というエラー

詳細情報

ビットマスク証明書の問題コードを次の表に示します。

説明 エラー コード
FLAG_CERT_REV_FAILED 0x00000001
FLAG_INVALID_CERT 0x00000002
FLAG_CERT_REVOKED 0x00000004
FLAG_INVALID_CA 0x00000008
FLAG_CERT_CN_INVALID 0x00000010
FLAG_CERT_DATE_INVALID 0x00000020
FLAG_CERT_WRONG_USAGE 0x00000040
FLAG_SECURITY_CHANNEL_ERROR 0x80000000