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Outlook の不在時機能が Microsoft 365 で正しく機能しない

現象

Microsoft 365 の Outlook で Out of Office (OOF) 機能を使用しようとすると、次のような現象が発生します。

  • OOF メッセージを保存できません。
  • 古いまたは重複する OOF メッセージが送信されます。
  • OOF メッセージを有効にしても、OOF メッセージは送信されません。

原因

この問題は、次のいずれかの理由で発生します。

  • 原因 1: メールボックス アシスタント イベントのバックログがあります (Exchange 2010 のみ)。
  • 原因 2: OOF ルール テンプレートの形式が正しくないか、破損しています。
  • 原因 3: OOF ルールクォータを超え、新しいルールを作成できません。
  • 原因 4: 既定の (または特定の) ドメインのリモート ドメイン設定が OOF メッセージを許可するように設定されていません。

解決方法

注:

4 つの原因のいずれかが原因で、OOF 応答が失敗する可能性があります。 そのため、各原因は一度に 1 つずつ除外する必要があります。

警告

Microsoft Exchange Server MAPI エディター (MFCMapi) を使用すると、Microsoft Exchange Serverと Exchange サーバー メールボックスが破損する可能性があります。 github から MFCMAPI をダウンロードします (下にスクロールし、[最新リリース] を選択します)。

この問題を解決するには、特定の原因の手順に従います。

解決方法 1

  1. OOF 機能を構成します。 これを行うには、必要に応じて、Windows PowerShellで次のいずれかのコマンドレットを実行します。

    Set-MailboxAutoReplyConfiguration <identity> -AutoReplyState Disabled
    Set-MailboxAutoReplyConfiguration <identity> -AutoReplyState Enabled

  2. MFCMapi を使用して値をPR_OOF_STATEチェックします。 これを行うには、次の手順を実行します。

    1. MFCMapi の [メイン] ウィンドウで、[セッション] を選択し、[ログオン] と [ストア テーブルの表示] を選択してメールボックスを開きます。

    2. アクセスするプロファイルを選択し、値が表示されるまで下部のウィンドウを下に PR_OOF_STATE スクロールします。 この値は、Windows PowerShellで OOF 機能を有効にした場合は True、OOF 機能を無効にした場合は False である必要があります。 たとえば、OOF 機能を無効にした場合は、次のスクリーンショットを検討してください。

      PR_OOF_STATE値のスクリーンショット。

  3. 値がPR_OOF_STATE予想される結果ではない場合は、キューに登録されたイベントにチェックするようにMicrosoft サポートに問い合わせてください (Exchange 2010 のみ)。

解決方法 2

注:

あなたの場合の症状は、これらとは若干異なる場合があります。 たとえば、OOF メッセージは予期したとおりに送信できませんが、OOF メッセージはエラーなしで設定できます。 ただし、これらの手順は引き続き適用されます。

この問題を解決するには、メールボックスから OOF ルールと OOF ルール テンプレートを削除します。 次に、OOF 機能を再度有効にし、動作をテストします。 それには、以下の手順を実行します。

注:

次の手順に従うときに、OOF メッセージをバックアップする必要はありません。

  1. MFCMapi の [メイン] ウィンドウで、[セッション] を選択し、[ログオン] と [ストア テーブルの表示] を選択してメールボックスを開きます。

  2. ルート コンテナーとインフォメーション ストアの上部を展開します。

  3. OOF 規則を削除します。 これを行うには、次の手順を実行します。

    1. [受信トレイ] を右クリックし、[ルール テーブルの表示] を選択します。

      • OOF 機能が無効になっている場合、OOF ルールは次の規則名と共にルール テーブルに一覧表示されます。
        MSFT: TDX OOF 規則

      • OOF 機能が有効になっている場合は、規則テーブルに 2 つの異なる OOF ルールが一覧表示されます。 一覧表示されるルールは、ルールが内部でのみ有効か、内部と外部の両方で有効になっているかによって異なります。 たとえば、次のスクリーンショットを考えてみましょう。

        [ルール テーブル] ダイアログ ボックスの詳細のスクリーンショット。

      • OOF テンプレートが破損しているか形式が正しくない場合は、それらの OOF テンプレートがルール テーブルに一覧表示されます。 ユーザーが他のルールを有効にしている場合は、他のエントリを確認できます。

    2. OOF 規則を右クリックし、[削除] を選択 します

      注:

      参照されているルールを除き、OOF 規則は削除しないでください。

    3. [ルール テーブル] ウィンドウを閉じます。

  4. OOF テンプレートを削除します。 これを行うには、次の手順を実行します。

    • [受信トレイ] を右クリックし、[関連付けられたコンテンツ テーブルを開く] を選択します。
    • 右側までスクロールし、[ メッセージ クラス ] 列を展開します。
    • 項目を並べ替えるには、[ メッセージ クラス ] 列を選択します。
    • メッセージ クラスが次のいずれかの値である項目を探します。
      • Ipm。Note.Rules.ExternalOofTemplate.Microsoft
      • Ipm。Note.Rules.OofTemplate.Microsoft

たとえば、次のスクリーンショットを考えてみましょう。

削除できる OOF ルールのスクリーンショット。

  • これら 2 つのメッセージ クラスのいずれかに属する項目を右クリックし、[ メッセージの削除] を選択します。

    注:

    参照されている項目以外の項目は削除しないでください。

    削除できる OOF ルールのスクリーンショット。

  • [アイテムの削除] ダイアログ ボックスで、[削除スタイル] の下の [DELETE_HARD_DELETEを渡す (回復不能) を完全に削除する] を選択し、[OK] を選択します

    [削除スタイル] の下の [DELETE_HARD_DELETEを渡す (回復不能) を完全に削除する] オプションを選択します。

  • 次のコマンドを使用して、OOF 機能を無効にしてから再度有効にします。

    Set-MailboxAutoReplyConfiguration \<identity> -AutoReplyState Disabled
    Set-MailboxAutoReplyConfiguration \<identity> -AutoReplyState Enabled

  • OOF 機能が期待どおりに機能し、症状が発生しなくなったかどうかを確認します。

解決策 3

OOF 応答が返されなくなった場合は、ルール クォータを超えている可能性があります。 そのため、内部および外部の OOF 規則を作成できません。 この問題を解決するには、次の手順を実行します。

  1. ルールクォータを増やします。 これを行うには、次の記事の手順に従います。

    ユーザーが Outlook またはOutlook Web Appで新しいルールを作成できない

  2. Information Store でのクォータ情報のキャッシュにより、更新されたクォータ値を有効にするには最大 2 時間が必要になる場合があります。

  3. 解像度 2 を繰り返します。

解決策 4

リモート ドメインの AllowedOFFType 値が None の場合、OOF メッセージは外部で起動されません。 外部 OOF を許可するには、この値を External に設定する必要があります。 既定では、この値は [なし] に設定されています。 リモート ドメインを検索すると、既定値は特定のエントリによってオーバーライドされます。 したがって、ユーザーがユーザーに @contoso.com 送信していて、リモート ドメイン設定にエントリがある Contoso.com 場合は、その特定のエントリに AllowedOOFType 値が使用されます。 の Contoso.comエントリがない場合は、既定の (*) リモート ドメインが使用されます。

Get-RemoteDomain | select Name,AllowedOOFType