エラー AADSTS50003 - 署名キーが構成されていません

この記事では、Microsoft Entra IDと統合された SAML ベースのシングル サインオン (SSO) 構成済みアプリにサインインしようとすると、"エラー AADSTS50003 - 署名キーが構成されていません" というエラー メッセージが表示される問題について説明します。

現象

SAML ベースの SSO を使用して ID 管理にMicrosoft Entra IDを使用するように設定されているアプリケーションにサインインしようとすると、エラーが発生AADSTS50003します。

原因

アプリケーション オブジェクトが破損しており、アプリケーション用に構成された証明書Microsoft Entra ID認識されません。

解決方法

新しい証明書を削除して作成するには、次の手順に従います。

  1. [SAML ベースの SSO 構成] 画面で、[SAML 署名証明書] セクションの [新しい証明書の作成] を選択します。
  2. [有効期限] を選択し、[ 保存] をクリックします。
  3. [ 新しい証明書をアクティブにする] をオンにして、アクティブな証明書をオーバーライドします。 次に、ウィンドウの上部にある [保存 ] をクリックし、同意してロールオーバー証明書をアクティブにします。
  4. [ SAML 署名証明書 ] セクションで、[ 削除 ] をクリックして 未使用 の証明書を削除します。

詳細情報

Active Directory 認証エラー コードと承認エラー コードの完全な一覧については、「Microsoft Entra認証と承認のエラー コード」を参照してください。

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