Microsoft Dynamics 365 でソリューション パッチをインポートしようとしたときにエラー コード 80048539が発生する
この記事では、Microsoft Dynamics 365 でソリューション パッチをインポートしようとしたときに発生する可能性があるエラー コード 80048539 の解決策について説明します。
適用対象: Microsoft Dynamics 365
元の KB 番号: 4471087
現象
Microsoft Dynamics 365 でソリューション パッチをインポートしようとすると、次のエラーが発生します。
ソリューションのインポート: [ソリューション パッチ名] が失敗しました。
エラー コード80048539。
ログ ファイルをダウンロードして Excel で開くと、次のような詳細が表示されます。
現象 1 の詳細:
エラー 0x80048539
ソリューション マニフェストのインポート: FAILURE: 親バージョン 1.1.0.0 ではパッチ バージョン 1.0.1.0 が無効です
現象 2 の詳細:
エラー 0x80048539
ソリューション マニフェストのインポート: FAILURE: ソリューション MyPatchTesting_Upgrade既に存在します。
原因
注:
make.powerapps.com を使用してアンマネージド ソリューションの更新プログラムをインポートし、このエラーを取得する場合、Microsoft はこの問題を認識しており、修正プログラムに取り組んでいます。 この問題を回避するには、[ 詳細設定] を 開き、[ 更新] オプション (推奨されません) を選択します。
エラー コード 80048539 は、無効な修正プログラムがインポートされていることを示します。 次のような潜在的な原因がいくつかあります。
原因 1
上記の「現象 1 の詳細」セクションに記載されているエラーの詳細が表示される場合は、次の手順に従います。
ソリューションパッチのバージョンは、既にインストールされているソリューションのバージョンより低くなっています。 たとえば、SolutionA という名前のソリューションがバージョン 1.1.0.0 で既にインストールされており、バージョン 1.0.1.0 のパッチをインポートしようとしています。
原因 2
上記の「現象 2 の詳細」セクションに記載されているエラーの詳細が表示される場合は、次の手順に従います。
これは、そのソリューションのアップグレードが既にインポートされていて、まだ適用されていない場合に発生する可能性があります。 既存のソリューションのアップグレードであるソリューションをインポートした後、ソリューションのインポートが終了すると、ソリューションのアップグレードを適用するボタンが表示されます。 このソリューションのソリューション アップグレードのインポート前にそのボタンを選択しなかった場合は、ソリューションの一覧でソリューションを見つけて、[ ソリューションのアップグレードの適用 ] ボタンを選択する必要があります。
解決方法
解決方法 1
上記の「現象 1 の詳細」セクションに記載されているエラーの詳細が表示される場合は、次の手順に従います。
インポートしようとしているソリューションパッチのバージョンが、既にインストールされているソリューションよりも高いバージョンであることを確認します。
解決方法 2
上記の「現象 2 の詳細」セクションに記載されているエラーの詳細が表示される場合は、次の手順に従います。
[設定]、[カスタマイズ] の順に移動し、[ソリューション] を選択します。 アップグレードしようとしている既存のインストール済みソリューションを選択し、[ ソリューションのアップグレードの適用] を選択します。
フィードバック
フィードバックの送信と表示