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シナリオ: Azure HDInsight での Apache Ambari の古いアラート

この記事では、Azure HDInsight クラスターと対話するときの問題のトラブルシューティング手順と可能な解決策について説明します。

問題

Apache Ambari UI では、次のようなアラートが表示される場合があります。

Apache Ambari の古いアラートの例。

原因

Ambari エージェントでは、多くのリソースの正常性が継続的に監視されます。 アラートは、特定のクラスターのプロパティが事前に定義されたしきい値内にあるかどうかを通知するように構成できます。 各リソース チェックが実行された後、アラートの条件が満たされている場合、Ambari エージェントから Ambari サーバーへ状態が報告され、アラートがトリガーされます。 アラート プロファイルの間隔に従ってアラートが確認されていない場合、サーバーでは Ambari Server Stale Alerts アラートがトリガーされます。

定義された間隔で正常性チェックが実行されない原因はいくつかあります。

  • ホストの使用率が高い (CPU 使用率が高くなっている) ため、Ambari エージェントがアラートを時間通りに実行するのに十分なシステム リソースを取得できません。

  • クラスターでは負荷の高い期間中に多くのジョブまたはサービスを実行しているため、ビジー状態です。

  • クラスター内のいくつかのホストが多数のコンポーネントをホストしているため、多くのアラートの実行を要求されています。 コンポーネントの数が多い場合、アラート ジョブがスケジュールされた間隔で実行されない可能性があります。

解決方法

Ambari の古いアラートに関する問題を解決するには、次の方法を試してください。

アラート間隔の時間を長くする

個々のアラート間隔の値を、クラスターの応答時間と負荷に基づいて大きくすることができます。

  1. Apache Ambari UI で、 [アラート] タブを選択します。
  2. 目的のアラート定義名を選択します。
  3. 定義から、[Edit](編集) を選択します。
  4. [Check Interval](チェック間隔) の値を大きくし、 [保存] を選択します。

Ambari Server Alerts のアラート間隔の時間を長くする

  1. Apache Ambari UI で、 [アラート] タブを選択します。
  2. [Groups](グループ) ドロップダウン リストで、[AMBARI Default](AMBARI の既定値) を選択します。
  3. [Ambari Server Alerts] アラートを選択します。
  4. 定義から、[Edit](編集) を選択します。
  5. [Check Interval](チェック間隔) の値を大きくします。
  6. [Interval Multiplier](間隔の乗数) の値を大きくし、 [保存] を選択します。

アラートを無効にしてから再度有効にする

古いアラートを破棄するには、それを無効にしてから再度有効にします。

  1. Apache Ambari UI で、 [アラート] タブを選択します。
  2. 目的のアラート定義名を選択します。
  3. 定義から、UI の右端にある [有効] を選択します。
  4. [確認] ポップアップ ウィンドウで、 [無効化の確認] を選択します。
  5. ページに表示されているすべてのアラート "インスタンス" が消去されるまで数秒待ちます。
  6. 定義から、UI の右端にある [無効] を選択します。
  7. [確認] ポップアップ ウィンドウで、 [有効化の確認] を選択します。

アラートの猶予期間を長くする

Ambari エージェントには、構成されたアラートがスケジュールどおりに実行されなかったことが報告されるまでに、猶予期間があります。 アラートがスケジュールどおりの時刻に実行されなかったが、猶予期間内に実行された場合、古いアラートは生成されません。

既定の alert_grace_period 値は 5 秒です。 /etc/ambari-agent/conf/ambari-agent.ini でこの設定を構成できます。 一定の間隔で古いアラートが発生しているホストについては、値を 10 に増やしてみてください。 その後、Ambari エージェントを再起動します。

次のステップ

ここで問題が説明されていない場合、または解決できない場合は、次のいずれかのチャネルを参照してください。

  • Azure コミュニティ サポートで、Azure の専門家からの回答をご確認ください。

  • X で @AzureSupport にお問い合わせください。こちらは、カスタマー エクスペリエンスの向上を目的とした、Microsoft Azure の公式アカウントです。 Azure コミュニティを適切なリソース (回答、サポート、エキスパート) と結び付けます。

  • さらにヘルプが必要な場合は、Azure portal からサポート リクエストを送信します。 表示するには、ポータル メニューから [ヘルプ] ( ? ) を選択するか、 [Help + support](ヘルプとサポート) ウィンドウを開きます。 詳細については、「Azure サポート要求を作成する方法」を参照してください。

    サブスクリプションの管理と課金のサポートは、Microsoft Azure サブスクリプションに含まれています。 テクニカル サポートは、Azure サポート プランを通じて提供されます。