GraphEdit の使い方

DirectX SDK をインストールすると、[スタート] メニューの [Microsoft DirectX SDK] の下の [DX Utilities] に GraphEdit が表示される。実行可能ファイルは GraphEdt.exe である。

次に、GraphEdit を使って実行できることについて簡単に説明する。これらの機能 (およびその他の機能) の詳細については、GraphEdit アプリケーション ヘルプを参照すること。

ファイル再生グラフの作成

GraphEdit を使うと、ファイルを再生するフィルタ グラフを作成できる。この機能は、アプリケーションで IGraphBuilder::RenderFile メソッドを呼び出すのと同じである。[File] メニューの [Render Media File] をクリックする。GraphEdit の [Open File] ダイアログ ボックスが表示される。マルチメディア ファイルを選択して [Open] をクリックする。選択したファイルを再生するためのフィルタ グラフが GraphEdit で作成される。

特定の URL にあるメディア ファイルをレンダリングすることもできる。[File] メニューの [Render URL] をクリックする。URL を指定するダイアログ ボックスが表示される。

カスタム フィルタ グラフの作成

GraphEdit では、システムに登録されているフィルタを使ってカスタム フィルタ グラフを作成できる。[Graph] メニューの [Insert Filters] をクリックする。システムに登録されているフィルタの一覧をフィルタ カテゴリ別に示すダイアログ ボックスが表示される。GraphEdit はレジストリの情報からこの一覧を作成する。次の図にこのダイアログ ボックスを示す。

フィルタの一覧を示すダイアログ ボックス

グラフにフィルタを追加するには、フィルタの名前を選択して [Insert Filters] をクリックするか、フィルタ名をダブルクリックする。フィルタを追加した後、1 つのフィルタの出力ピンからもう 1 つのフィルタの入力ピンにマウスをドラッグすると、2 つのフィルタを接続できる。ピンが接続を受け入れると、ピンを接続する矢印が表示される。

2 つのフィルタの接続

グラフの実行

GraphEdit でフィルタ グラフを作成した後、グラフを実行し、グラフが予測どおりに動作するかどうかを確認できる。[Graph] メニューには、[Play]、[Pause]、および [Stop] のメニュー コマンドがある。これらのコマンドはそれぞれ、IMediaControl メソッドである RunPause、および Stop を呼び出す。[GraphEdit] ツール バーにも、これらのコマンドを実行するボタンが表示される。

[Pause]、[Play]、[Stop] ボタン

GraphEdit の [Stop] コマンドは、最初にグラフをポーズし、タイム ゼロをシークする (グラフはシーク可能とする)。ファイルを再生するために、この動作でビデオ ウィンドウが最初のフレームにリセットされる。次に、GraphEdit は IMediaControl::Stop を呼び出す。

グラフがシーク可能な場合は、ツール バーの下に表示されるスライダ バーをドラッグすると、グラフをシークできる。スライダ バーをドラッグすると、IMediaSeeking::SetPositions メソッドが呼び出される。

プロパティ ページの表示

カスタム プロパティ ページをサポートしているフィルタもある。カスタム プロパティ ページは、フィルタのプロパティを設定するためのユーザー インターフェイスを提供する。GraphEdit でフィルタのプロパティ ページを表示するには、フィルタを右クリックし、ポップアップ ウィンドウの [Properties] をクリックする。フィルタで定義されているプロパティ シートがある場合は、プロパティ シートがプロパティ ページに表示される。さらに、GraphEdit にはフィルタの各ピンのプロパティ シートが含まれている。ピン プロパティ シートは、フィルタではなく GraphEdit によって定義される。ピンが接続されている場合は、ピン プロパティ シートに接続のメディア タイプが表示される。ピンが接続されていない場合は、ピンの優先メディア タイプが表示される。