この記事では、Microsoft Dynamics CRM for Phone and Tablets が、 TokenLifetime
プロパティの長さのために Dynamics CRM 組織に接続できない問題の解決策について説明します。
適用対象: Microsoft Dynamics CRM 2013、Microsoft Dynamics CRM 2013 Service Pack 1
元の KB 番号: 3034570
症状
Microsoft Dynamics CRM モバイル クライアント アプリケーションのいずれかで Microsoft Dynamics CRM 組織を設定しようとすると、認証は終わりのないループに入り、アプリケーションは何らかの認証を実行しようとしているように見えますが、完了しません。
原因
証明書利用者の AD FS の TokenLifetime
プロパティの既定値よりも大きいと、この認証ループが発生する可能性があります。
解決方法
TokenLifetime
の推奨値は、既定値の 0 に設定する必要があります。これは、600 分または 10 時間を意味します。 代わりにフェデレーション サービスで SSOLifetime オプションを使用すると、ユーザーがこれらの Microsoft Dynamics CRM モバイル アプリケーションで資格情報を頻繁に導入する必要を防ぐことができます。 SSOLifetime の既定値は 480 分または 8 時間です。
詳細
ADFS の SSO Lifetime
プロパティを変更する方法については、「 Set-ADFSPropertiesを参照してください。
PowerShell を使用して ADFS 証明書利用者の TokenLifetime
プロパティを変更する方法については、「 要求ベースの認証とセキュリティ トークンの有効期限を参照してください。