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Microsoft Dynamics CRM 2011 Outlook クライアントが外部 IFD Web アドレスへの構成に失敗する

この記事では、ユーザーが Microsoft Dynamics CRM Outlook クライアントを外部 Web アドレスに構成できず、エラー 資格情報を認証できないため Microsoft Dynamics CRM サーバーに接続できません が発生する問題の解決策について説明します。

適用対象: Microsoft Dynamics CRM 2011
元の KB 番号: 2912175

現象

Active Directory 証明書サービス (ADFS) を使用して Microsoft Dynamics CRM 2011 展開がインターネットに接続する展開 (IFD) 用に構成されている場合、ユーザーは Microsoft Dynamics CRM Outlook クライアントを外部 Web アドレスに構成しようとしたときに、次のエラーを受け取ることがあります。

資格情報を認証できないため、Microsoft Dynamics CRM サーバーに接続できません。 接続を確認するか、管理者に問い合わせてください。

構成ログを確認すると、次の例外もキャプチャされます。

URL への接続中にエラーが発生しました: https://crmorg.domain.com/XRMServices/2011/Discovery.svc 例外: System.ServiceModel.EndpointNotFoundException: メッセージを受け取ることができるエンドポイントが https://adfs.domain.com/adfs/services/trust/13/username でリッスンしていません。

ただし、ユーザーは Web ブラウザーからエラーなしで外部 URL にアクセスできる場合があります。

原因

/adfs/services/trust/13/username エンドポイントを有効にすることができます。 このエンドポイントが有効になっている場合、クライアントは usernamemixed エンドポイントと kerberosmixed エンドポイントに到達できないため、認証が失敗します。

解決方法

/adfs/services/trust/13/username エンドポイントを無効にして、ADFS サービスを再起動します。 このアクションを実行するには、次の手順を参照してください。

  1. AD FS 管理コンソールを開きます。
  2. 左側のナビゲーション ウィンドウで、 Service を展開し、 Endpoints を選択します。
  3. エンドポイントの一覧で、/adfs/services/trust/13/username エンドポイントを見つけて右クリックします。
  4. [ 表示不可を選択します。
  5. AD FS サービスを再起動します。