次の方法で共有


メール アドレスが別のorganization エラー用に構成されているため、メールが同期されていません

この記事では、Microsoft Dynamics 365でメールボックスをテストして有効にしようとすると、この記事に記載されているエラーの解決策について説明します。

適用対象: Microsoft Dynamics CRM
元の KB 番号: 4053618

現象

Microsoft Dynamics 365でメールボックスをテストして有効にしようとすると、次のいずれかのアラートがログに記録されます。

メールボックス名>メールボックスのメール アドレスが別のDynamics 365 organization用に<構成されているため、受信メールは同期されません。 現在のorganizationのメールボックスをテストして有効にし、プライマリ以外の組織の同期方法を [なし] に変更するように管理者に依頼します。
Email サーバー エラー コード: IncomingIncorrectCrmOrgError

電子メール アドレスの電子メール アドレス<>が別のDynamics 365 organization用に構成されているため、送信メールは送信されません。 管理者に、現在のorganizationのメールボックスをテストして有効にするよう依頼し、非優先組織の同期方法を [なし] に変更します。
Email サーバー エラー コード: OutgoingIncorrectCrmOrgError

メールボックス<メールボックス名>のメール アドレスが別の Microsoft Dynamics 365 organizationで構成されているため、予定、連絡先、タスクを同期できません。 ベスト プラクティスは、プライマリ organizationでメールボックスをテストして有効にするときに構成を上書きすることです。 また、非プライマリ組織のメールボックスの同期方法を [なし] に変更します。
Email サーバー エラー コード: ExchangeSyncIncorrectCrmOrgError

アラートの [詳細の表示 ] を選択すると、次の詳細も表示される場合があります。

例外: Exchange の構成フォルダーのチェックと更新に失敗しました。

原因

Exchange メールボックスは、1 つの Microsoft Dynamics 365 organizationとの同期 Server-Side 使用するようにのみ構成できます。 これらのアラートは、複数の Microsoft Dynamics 365組織がある場合にログに記録され、複数の組織との同期 Server-Side 使用するようにメールボックスを構成しようとします。

解決方法

プライマリ Microsoft Dynamics 365 organizationでメールボックスをテストして有効にする

  1. Exchange メールボックスとの同期を使用するように構成 Server-Side Microsoft Dynamics 365 organizationにサインインします。

  2. [設定] に移動し、[Email構成] を選択します。

  3. [ メールボックス] を選択します

  4. 選択したビューを [自分のアクティブなメールボックス] から [アクティブなメールボックス] に変更します。

  5. Server-Side 同期に対して有効にするメールボックスを選択し、[ テスト] & [メールボックスの有効化] ボタンを選択 します。

    重要

    表示されるダイアログの チェック ボックスをオン にし、[ OK] を選択します。 Exchange メールボックスが以前に別の Microsoft Dynamics 365 organizationで構成されていた場合、このチェック ボックスをオンにすると、代わりに Exchange メールボックスが更新され、この Microsoft Dynamics 365 organizationと同期されます。 このチェック ボックスをオンにせず、Exchange メールボックスが既に別の Microsoft Dynamics 365 organizationで構成されている場合、テストは失敗し、この記事の「現象」セクションに記載されているアラートの 1 つをログに記録します。

  6. テスト & Enable プロセスが完了するまで待ちます。 テスト結果が [成功] でない場合は、メールボックス レコード内の [アラート] 領域を確認します。

プライマリ以外の Microsoft Dynamics 365 組織の同期方法を [なし] に変更する

複数の Microsoft Dynamics 365 organizationがある場合は、非プライマリ organization内のユーザーのメールボックスを、同期方法の [なし] に設定するように構成します。 たとえば、運用環境に使用される Microsoft Dynamics 365 organizationと、テストに使用される別の Microsoft Dynamics 365 organizationがある場合、ユーザーはいずれかの組織で Server-Side 同期を使用できますが、両方を使用することはできません。

  1. システム管理者ロールを持つユーザーとして、プライマリ以外の Microsoft Dynamics 365 organizationにサインインします。
  2. [設定] に移動し、[Email構成] を選択します。
  3. [ メールボックス] を選択します
  4. 選択したビューを [自分のアクティブなメールボックス] から [アクティブなメールボックス] に変更します。
  5. Server-Side 同期のために無効にするメールボックスを開きます。
  6. 同期方法のオプションを [なし] に変更し、[ 保存] & [閉じる] を選択します。