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ユーザー ライセンスの割り当てを解除した後のエラー

症状

通常のメールボックスに保留が適用されているユーザーの Microsoft 365 または Office 365 ライセンスの割り当てを解除すると、次の現象が発生します。

  • Microsoft 365 管理センターは、ポップアップ ウィンドウの Account タブに次のいずれかのエラー メッセージが表示され、ユーザーの詳細が表示されます。

    • Exchange: 不明なエラーが発生しました。 相関 ID:12ffde19-5350-4fb6-baec-3359e4042eb8 を参照してください。
    • コマンドレット Disable-Mailbox の実行に失敗しました。.;Exchange: 不明なエラーが発生しました。
  • Microsoft Entra ID でユーザーの属性に加えた変更は、Exchange Online に同期されません。

  • ユーザーのメールボックスは、 非アクティブなメールボックスに変更する代わりにアクティブなまま

この問題は、Exchange Online およびハイブリッド Exchange 環境のクラウド ユーザーに影響する可能性があります。

原因

この問題は、通常のメールボックスに保留が適用されているアクティブ ユーザーのライセンスの割り当てを解除した場合に発生します。 この動作は仕様によるものです。

ユーザー ライセンスが割り当てられていないときにメールボックスに保留が適用されていない場合、Exchange Online はユーザー アカウントからメールボックスを切断し、30 日後にメールボックスを完全に削除します。 ただし、ユーザー ライセンスが割り当てられていないときに保留が存在する場合は、コンテンツを保持する必要があるメールボックスを切断できないため、Exchange Online はエラーを生成します。

解決策

この問題を修正するには、次の手順に従ってください。

  1. アカウント エラーがあるテナント内のすべてのユーザーを特定します

  2. アカウント エラーが発生したユーザーごとに、目的に基づいて次のオプションから選択します。

アカウント エラーがあるテナント内のすべてのユーザーを特定する

  1. 次の PowerShell コマンドレットを実行して、 Microsoft Graph PowerShell に接続します

    Install-Module Microsoft.Graph -Scope AllUsers -Repository PSGallery -Force
    Connect-MgGraph -Scopes User.Read.All
    
  2. 次の Get-MgBetaUser PowerShell コマンドレットを実行して、エラーがあるテナント内のすべてのユーザー アカウントを一覧表示します。

    Get-MgBetaUser -All | Select-Object -Property UserPrincipalName -ExpandProperty ServiceProvisioningErrors | FL UserPrincipalName, AdditionalProperties
    
  3. リストされている各ユーザーの AdditionalProperties パラメーターの ErrorDescription 値を確認します。 次の例では、エラーの説明は、Exchange Online が訴訟ホールドを持つメールボックスを無効にできないことを確認します。

    Get-MgBetaUser PowerShell コマンドレットからの出力のスクリーンショット。

ユーザー ライセンスの割り当てを解除し、メールボックスの内容を保持する

アカウント エラーが発生したユーザー メールボックスを非アクティブなメールボックスに変換するには、次の手順に従います。

  1. アカウント エラーを解決するには ユーザー ライセンスを再割り当てします。 ユーザー アカウントのライセンスが付与されている間は、次の手順を完了する必要があります。

  2. Microsoft Entra Connect を使用してオンプレミスの Active Directoryから同期されるクラウド ユーザー アカウントの場合は、次のいずれかのオプションを選択します。

    • オンプレミス アカウントを削除します。

    • オンプレミス アカウントを、Microsoft Entra ID と同期しない 組織単位 に移動します。

    • オンプレミス アカウントが Microsoft Entra ID に同期されないようにする attribute 値を Microsoft Entra Connect で指定します。

  3. クラウドで直接作成されたユーザー アカウントの場合は、ユーザー アカウントを削除

これらの手順を完了すると、Exchange Online は次の操作を実行します。

  • すぐにユーザー ライセンスの割り当てを解除し、使用可能なライセンスのプールに追加します。

  • 削除されたユーザー アカウントを、Microsoft 365 管理センターと Microsoft Entra 管理センターの Deleted users リストに追加します。 Exchange Online は、復元しない限り、削除されたユーザー アカウントを 30 日後に完全に削除します。 ユーザー アカウントを復元する場合は、必ずライセンスを再割り当てしてください。

  • ユーザー メールボックスから非アクティブなメールボックスへの変換を開始します。 ユーザー アカウントが完全に削除されると、変換が完了します。

    ヒント

    非アクティブなメールボックスは電子メールコンテンツを保持し、作成後にユーザー ライセンスを必要としません。 ユーザー メールボックスを非アクティブなメールボックスに変換する方法の詳細については、「 非アクティブなメールボックスの作成と管理を参照してください。 組織内の非アクティブなメールボックスを一覧表示するには、「 非アクティブなメールボックスの表示を参照してください。

ユーザー ライセンスの割り当てを解除し、メールボックスのコンテンツを削除する

  1. アカウント エラーを解決するには ユーザー ライセンスを再割り当てします。 次の手順は、ユーザー アカウントのライセンスが付与されている間に完了する必要があります。

  2. メールボックスの 1 つ以上の保留を削除するには、次の手順に従います。

    1. 保留を特定する

    2. 保留リストを削除する

    3. 結果の遅延保留を削除する

  3. ユーザー ライセンスの割り当てを解除する

これらの手順を完了すると、Exchange Online はユーザー アカウントからメールボックスを切断し、30 日後または 60 日後にメールボックスを完全に削除します ([回復性の解除 有効にした場合