Microsoft Edge の Web サイトにアクセスすると、サイトが安全でない可能性があると判断された場合、 Microsoft Defender SmartScreen によってサイトがブロックされたり、警告が表示されたりすることがあります。 この記事では、サイトが安全でない可能性があるかどうかを判断するために SmartScreen が使用する基準と、サイトが安全でないと誤ってマークされている場合に問題を解決する方法について説明します。
症状
Web サイトにアクセスすると、サイトが安全でないと報告されたことを示す警告ページが表示されます。
原因
Microsoft Defender SmartScreen は、次の表に示すように、いくつかの要因に基づいて、サイトが安全でない可能性があるかどうかを判断します。
| ディメンション | Description |
|---|---|
| URL 評判 | 新しく登録されたドメイン、悪意のある履歴、ホスティング プロバイダー、トラフィック量 |
| ページ コンテンツ | 詐欺的なフォーム、悪意のあるスクリプト、またはフィッシング ページの存在 |
| ファイルの動作 | 機密性の高いファイルをダウンロードするかどうかとその署名の状態 |
| TLS セキュリティ | 証明書の有効性とプロトコルのバージョン |
| ユーザーフィードバック | レポートの数と信頼レベル |
| 動的な動作 | JavaScript アクティビティ、リダイレクト、難読化 |
サイトでこれらのディメンション チェックが失敗した場合、SmartScreen はサイトを安全でないと報告します。
解決策
安全なサイトに対して警告またはブロックが誤って表示されたと思われる場合は、次の手順を使用して Microsoft に報告できます。
Web サイトの所有者である場合
ブロック ページの [詳細情報] ヘッダーの下にある [このサイトに脅威が含まれていない (マルウェア/フィッシング) ことを報告する] を選択します。
SmartScreen 評判グループからの確認メール メッセージを待ちます。
問題が緊急である場合、または評判グループの調査後に応答が必要な場合は、評判グループからのメッセージに返信して懸念事項を提示します。
Web サイトの所有者でない場合
Web サイトの所有者に連絡し、「Web サイト所有者の場合」の手順を使用して問題 を報告することをお勧めします。
サイト所有者とユーザーの両方が、 WDSI ファイル送信ポータルを使用して問題を報告できます。 分析のためにファイルを送信する方法の詳細については、「分析 のためにファイルを送信する」を参照してください。
サイトがブロックされないようにする
SmartScreen がサイトをブロックする可能性を減らすには、次の手順を実行します。
- HTTPS を有効にし、有効な証明書を使用します。
- iframe が不明なサード パーティのコンテンツを読み込むのをブロックします。
- コンテンツ セキュリティ ポリシー (CSP) とその他のセキュリティで保護された応答ヘッダーを使用します。
- WebShellやトロイの木馬、疑わしいアップロードファイルを定期的にスキャンしてください。
- ドメインの評判を維持し、ホスティングまたは DNS に頻繁に変更を加えないようにします。