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Dynamics 365 メールボックスのテスト時に "Http サーバーから許可されていない例外が返されました" というエラーが表示される

この記事では、Microsoft Dynamics 365 のメールボックス レコードの [ テスト] ボタンと [メールボックスの有効化 ] ボタンを選択したときに発生するエラーの解決策について説明します。

適用対象: Microsoft Dynamics 365
元の KB 番号: 4483440

現象

Dynamics 365 のメールボックス レコードで Test & Enable Mailbox ボタンを選択すると、テスト結果セクションに Failure が表示され 次のアラートがログに記録されます。

電子メール サーバーへのセキュリティで保護された接続の確立中にエラーが発生したため、"メールボックスは Dynamics 365 に接続されました" というメール メッセージを送信できません。 メールボックス [メールボックス名] が同期されませんでした。 電子メール サーバー プロファイルの所有者に Microsoft Exchange Online が通知されました。
電子メール サーバーのエラー コード: Http サーバーから許可されていない例外が返されました。

Details を選択すると、次の詳細が表示されます。

エラー : System.Net.WebException: 要求が HTTP 状態 403: 禁止で失敗しました。
at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
at System.Web.Services.Protocols.SoapHttpClientProtocol.EndInvoke(IAsyncResult asyncResult)
at Microsoft.Crm.Asynchronous.EmailConnector.ExchangeServiceBinding.EndCreateItem(IAsyncResult asyncResult)
at Microsoft.Crm.Asynchronous.EmailConnector.ExchangeOutgoingEmailProvider.EndCreateItem()

原因

Dynamics 365 は、Exchange Web Services (EWS) 要求を使用して Microsoft Exchange と通信します。 EWS が無効になっている場合、このエラーが発生します。 Exchange で EWS が無効または制限される可能性のあるいくつかの方法を次に示します。

  1. EWS はメールボックスに対して無効になっています。
  2. EWS は組織全体で無効になっています。
  3. EwsApplicationAccessPolicyEnforceAllowList に設定されており、EwsAllowListは Dynamics 365 からのアクセスを許可しません。
  4. EwsApplicationAccessPolicyEnforceBlockList に設定され、EwsBlockListには Dynamics 365 が含まれています。

解決方法

一部のメールボックスでのみ問題が発生した場合に、メールボックスに対して EWS が無効になっているかどうかを確認する

  1. まず、次の PowerShell コマンドを使用して、特定のメールボックスに対して EWS が無効になっているかどうかを確認します。

    Get-CASMailbox <mailbox-alias> | ft EwsEnabled
    
  2. EwsEnabledFalse に設定されている場合は、次のコマンドを使用して有効にします。

    Set-CASMailbox <mailbox-alias> -EwsEnabled $True
    

    重要

    このコマンドを実行すると、設定の変更が有効になるまでに最大 120 分かかる場合があります。

EWS が組織レベルで無効になっているか、EwsAllowList によって EWS トラフィックが制限されているかどうかを確認する

  1. 次の PowerShell コマンドを使用して、組織レベルの設定を確認します。

    Get-OrganizationConfig |ft Name, EwsEnabled,EwsApplicationAccessPolicy,EwsBlockList,EwsAllowList
    
  2. EwsEnabledFalse に設定されていないことを確認します。 有効にする場合は、次を使用します。

    Set-OrganizationConfig -EwsEnabled $True
    

    重要

    このコマンドを実行すると、設定の変更が有効になるまでに最大 120 分かかる場合があります。

  3. EwsApplicationAccessPolicyEnforceAllowList に設定されている場合は、Dynamics 365 (CRM) と Exchange との通信を許可する CRM (CRM/*など) の値がEwsAllowListに含まれているかどうかを確認します。 そうでない場合は、次のコマンドを使用して、CRM/* および許可するその他のアプリケーションを含むようにリストを更新します。 この例 <PreviousAllowedList> は、以前に許可リストに含まれているアプリケーションの一覧です。

    Set-OrganizationConfig -EwsApplicationAccessPolicy:EnforceAllowList -EwsAllowList:CRM/*,<PreviousAllowedList>
    

    重要

    このコマンドを実行すると、設定の変更が有効になるまでに最大 120 分かかる場合があります。

  4. EwsApplicationAccessPolicyEnforceBlockList に設定されている場合は、EwsBlockListに CRM (CRM/*など) の値が含まれているかどうかを確認します。これにより、Dynamics 365 (CRM) が Exchange と通信できなくなります。 その場合は、次のコマンドを使用して、CRM を含めないようにリストを更新します。 この例では <PREviousBlockList WITH CRM REMOVED> は、以前に CRM を除くブロックリストに含まれているアプリケーションの一覧です。

    Set-OrganizationConfig -EwsApplicationAccessPolicy:EnforceBlockList -EwsBlockList:<PreviousBlockList WITH CRM REMOVED>
    

    重要

    このコマンドを実行すると、設定の変更が有効になるまでに最大 120 分かかる場合があります。

詳細

PowerShell を使用して Exchange 設定を変更し、EWS へのアクセスを制御する方法の詳細については、次の記事を参照してください。