次の方法で共有


Azure Application Insights でデータ エクスポート オプションを使用できない

この記事では、新しい環境でログ分析と可観測性のために Application Insights を設定するときに、データ エクスポート オプションを使用できない問題の解決策について説明します。

症状

新しい環境でログ分析と監視のために Azure Application Insights を設定する場合、データ エクスポート オプションは使用できません。

原因

データ エクスポート機能は、マネージド環境でのみサポートされます。 環境が管理されていない場合、この機能は使用できません。 さらに、データ エクスポートに関連付けられている機能を有効にするには、Premium ライセンスが必要です。

解決策

データ エクスポート機能を有効にするには、次の手順に従います。

  1. 環境の種類を確認します。

    1. Power Platform 管理センターのに移動します。

    2. 環境設定を確認して、管理対象に設定されているかどうかを確認します。

      環境がアンマネージドの場合は、マネージドに変換します。 詳細な手順については、「管理センターの でマネージド環境を有効または編集するを参照してください。

  2. 続行する前に、必要なすべてのライセンスが設定されていることを確認します。 詳細については、「Microsoft Power Platform ライセンスの概要」を参照してください。

  3. ユーザーに必要な管理ロールの 1 つがあることを確認します。

    • Power Platform管理者
    • Dynamics 365 管理者
    • Microsoft 365 グローバル管理者
  4. 環境をマネージドに変換した後、Azure Application Insights でデータ エクスポート オプションが使用できるようになったかどうかを確認します。

  5. データのエクスポートを手動でスケジュールします。 詳細については、「データを Application Insightsにエクスポートする」を参照してください。

    現在、Azure Application Insights では、データ エクスポートの自動スケジュール設定はサポートされていません。 ユーザーは手動でエクスポートをスケジュールする必要があります。

詳細情報

Azure Application Insights (プレビュー) での会話診断の