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特権が不足しているため、ソリューションのインポートまたはアプリケーションのインストールエラーが発生する

この記事では、Microsoft Power Apps の権限がないためにソリューションをインポートしたり、アプリケーションをインストールしたりできない問題の回避策について説明します。

適用対象: Power Platform、ソリューション

現象

ユーザーがソリューションをインポートしようとしたり、 Power Platform 管理センターにアプリケーションをインストールしようとすると、次のようなエラー メッセージが表示されます。

Microsoft.Crm.CrmSecurityException: プリンシパル ユーザー (Id=... accessMode=1...(関連付けられたロールからフィルター処理された特権を持つライセンスのないユーザーのセットアップ/スタブ。ライセンスの割り当てを検討してください。))、 <コンポーネントの種類> 特権が不足しています...

原因

このエラーは、次の理由で発生します。

  • インポートまたはインストールを実行するユーザーのアクセス モードは、読み取り/書き込みではなく管理モードに設定されます。 有効な Power Platform ライセンスを持たないユーザーは、既定のアクセス モードの 管理モードになります。
  • ユーザーには、ソリューション内のすべてのコンポーネントを含むソリューションをインポートするための十分な特権がありません。

回避策

この問題を回避するには、次の方法を使用します。

  • インポートまたはインストールを実行しているユーザーのアクセス モードが 管理モードの場合は、 それを読み取り/書き込みに 更新し、 ユーザーに有効なライセンスを割り当てます
  • ユーザーのセキュリティ ロールを確認し、ソリューションに含まれるコンポーネントによって使用されるすべてのテーブルに対する 作成 および 更新 権限がユーザーに付与されているかどうかを確認します。 そうでない場合は、これらの特権を含む セキュリティ ロールをユーザーに割り当てますシステム管理者システム カスタマイザー、および Environment Maker セキュリティ ロールには、これらの特権があります。