"Dataverse ソリューションのプロセス 'RegisterFlowMachine' が非アクティブ化されているため、登録に失敗しました" エラー
この記事では、Microsoft デスクトップ用 Power Automateでコンピューターを登録できない問題の解決策について説明します。
現象
コンピューターを デスクトップ用 Power Automate に登録すると、登録が失敗し、次のエラー メッセージが表示されます。
Dataverse ソリューションのプロセス 'RegisterFlowMachine' が非アクティブ化されているため、登録に失敗しました。
原因
この問題は、Dataverse で RegisterFlowMachine プロセスが非アクティブ化されているために発生します。
詳細については、デスクトップ用 Power Automateに対してアクティブ化する必要があるプロセスを参照してください。
解決方法
この問題を解決するには、 RegisterFlowMachine プロセスをアクティブにします。
前提条件
https://[org].crm.dynamics.com
など、組織のエンドポイントにアクセスできる必要があります。
組織のエンドポイントは、コンピューターを登録する環境名を選択することで、 Environments で見つけることができます。
RegisterFlowMachine プロセスをアクティブ化する手順
Web ブラウザーで次の URL を開き ([org] を組織の識別子に置き換えます)、サインインします。
https://[org].crm.dynamics.com
右上隅にある歯車アイコンを選択し、 [Advanced Settings を選択します。
設定>カスタマイズ の順に選択します。
システムのカスタマイズを選択。
Components>Processes に移動し、View を All に設定します。 RegisterFlowMachine プロセスの状態を確認します。 状態が Deactivated の場合は、手順 6 に進みます。
RegisterFlowMachine プロセス名の前にあるチェック ボックスをオンにし、Activate を選択します。
Power Automate マシン ランタイム アプリケーションを開き、同じ環境で 登録 もう一度試します。
Power Automate 用にアクティブ化する必要があるプロセス
- BatchGetFlowMachineStatus
- GetPublicKey
- LeaveGroup
- PowerAutomateProxy
- RegisterFlowMachine
詳細
その他の登録の問題については、Power Automate での Machine 登録エラーを参照してください。