症状
Microsoft OneDrive 同期アプリにサインインすることはできません。次のエラー メッセージが表示されます。
ID プロバイダーのユーザー アカウントAADSTS50020テナントに存在せず、アプリケーション (OneDrive SyncEngine) にアクセスできません。
原因
この問題は、前のテナントのキャッシュされた ID によって発生する可能性があります。 これは最も一般的に、テナント間の移行中に発生します。
その他の考えられる原因の詳細については、「 エラー AADSTS50020 - ID プロバイダーのユーザー アカウントがテナントに存在しない」を参照してください。
解決策
この問題を解決するには、キャッシュされた Microsoft Office アカウント ID をレジストリから削除します。
Von Bedeutung
慎重にこのセクションの手順に従います。 レジストリを正しく変更しないと、重大な問題が発生する可能性があります。 変更する前に、問題が発生した場合に復元するためにレジストリをバックアップします。
レジストリエディタを起動します。
次のレジストリ エントリを見つけます。
HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\Common\Identity[ID] を右クリックし、[削除] を選択します。
手記:共有コンピューターのライセンス認証を有効にしている場合は、HKEY_USERS\<The user SID>\SOFTWARE\Microsoft\Office\16.0\Commonから ID レジストリ エントリも削除します。 現在サインインしているユーザーの SID を取得するには、コマンド プロンプト ウィンドウで whoami /user コマンドを実行します。 問題が解決しない場合は、「前のライセンス認証情報を手動でクリアする」の「セクション A: Office ライセンスとキャッシュされたアカウントを削除する」を展開し、「パート 1: 以前の Office ライセンス認証を削除する」と「パート 3: Windows 資格情報マネージャーに格納されている Office 資格情報を削除する」の手順に従います。
それでも問題が発生する場合は、次の手順に従います。
OneDrive for Business からサインアウトします。
次の場所にあるすべてのフォルダーを削除します。
- %localappdata%/Microsoft/OneAuth
- %localappdata%/Microsoft/IdentityCache