作成直後に電源喪失が発生すると、単純ボリュームにアクセスできなくなる可能性があります

この記事では、作成直後に電源喪失が発生した場合に単純なボリュームにアクセスできなくなる可能性がある問題の解決策について説明します。

適用対象: Windows 7 Service Pack 1
元の KB 番号: 2001877

現象

次のような状況を想定します。 Windows 7 では、ディスク管理で新しい単純なボリュームを作成するか、リムーバブルディスク上に DiskPart.exe します。 Windows 7 システムでボリュームの作成から数分以内に突然の電源喪失が発生した場合、電源喪失の前に作成したボリュームにアクセスできなくなる可能性があり、システムの電源を入れ直したときにドライブ文字が割り当てられない可能性があります。

さらに、ディスク管理では、ボリュームに状態 ("正常" など) やファイル システムの種類が一覧表示されていない可能性があります。 ディスク管理でボリュームを変更しようとすると、次のエラー メッセージが表示されることがあります。

ディスク管理コンソール ビューが最新ではないため、操作を完了できませんでした。 更新タスクを使用してビューを更新します。 問題が解決しない場合は、ディスク管理コンソールを閉じてから、ディスクの管理を再起動するか、コンピューターを再起動します。

原因

この問題は、電源喪失が発生した時点で、新しいボリュームの構成情報がディスクに書き込まれなかったために発生します。

解決方法

「現象」セクションで説明されている問題が発生している場合は、ボリュームを再インストールすると問題が解決します。 ボリュームを再インストールするには、次の手順に従います。

  1. デバイス マネージャーを開きます。 デバイス マネージャーにアクセスするには、[検索の開始] ボックスに「デバイス マネージャー」または「devmgmt.msc」と入力します。

  2. デバイス マネージャー開いたら、[ストレージ ボリューム] をクリックして、デバイス ツリーの [記憶域ボリューム] 部分を展開します。

  3. [ストレージ ボリューム] の下に、"不明なデバイス" と表示されているボリュームが表示されます。このデバイスを右クリックし、[アンインストール] を選択します。確認を求められたら、[OK] を選択します。

  4. メッセージが表示されたら、システムを再起動します。 システムの再起動が完了したら、ボリュームにアクセスできる必要があります。 システムの再起動を求められない場合は、デバイス マネージャーで右クリックし、[ハードウェアの変更をスキャンする] を選択します。スキャンが完了し、ボリュームのインストールが完了すると、ボリュームにアクセスできるようになります。

    注:

    ボリュームの作成から数秒以内に電力損失が発生した場合、まれに、上記の手順に従った後にボリュームのフォーマットを求められる場合があります。 この場合、電源喪失が発生した時点でファイル システム構成は書き込まれませんでした。 ボリュームの再フォーマットまたは再作成が必要な場合があります。

問題が解決された場合、このセクションの作業は完了していることになります。 問題が解決されていない場合は、サポートに問い合わせることができます。