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インターネット経由で Windows Server 2003 をアクティブ化しようとするとエラーが発生する: メッセージ番号 32777

この記事では、インターネット経由で Microsoft Windows Server 2003 をアクティブ化できない場合にエラーが発生する問題の回避策について説明します。

適用対象: Windows Server 2003
元の KB 番号: 816897

現象

インターネット経由で Windows Server 2003 をアクティブ化しようとすると、Windows 製品のライセンス認証が失敗し、次の問題が発生する可能性があります。

  • ユーザー名とパスワードの入力を求めるメッセージが表示されます。

  • 次のエラー メッセージが表示されます。

    アクティブ化サーバーとの接続を確立できません。 ネットワーク設定を確認し、インターネットに接続できることを確認してから、もう一度やり直してください。 メッセージ番号 32777。

ユーザー名とパスワードを入力したかどうかにかかわらず、Windows 製品のライセンス認証は失敗します。

原因

この問題は、次の両方の条件に該当する場合に発生します。

  • Microsoft Internet Explorer のセキュリティ強化構成は、サーバーで有効になっています。
  • 基本認証が有効になっているプロキシ サーバーを介してインターネットに接続します。

Internet Explorer セキュリティ強化構成 ( Internet Explorer のセキュリティ強化とも呼ばれます) では、証明書の失効が使用されます。 この証明書失効参照プロセスには、URL 取得操作が含まれます。 この場合、URL の取得はプロキシ サーバーを経由し、ログオンしているユーザーの明示的なコンテキストの外部で発生します。 そのため、基本認証では、ユーザー アカウント名とパスワードの入力を誤って求められます。 通常、ユーザーは証明書が検証されていることに気づいておらず、一連の証明書の検証中に繰り返しメッセージが表示される場合があります。

この問題を回避するには、以下のいずれかの方法を使用します。

注意

次の方法は、最も好ましい方法から最も優先される方法の順に一覧表示され、最も好ましい方法が最初に現れます。

回避策 1: 基本認証を使用しない

プロキシ サーバーで基本認証を使用しないでください。 基本認証を使用する必要がある場合は、基本認証の要件から証明書失効リスト (CRL) の URL を除外します。 これを行うには、プロキシ サーバーで認証されていない CRL の次の一覧を構成します。

  • http://crl.microsoft.com/pki/crl/productsMicrosoftProductSecureServer.crl
  • http://crl.microsoft.com/pki/crl/products/MicrosoftProductSecureCommunications.crl
  • http://crl.microsoft.com/pki/crl/products/MicrosoftRootAuthority.crl
  • http://www.microsoft.com/pki/crl/productsMicrosoftProductSecureServer.crl
  • http://www.microsoft.com/pki/crl/products/MicrosoftProductSecureCommunications.crl
  • http://www.microsoft.com/pki/crl/products/MicrosoftRootAuthority.crl

回避策 2: 電話を使用してアクティブ化する

Windows のライセンス認証を試みるときに、この記事の「 Symptoms 」セクションに記載されているエラー メッセージが表示される場合は、Windows のライセンス認証ウィザードの Telephone ボタンをクリックして、電話で Windows をライセンス認証します。

回避策 3: Internet Explorer で証明書の失効を無効にする

Internet Explorer で証明書の失効を無効にして、Windows のライセンス認証を成功させます。 これを行うには、次のステップに従います。

注意

Internet Explorer で証明書の失効を無効にしないことをお勧めします。

  1. Internet Explorer を起動します。

  2. [ツール] メニューの [インターネット オプション] をクリックします。

  3. [Advanced] タブをクリックし、[Settings] ボックスの一覧で次のチェック ボックスをオフにします。

    • 発行元の証明書失効を確認する
    • サーバー証明書の失効を確認する (再起動が必要)
  4. 適用をクリックし、OK をクリックします。

  5. Internet Explorer を終了して再起動します。

  6. Windows のライセンス認証を行います。

  7. Internet Explorer で、Tools メニューの Internet Options をクリックします。

  8. [ Advanced ] タブをクリックし、[ Settings の一覧で次のチェック ボックスをオンにします。

    • 発行元の証明書失効を確認する
    • サーバー証明書の失効を確認する (再起動が必要)
  9. 適用をクリックし、OK をクリックします。

  10. Internet Explorer を終了して再起動します。

詳細

他の問題によってエラー メッセージ番号 32777 が生成される可能性があるため、Setuplog.txt ファイルを表示して、この記事で説明されている問題がこのエラーの原因であるかどうかを判断できます。 状態コード 407 は、通常、この記事で説明されている問題の発生を示します。 Setuplog.txt ファイルに表示される状態コード 407 の例を次に示します。

<DateTime>,d:\dnsrv\base\ntsetup\oobe\msobmain\msobmain.cpp,4423,,DISPID_EXTERNAL_CONNECTEDTOINTERNETEx
<DateTime>,d:\dnsrv\base\ntsetup\oobe\msobcomm\connmgr.cpp,1560,,WPA HTTP サーバーへの接続を試みます
<DateTime>,d:\dnsrv\base\ntsetup\oobe\msobcomm\connmgr.cpp,2170,,現在のログオン セッションで RAS 自動ダイヤルが無効になりました
<DateTime>,d:\dnsrv\base\ntsetup\oobe\msobcomm\connmgr.cpp,1480,WPA HTTP サーバーからの HTTP 状態コード 407
<DateTime>,d:\dnsrv\base\ntsetup\oobe\msobcomm\connmgr.cpp,2184,,現在のログオン セッションの RAS Autodial の復元値
<DateTime>,d:\dnsrv\base\ntsetup\oobe\msobcomm\connmgr.cpp,1657,,WPA HTTP サーバーに接続できます
<DateTime>,OOBE トレース,0,,GetPreferredConnection: null
<DateTime>,OOBE トレース,0,,UseModem: false
<DateTime>,d:\dnsrv\base\ntsetup\oobe\msobmain\msobmain.cpp,3049,,DISPID_EXTERNAL_CONNECT
<DateTime>,d:\dnsrv\base\ntsetup\oobe\msobmain\msobmain.cpp,3054,,DISPID_EXTERNAL_RECONNECT
<DateTime>,d:\dnsrv\base\ntsetup\oobe\msobmain\msobmain.cpp,4500,,DISPID_EXTERNAL_ACTIVATE
<DateTime>,d:\dnsrv\base\ntsetup\oobe\msobmain\msobmain.cpp,6979,,waiting for response from m_pLicenseAgent->AsyncProcessHandshakeRequest()
<DateTime>,d:\dnsrv\base\ntsetup\oobe\msobmain\msobmain.cpp,5724,,m_pLicenseAgent->AsyncProcessHandshakeRequest() failed. エラー = 32777
<DateTime>,d:\dnsrv\base\ntsetup\oobe\msobmain\msobmain.cpp,311,,Windows 製品ライセンス認証エラー。
<DateTime>,d:\dnsrv\base\ntsetup\oobe\msobmain\msobmain.cpp,313,,ReturnActivationStatus: Status = 7, Detail = 32777
<DateTime>,OOBE トレース,0,,アクティブ化に失敗しました。 エラー = 7

データ収集

Microsoft サポートの支援が必要な場合は、「展開関連の問題について TSS を使用して情報を収集する」に記載している手順に従って情報を収集することをお勧めします。