アニメーションの作成

[Microsoft エージェントは Windows 7 の時点で非推奨となり、以降のバージョンの Windows では使用できない可能性があります。

キャラクターのアニメーションの作成を開始するには、ツリーで [アニメーション ] アイコンを選択します。 これにより、[ プロパティ ] ページが表示され、すべてのアニメーションの既定の設定が表示されます。 [ プロパティ ] ページで、フレーム サイズ、既定のフレーム期間、カラー パレットの設定を変更できます。

キャラクターのフレーム サイズの設定

アニメーション フレームの高さと幅は、文字定義全体 (つまり、そのすべてのキャラクターのアニメーションの場合) 全体で一定である必要があります。 フレーム サイズは既定の設定 (128 x 128 ピクセル) から変更できますが、エディターに表示される画像は既定の表示サイズに合わせて拡大縮小されます。 既定のフレーム設定を変更した場合は、[編集] メニューから [フレーム ウィンドウを開く] を選択して、フレームの完全なサイズを表示できます。

キャラクターのパレットを設定する

既定では、エディターは読み込んだ最初のビットマップ イメージを使用して、文字の既定のカラー パレット、文字の表示方法を決定する色、および 11 番目 のパレット位置の色を透明度の色として設定します。 ただし、[パレット 情報 ]グループでパレットと透明度を明示的に設定できます。 これにより、パレットに使用するイメージ ファイルを指定できます。 アニメーション イメージ ファイルまたは任意のグラフィック ファイルのいずれかを指定できます。 指定するパレット ファイルは、8 ビット (256) カラー ファイルである必要があります。 読み込まれたら、[ 設定の変更 ] ボタンを使用して透明度の色を変更します。

キャラクターのカラー パレットで標準のシステム カラーを再マップすることはできません。 エディターは、イメージを表示するときにシステムのカラー パレットを自動的に予約します。 さらに、すべてのアニメーション画像で同じカラー パレットと透明度の色を使用する必要があります。 これは非常に重要です。 表示されない場合は、エディターに読み込むと、画像の色の再マッピングが表示されることがあります。

文字のカラー パレットを設定できますが、表示プロパティが 8 ビット (256) カラー パレットに設定されているWindows システムでは、文字の色は現在のシステム パレットの対象になります。 アプリケーションによってシステム パレットが変更される可能性があるため、文字が正しい色設定で表示されない場合があります。 これを防ぐ方法はありませんが、使用する色の数を制限し、文字を駆動するアプリケーションで使用されるパレットに基づいてキャラクターのパレットを設定することで、効果を軽減できます。 たとえば、Web ページで使用する文字を開発する場合は、Microsoft Internet Explorer のハーフトーン パレットを使用して文字のパレットを設定できます。 ブラウザーのパレットをキャプチャするには、Web ページ上の画像を右クリックし、[名前を付けて保存] コマンドを選択し、[名前を付けて保存] オプションで [ビットマップ] を選択し、[保存] をクリックします。 アニメーションイメージファイルを特定のパレットファイルに最適化するには、平衡デバベリザーのような製品を使用することができます。

新しいアニメーションの作成

グローバル アニメーション設定を決定したら、アニメーションの作成を開始できます。 新しいアニメーションを作成するには、[編集] メニューまたはツールバーの [新しいアニメーション] ボタンから [新しいアニメーション] を選択します。 これにより、[アニメーション] アイコンの下のツリーに新しい アニメーション アイコンが追加され、新しいアイコンに既定の名前が割り当てられます。 [アニメーション名] フィールドに「アニメーション名」と入力すると 、アニメーションの名前を変更 できます。 文字定義内のアニメーション名は一意である必要があることに注意してください。 また、ファイル名に対して有効な文字ではない文字を名前に使用しないでください。

フレームの追加

すべてのアニメーションはフレームで構成されます。 アニメーションの新しいフレームを作成するには、[編集] メニューまたはツール バーから [新しいフレーム] を選択します。 これにより、アニメーション アイコンの下のツリーに新しいフレーム アイコンが追加され、3 つのタブ付きページが表示されます。 [ 全般] ページには、フレームの画像を読み込んで調整できるコントロールが含まれています。 フレームの外観の表示領域も含まれます。

Screenshot that shows the Image pane with the filename, path, and position.

フレームには、1 つ以上の画像を含めることができます。 フレームのイメージを定義するには、[イメージ] リスト ボックスのすぐ上にある [イメージ ファイルの追加] ボタンをクリックします。 [ イメージ ファイルの選択 ] ダイアログ ボックスが表示され、ビットマップ イメージ ファイルを選択できます。

Screenshot that shows an image file being selected in File Explorer.

読み込むファイルを選択し、[ 開く] を選択すると、[ 全般] ページのフレーム表示に画像が表示されます。 エディターは、1 ビット (モノクロ)、4 ビット、または 8 ビットWindowsビットマップ形式、または GIF 形式で格納された画像を受け入れます。

[ 位置 ] ボックスの画像の下にある 4 つの矢印ボタンを使用して、フレーム内の画像の外観を調整できます。 イメージがフレームのサイズより大きい場合は、フレーム内に表示されるイメージの部分のみが表示されます。 フレーム サイズを大きくすると、エディターの表示領域内に収まるようにイメージが拡大縮小される場合があります。

[編集] メニューから [フレーム ウィンドウを開く] を選択して、フレームを表示することもできます。 これにより、フレームに読み込まれたイメージをスケーリングすることなく、現在のフレームが別のウィンドウに表示されます。 このウィンドウの初期サイズは、フレームの高さと幅の設定に基づいています。 サイズを小さくすることはできますが、大きくすることはできません。 フレーム ウィンドウには、エディターのコントロールを使用して行った変更が反映され、他のプロパティ ページを表示しながらフレームを表示することもできます。

Screenshot that shows the Position pane.

複数の画像から 1 つのフレームを作成できます。 [ イメージの追加 ] ボタンを選択して別の画像を選択するたびに、画像が一覧と画像表示領域に追加されます。 複数のファイルを選択して、複数の画像を追加することもできます。 Shift キーまたは Ctrl キーを押しながら、[ イメージ ファイルの選択 ] ダイアログ ボックスをクリックし、[ 開く] を選択します。 [画像] リスト ボックスの上にある [上へ移動] ボタンと [へ移動] ボタンは、選択した画像をフレームの表示順序 (z オーダー) で移動します。 画像は、リスト内でドラッグして移動することもできます。 一覧で画像を選択し、[ 削除 ] ボタンをクリックすると、イメージが削除されます。 読み込んだイメージを別のイメージ ファイルに変更するには、ファイル名をクリックして直接編集するか、 ... (省略記号) ボタンを使用して [ イメージ ファイルの選択 ] ダイアログ ボックスを表示し、別のファイルを選択します。

Screenshot that shows the ellipses button.

[ 期間 ] テキスト ボックスを使用して、フレームの期間を設定できます。つまり、フレームが表示される時間です。 フレームにイメージがなく、継続時間が 0 の場合、アニメーションの再生時にフレームは表示されません。

また、フレームの表示時に再生する効果音ファイルを指定することもできます。 Web サーバーから文字を読み込む場合は、サウンド エフェクト ファイルを圧縮して読み込み時間を最小限に抑えることができます。 その後、エージェント文字エディターで圧縮サウンド ファイルを指定できます。 さらに、アニメーションの継続時間よりも長い期間の効果音を使用しないようにし、特に、Microsoft Agent アニメーション サービスはサウンドが完了するまでアニメーションの完了イベントを送信しないため、ループする効果音を回避します。 また、音声入力に干渉するため、 リッスン 状態または 聴覚 状態に割り当てるアニメーションに効果音を指定しないようにします。 最後に、アニメーションに複数のサウンド エフェクトを含めることができますが、アニメーションのタイミングに影響を与える可能性があるため、それらが重なるように配置しないでください。 また、サウンド エフェクトは、ユーザーのハードウェアに基づいて異なるレートで再生される可能性があることに注意してください。

アニメーションにフレームを追加するには、[ 新しいフレーム ]コマンドをもう一度選択し、同じ手順に従います。 オプションとして、複数のイメージを読み込み、それらの新しいフレームを自動的に生成することもできます。 この機能を使用するには、[編集]メニューから[イメージから新しいフレーム]を選択します。 フレームは、画像ファイル名に基づいてアルファベット順に作成されます。 アニメーションのすべてのフレームの定義が完了したら、[ 新しいアニメーション ] コマンドをもう一度選択して、新しいアニメーションを開始できます。

アニメーションにフレームを追加したり、アニメーション内またはアニメーション間でフレームを移動したりする方法は他にもあります。 別のフレーム (同じまたは別のアニメーションから) を選択し、[ 切り取り ] または [コピー] を選択してから、そのアニメーションのアニメーションまたはフレームを選択して、[ 貼り付け] を選択できます。 また、あるアニメーションから別のアニメーションにフレームをドラッグすることもできます。 アニメーション内でドラッグすると、アクションによってフレームが移動します。 別のアニメーションにドラッグすると、フレームがコピーされます。 同じアニメーションで前のフレームにドラッグすると、ドラッグ先のフレームの前にフレームが挿入されます。 次のフレームにドラッグすると、ドラッグ先のフレームの後に配置されます。 マウスの右ボタンを使用してフレームをドラッグすると、ボタンを離すと、転送の選択肢を含むポップアップ メニューが表示されます。

アニメーションを作成するには、既存のアニメーションをコピーし (アニメーションを選択して [コピー]を選択)、[ アニメーション ] アイコンまたは別のアニメーション アイコンを選択し、[ 貼り付け] を選択します。 名前は変更できますが、エディターによってアニメーションの新しい名前が自動的に作成されます。

分岐

フレームを作成するときに、次に再生するフレームを定義することもできます。 既定では、アニメーション シーケンスで再生される次のフレームは、常に z オーダーの次のフレームです。 ただし、[分岐] ページ 選択することで、サーバーが再生できる他のフレームを最大 3 つまで設定できます。 適切なフィールドに確率パーセンテージとターゲット フレーム番号を入力します。 イメージがなく、期間が 0 に設定されているフレームでも分岐を指定できます。 これにより、最初に特定の画像を表示せずに分岐できます。

Screenshot that shows the 'Branching' page.

分岐機能を使用して、無限にループするアニメーションを作成できます。 ただし、ループ アニメーションが再生されると、ユーザーがプッシュツートーク キーを押したり 、Stop メソッドを呼び出すクライアント アプリケーションなどのイベントが発生するまで、キャラクターのキュー内の他のアニメーションは再生されないことに注意してください。 したがって、ループ アニメーションを作成する前に、アニメーションが使用されるコンテキストを慎重に検討してください。

分岐ページでは、Exit Branching を作成することもできます。 終了分岐は、アニメーションが停止したときと、次のアニメーションが再生される前にアニメーションが実行するフレームへの分岐です。 終了分岐を定義すると、アニメーション間の切り替え中にスムーズに移動できます。 終了分岐では、循環ループを作成することはできませんが、最終的にはアニメーションの最後のフレームに終了できる必要があります。

フレームごとに終了分岐を指定する必要はありませんが、指定しない場合、アニメーションはフレームの通常の分岐に従います。 フレームに明示的な分岐がない場合、アニメーションはその後のフレームに自動的に分岐します。 たとえば、フレーム 3 からフレーム 1 に分岐し、フレーム 1 に他の分岐 (標準分岐または出口分岐) がない場合、フレーム 1 はフレーム 2 に分岐します。 フレーム 2 に分岐がない場合、アニメーションはフレーム 3 に分岐し、循環ループが発生します。 代わりに、フレーム 3 からフレーム 1 に分岐し、フレーム 1 の終了分岐をフレーム 3 の後のフレームに設定し、通常はアニメーションの最後のフレームに進むことができます。

場合によっては、目に見えて再生されず、アニメーションの末尾を提供するアニメーションの明示的な最終フレームを作成する必要がある場合があります。 たとえば、アニメーションを終了する必要がありますが、最後のフレームに終了することは適切ではありません。 これを行うには、アニメーションの最後のフレームとして空白の 0 継続時間フレームを作成します。 これにより、アニメーションの最後のフレームを通じてアニメーションを正常に再生でき、終了分岐の最終的な終了ポイントを指定することもできます。

アニメーションのプレビュー

[編集] メニューの [プレビュー] コマンドを選択するか、ツール バーの [プレビュー] ボタンを選択して、エージェント文字エディターでアニメーションをプレビューできます。 これにより、現在選択されているフレームから開始して、ブランチやサウンド エフェクトを含むアニメーションが再生されます。 アニメーションが完了すると、現在選択されているフレームにリセットされます。 アニメーション全体を再生するには、ツリー ビューに移動し、アニメーションのアイコンまたはアニメーションの最初のフレームを選択し、[ プレビュー ] コマンドを選択します。 エディターは、[ 全般 ] ページでフレームをアニメーション化します。 プレビューを終了する前に停止するには、[ プレビューの停止 ] コマンドを選択します。 プレビューの再生中に[ プレビュー停止] コマンドが自動的に変更されます。

[編集] メニューまたはツール バーの [Exit Branching のプレビュー] コマンドを選択して、終了分岐をプレビューすることもできます。 これにより、特定のフレームから出口分岐がどのように表示されるかをテストできます。

スピーキング オーバーレイの割り当て

アニメーションの最後のフレームで読み上げる文字を定義できます。 このフレームで、[ オーバーレイ ] ページを選択します。 このページでは、Microsoft エージェントでサポートされている標準の口の位置にマウス イメージ ファイルを読み込んで割り当てることができます。 [ イメージの追加 ] ボタンをクリックし、ダイアログ ボックスからイメージを選択します。 複数の画像を選択することもできます。エディターは、選択した口の位置から画像を読み込んで割り当てます。 [ 上へ移動 ] ボタンと [下へ移動 ] ボタンをクリックするか、エントリをドラッグして一覧の画像の割り当てを変更します。 [ 削除 ] ボタンをクリックして画像を削除します。 割り当てられたファイルのパス名を編集するには、リスト内のエントリをクリックしてそのファイル名を再入力するか、 省略記号 ボタンを選択して [ イメージ ファイルの選択 ] ダイアログ ボックスを表示します。

Screenshot that shows the 'Overlays' page with a file selected.

マウス オーバーレイは、表示されるベース フレームのアウトライン内に収まる必要があります。 そうでない場合は、ベース フレームにクリップされます。

たとえば、文字がベース フレームの外側の口で話すようにする場合は、文字が横向きに向かって話す場合は、最初に、文字の頭 (またはキャラクターが話すときに移動する領域) を上の画像としてベース フレームを作成します。 次に、マウス オーバーレイを定義してそのイメージを置き換え、[ ベース フレームの上部イメージを置き換える ] オプションを設定します。 [ すべて設定 ] ボタンを使用して、フレーム内のすべてのマウス オーバーレイに対してこのオプションを設定することもできます。

リターン アニメーションの割り当て

1 つのアニメーションから次のアニメーションへのスムーズな切り替えを作成するには、ニュートラル イメージで開始および終了するようにアニメーション シーケンスを設計します。 詳細については、「 Microsoft エージェントの文字の設計」を参照してください。 ただし、これは、すべてのアニメーションがニュートラルな位置で終了する必要があることを意味するわけではありません。 一連のフレームを介してキャラクターをアニメーション化し、最後のフレームで話すようにし、キャラクターをニュートラルな位置に返す個別の補完的なアニメーションを作成できます。 この補完的なアニメーションは Return アニメーションと呼ばれます。

この目的のために明示的なアニメーションを作成することで、Return アニメーションを定義できます。 アニメーション内で定義した終了分岐を使用して Return アニメーションを作成することもできます。 Return アニメーションを割り当てるには、ツリーでアニメーションを選択し、[プロパティ] ページの [戻るアニメーション] ドロップダウン リストから、作成した Return アニメーションまたは Exit Branching を選択します。

Return アニメーションの作成と割り当てには、追加の利点があります。サーバーが別のアニメーションを再生する要求を取得すると、Return アニメーションが割り当てられている場合、最後に再生したアニメーションの Return アニメーションの再生が試みられます。 これにより、スムーズな移行が保証されます。 アニメーションがニュートラルな位置で開始および終了する場合は、Return アニメーションを定義する必要はありません。 同様に、あるアニメーションから別のアニメーションへの切り替えを自分で処理する場合は、Return アニメーションを割り当てる必要がない場合があります。

アニメーションを状態に割り当てる

Microsoft エージェント アニメーション サービスは、ホスティング クライアント アプリケーションが特定のメソッドを使用すると、アニメーションを自動的に再生します。 たとえば、アプリケーションが MoveTo メソッドと GestureAt メソッドを呼び出すと、サーバーは文字が表示される場所を自動的に決定し、適切なアニメーションを再生します。 同様に、Microsoft エージェントは、ユーザーが数秒間キャラクターと対話していない場合に、アイドル 状態のアニメーションを自動的に再生します。 サーバーがアプリケーションの代わりにアニメーションを自動的に再生する場合、これらの条件は 状態と呼ばれます。 ただし、サーバーで再生するアニメーションを把握するには、これらの状態にアニメーションを割り当てる必要があります。

アニメーションまたはアニメーションを状態に割り当てるには、適切なアニメーションを作成し、[エディター] ウィンドウのツリー ビューで [状態] エントリを展開し、[状態] アイコンを選択します。 作成したアニメーションの一覧が、ウィンドウの右側のリスト ボックスに表示されます。 この状態に割り当てるアニメーションを確認します。 複数のアニメーションを同じ状態に割り当てることができます。 これにより、サーバーは状態に対して異なるアニメーションをランダムに選択できます。 アニメーションを状態に割り当てると、アニメーションがそのアニメーションを直接再生できなくなります。

ツリー内のアニメーションのエントリを選択して、アニメーションを状態に割り当てることもできます。 [プロパティ] ページの [状態の割り当て] リスト ボックスに状態が一覧表示されます。 アニメーションを割り当てる状態のチェック ボックスをオンにします。

エディターでは追加の状態の作成はサポートされていません。状態は、サーバーがクライアント アプリケーションの代わりに自動的にアニメーションを再生する必要がある状況にのみ適用されるためです。 したがって、独自の状態を定義する利点はありません。 必要に応じて、Play メソッドを使用して任意のアニメーションを明示的に 再生 できます。

文字定義の保存

[ファイル] メニュー[保存] コマンドを選択するか、ツール バーの [文字定義の保存] ボタンを選択して、文字の定義ファイルを保存できます。 文字定義ファイルを新しい名前で保存する場合は、[ファイル] メニューの [名前を付けて保存] コマンドを選択します。 エディターは、文字の編集可能な定義をエージェント文字定義 (.ACD) ファイル。 この自己文書化テキスト ファイル形式は、ほとんどのテキスト エディターやワープロ アプリケーションで編集することもできます。

文字定義の印刷

文字の定義を印刷するには、[ファイル] メニューの [印刷] コマンドを選択するか、ツール バーの [印刷] ボタンを選択します。 印刷出力のプロパティを設定するには、[ ページ設定] コマンドを選択し、[ 印刷 ] コマンドを選択する前に設定を選択します。

文字の構築

アニメーションの作成が完了したら、キャラクターとイメージを、Microsoft エージェントがこのデータの読み込みに使用する特別な形式にコンパイルする必要があります。 文字をビルドするには、[ ファイル ] メニューまたはツール バーから [文字のビルド] コマンドを選択します。 文字定義ファイルに未保存の編集がある場合は、[文字の ビルド ] ダイアログ ボックスを表示する前に、エディターによって定義ファイルが保存されます。

Screenshot that shows the 'Build Character' window with a file selected.

エージェント文字エディターは、文字定義ファイル名に基づいてファイル名を自動的に提案します。 [文字のビルド] ダイアログ ボックスにはドロップダウン リストも含まれているため、文字を 1 つのストレージ ファイル (.ACS) または複数のファイルとして使用できます。 後者を選択すると、エディターによって .文字のデータと .作成したアニメーションごとに ACA ファイル。 クライアント アプリケーションと同じコンピューターに格納されている文字をインストールしてアクセスする場合は、通常、単一の構造化ファイル形式を選択します。 この形式は、簡単で効率的なインストールと文字へのアクセスを提供します。 ただし、HTTP プロトコルを使用して Web サーバーから文字にアクセスする場合は、.ACF (個々の) ファイル形式。 この後者のファイル構造により、Web ページ スクリプトは個々のアニメーション ファイルを読み込み、ユーザーのブラウザー ファイル キャッシュにデータを格納できます。 アニメーション データは必要に応じてダウンロードできるため、一度に一連のアニメーションがダウンロードされるのを待つ必要がないため、Web 経由で効率的にアクセスできます。 さらに、文字のデータはブラウザー キャッシュに格納されるため、ファイル領域を自動的に再利用できます。

Web サーバーから文字データ (単一の構造化ファイルまたは複数のファイルとして) をダウンロードし、ユーザーのコンピューター上の別の場所にインストールすることもできますが、このような方法では、ダウンロードとインストールのためのセキュリティプロビジョニングが必要です。 その結果、Microsoft エージェント API には、ブラウザーのキャッシュを除き、文字のダウンロード可能なインストールのサポートは含まれません。 ただし、独自のインストール制御を作成し、適切なセキュリティ規則に従って配布することで、このシナリオを引き続きサポートできます。 詳細については、Microsoft インターネット クライアント ソフトウェア開発キットを参照してください。

[圧縮] オプションを使用すると、文字データを圧縮するかどうかを設定できます。 通常、このオプションを設定して文字データを圧縮しますが、圧縮されたデータを使用して文字を作成する場合は時間がかかります。

文字をビルドすると、同じディレクトリの場所に文字をビルドすると、後続のビルドが高速になります。 文字エディターは、変更されていないファイルを自動的に検証してコピーし、編集されたデータを再コンパイルします。

エディターは、文字のビルド中に文字ファイル内のエラーを検出すると、情報をログ ファイルに書き込み、メッセージ ボックスを表示します。 ログ ファイルを表示するか、無視して後でテキスト エディターで読み取ることもできます。 ただし、次回文字ファイルをビルドすると、エディターによってログ ファイルが上書きされることに注意してください。

既存の文字の編集

既存の文字を編集するには、[ファイル] メニューの [開く] を選択し、文字の定義ファイル (.ACD) をクリックし、[開く] を選択します。 ファイルがエディターに読み込まれます。 コンパイル済み文字ファイル (.ACS。ACF、または .ACA) とエディターを使用します。

文字の定義ファイル (.ACD)はテキストファイルであり、テキストエディタまたはワープロプログラムでファイルを開いて文字の定義を編集することもできます。 ただし、変更を完了する場合は、コンパイルのために文字エディターに読み込む前に、ファイルを元の形式で保存してください。