엑셀2007로 작성한 파일을 실행하면 파일이 열리지 않고 아주 늦게 열리거나 또는 아예 열리지 않고 엑셀창들이 비활성화되면서 단추를 누르면 열기만 선택이 되는 그러한 오류입니다...

익명
2010-03-30T02:57:03+00:00

엑셀2007로 작성한 파일을 실행하면 파일이 열리지 않고 아주 늦게 열리거나 또는 아예 열리지 않고 엑셀창들이 비활성화되면서 단추를 누르면 열기만 선택이 되는 그러한 오류입니다...

Microsoft 365 및 Office | Excel | 가정용 | Windows

잠긴 질문. 이 질문은 Microsoft 지원 커뮤니티에서 마이그레이션되었습니다. 질문이 도움이 되었는지 여부에 대해 응답할 수는 있지만, 메모나 회신을 추가하거나 질문을 따를 수는 없습니다.

댓글 0개 설명 없음
질문 작성자가 수락한 답변
익명
2010-04-02T00:06:38+00:00

안녕하십니까? nman21님

Microsoft Office의 Excel 사이트를 방문해 주셔서 감사합니다.

문의 하신 문제에 대한 답변을 드리겠습니다.

현재 계속 다른 문제가 발생하고 있으니 Excel 프로그램이 손상되었을 가능성이 있습니다.

현재 설치되어 있는 Excel 프로그램을 완전히 제거하신 후 다시 설치를 권장 드려봅니다.

해결 방법은

  1. Office 2007 제거 Fix It을 이용하여 Office 프로그램을 제거합니다.

a. 아래 링크된 Fix It 50154 제거 툴을 이용하여 프로그램을 제거 합니다.

http://go.microsoft.com/?linkid=9669698

b. 삭제가 완료 되면 Microsoft Office Professional plus 2007을 다시 설치해 봅니다. 2. Windows Cleanup Utility를 이용하여 Office 프로그램을 제거 합니다.

a.. 아래 링크된 Microsoft Web Site에서 Windows Cleanup Utility을 다운로드 하여 설치 합니다. 

http://download.microsoft.com/download/e/9/d/e9d80355-7ab4-45b8-80e8-983a48d5e1bd/msicuu2.exe

b. 프로그램에 대한 설명이 나오면 [Next]버튼을 클릭합니다.

![](http://u07wqw.blu.livefilestore.com/y1pLW4WDOkZglbkrmOdOfXraAO0BniBystM0aH0BeG4fN0uQbs96oPJ7xyO2LXANYTTk_AL7LLLbzYW5HO3FfGy2BssnE1CR0Xc/Windows Installer Clean Up Setup %EC%84%A4%EC%B9%98.png)

c. 프로그램의 라이센스에 대한 동의를 하고 [Next]를 클릭하여 설치를 완료 합니다.

![](http://public.blu.livefilestore.com/y1pZefbSwxxsEIeNheRFNO6qr9oNGbr7p4Z27-XtKiH83BNrGniBcypW9KzInhwm-CV2i5fhBTS5sVBaBB8V2jGQA/Windows Installer Clean Up Setup %EC%84%A4%EC%B9%98 %EB%8F%99%EC%9D%98.png)

d. 설치가 완료 되면 Windows Cleanup Utility를 실행 합니다.

e. 해당 설치 목록에 Microsoft Office Professional plus 2007을 선택하여 제거 합니다.

f. 삭제가 완료 되면 Microsoft Office Professional plus 2007을 다시 설치해 봅니다. 3. 수동으로 Office 설치 파일 제거합니다.

a. 윈도우 탐색기를 이용하여 다음 폴더를 제거합니다.

 - C:\Program files\Microsoft Office

 - C:\Program Files\Common Files\Microsoft Shared\Dao

 - C:\Program Files\Common Files\Microsoft Shared\Stationery

 - C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\40\Bin

 - C:\Program Files\Common Files\Microsoft Shared\OFFICE12

 - C:\Program Files\Common Files\Microsoft Shared\Source Engine

 - C:\Users<사용자 이름>\Office Genuine Advantage

 - C:\Users<사용자 계정>\AppData\Roaming\Microsoft\Document Building Blocks

 - C:\Users<사용자 계정>\AppData\Roaming\Microsoft\Templates

b. msocache를 검색하여 제거합니다.

 - 윈도우 시작 버튼을 클릭합니다.

 - 실행 및 검색 창에 msocache를 검색하여 삭제합니다.

![](http://public.blu.livefilestore.com/y1plmWlTbUIpcCAtRwk5zTSHVTOIMgCGyqFqd5nspXIw76-7tm6rnoFOaLubBIA9W6Ui25olkLZZk7fuM6otL1NGA/Win7]%EC%8B%9C%EC%9E%91-%EA%B2%80%EC%83%89 %EB%B0%8F %EB%AA%85%EB%A0%B9%EC%96%B4.png)

c. %temp%를 검색하여 제거합니다.

 - 윈도우 시작 버튼을 클릭합니다.

 - 실행 및 검색 창에 msocache를 검색하여 삭제합니다.

![](http://public.blu.livefilestore.com/y1plmWlTbUIpcCAtRwk5zTSHVTOIMgCGyqFqd5nspXIw76-7tm6rnoFOaLubBIA9W6Ui25olkLZZk7fuM6otL1NGA/Win7]%EC%8B%9C%EC%9E%91-%EA%B2%80%EC%83%89 %EB%B0%8F %EB%AA%85%EB%A0%B9%EC%96%B4.png)

d. Office 관련 레지스트리를 제거합니다.

 - 윈도우 시작 버튼을 클릭합니다.

 - 실행 및 검색 창에 regedit를 적고 Enter를 눌러 레지스트리 편집기를 실행합니다.

![](http://public.blu.livefilestore.com/y1plmWlTbUIpcCAtRwk5zTSHVTOIMgCGyqFqd5nspXIw76-7tm6rnoFOaLubBIA9W6Ui25olkLZZk7fuM6otL1NGA/Win7]%EC%8B%9C%EC%9E%91-%EA%B2%80%EC%83%89 %EB%B0%8F %EB%AA%85%EB%A0%B9%EC%96%B4.png)

 - HKey_Current_User\Software\Microsoft\Office를 선택하고 마우스 우측 버튼을 클릭하여 하위 폴더를 모두 제거합니다.

![](http://u07vqw.blu.livefilestore.com/y1pI1rAVtYattV244Yyz8BMLBn7cn2-jbChMyPGThpNdLeM419MhZtJ4EgOQbrOtsT1Mwi-Qa2EKF5wGYFGrZZWvEQNGJn1P0U_/Regedit-Office %EC%82%AD%EC%A0%9C.png)

 - HKey_Local_Machine\Software\microsoft\Office를 선택하고 마우스 우측 버튼을 클릭하여 하위 폴더를 모두 제거합니다.

![](http://u07vqw.blu.livefilestore.com/y1pI1rAVtYattV244Yyz8BMLBn7cn2-jbChMyPGThpNdLeM419MhZtJ4EgOQbrOtsT1Mwi-Qa2EKF5wGYFGrZZWvEQNGJn1P0U_/Regedit-Office %EC%82%AD%EC%A0%9C.png)

e. Windows를 재부팅 하고 Microsoft Office Professional plus 2007을 다시 설치해 봅니다.

자동 업데이트로 인한 80070643의 문제의 해결 방법은

  1. microsoft Internet Explorer 캐시 폴더, 쿠키, 열어본 페이지 목록 및 운영 체제 임시 폴더의 내용 삭제합니다.

a. Internet Explorer를 실행합니다.

b. 우측 상단 도구 메뉴를 클릭하여 옵션을 선택합니다.

c. 옵션 메뉴 중 일반 탭의 검색 기록의 [삭제] 버튼을 선택합니다.

d. 삭제 메뉴가 나타나면, 임시 인터넷 파일과 쿠키를 체크하고 삭제를 선택합니다.

![](http://u07vqw.blu.livefilestore.com/y1pTijOu3fjA2ApqI7wdA-ZCf2VsYnj87uITMkHdchsfMNQFVhU76fh_wR8CBEnANvKt6s3Sd4-0WUc4YGRSFYsEUW_kkQgvwBl/Internet-%EB%8F%84%EA%B5%AC-%EC%98%B5%EC%85%98-%EC%82%AD%EC%A0%9C-%EC%9E%84%EC%8B%9C %EC%9D%B8%ED%84%B0%EB%84%B7 %ED%8C%8C%EC%9D%BC, %EC%BF%A0%ED%82%A4.png)

e. 옵션 메뉴 중 일반 탭의 검색 기록의 [설정] 버튼을 선택합니다.

![](http://u07vqw.blu.livefilestore.com/y1pvK3kAA2bTH90YcvWvsYcKr2QAiKOnTkQiIcGNsbFwlxUSypkiezCcChrjZqCzLpjX_JPP4aW9SAMj8k3_odlpDbFsCXvZNMr/Internet Explorer-%EC%9D%B8%ED%84%B0%EB%84%B7 %EC%98%B5%EC%85%98-%EC%84%A4%EC%A0%95.png)

f. 설정 메뉴가 나타나면 [개체보기]를 선택하여 손상됨으로 표시된 개체를 모두 삭제합니다.

![](http://u07vqw.blu.livefilestore.com/y1pdFy7aDBO76bGVhzph1xM6a7oXgsOkdNcRPDDPmWs0pOTxBtJQZH0-F9I8M8DazIPRySn_2FU8OPMRuB61BmHRxEQIoi5w1B1/Internet Explorer-%EC%9D%B8%ED%84%B0%EB%84%B7 %EC%98%B5%EC%85%98-%EC%84%A4%EC%A0%95-%EA%B0%9C%EC%B2%B4%EB%B3%B4%EA%B8%B0.png)

g. 옵션 메뉴 중 개인 정보 탭의 설정 메뉴 중 [기본값] 보튼을 선택합니다.

![](http://u07vqw.blu.livefilestore.com/y1pdFy7aDBO76aSBtFzlaD0jfjxIJtX-RA2Sy8bWaKx7ua-Hggi_KbQq272DL93DCFPhBitL1S1Qao3jN17MKzspRNvJBvS0_EJ/Internet Explorer-%EC%9D%B8%ED%84%B0%EB%84%B7 %EC%98%B5%EC%85%98-%EA%B0%9C%EC%9D%B8%EC%A0%95%EB%B3%B4-%EA%B8%B0%EB%B3%B8%EA%B0%92.png)

h. 윈도우 버튼을 클릭하여 검색 및 실행 창에 %temp%를 입혁하여 임시파일을 모두 제거합니다.

![](http://u07vqw.blu.livefilestore.com/y1pSDwva4MAh97uuuWTZbWPS6CwjdVoiMwABUmZzGUmAwXmEgqWHB2RGcQ5CZxIY6RC55chB1WamfJsd-EJ0nVwZSi6wRld2LmF/Win7]%EC%8B%9C%EC%9E%91-%EA%B2%80%EC%83%89 %EB%B0%8F %EB%AA%85%EB%A0%B9%EC%96%B4.png)

i. 임시 파일이 모두 제거되면 다시 업데이트를 실행해 봅니다. 2. Microsoft Windows Script 5.6 설치합니다.

a. 아래 링크로 접속하여 Microsoft Windows Script 5.7을 설치합니다.

http://www.microsoft.com/downloads/details.aspx?FamilyID=47809025-D896-482E-A0D6-524E7E844D81&displaylang=en&displaylang=en&displaylang=en

b. 설치가 완료 되면 다시 업데이트를 실행해 봅니다. 3. Microsoft office Update 폴더를 제거합니다.

a. 윈도우 시작 버튼을 클릭하여 검색 및 실행창에 OfficeUpdate12를 검색합니다.

 (폴더의 위치는 C:\Program Files\OfficeUpdate12에 있습니다.)

![](http://u07vqw.blu.livefilestore.com/y1pSDwva4MAh97uuuWTZbWPS6CwjdVoiMwABUmZzGUmAwXmEgqWHB2RGcQ5CZxIY6RC55chB1WamfJsd-EJ0nVwZSi6wRld2LmF/Win7]%EC%8B%9C%EC%9E%91-%EA%B2%80%EC%83%89 %EB%B0%8F %EB%AA%85%EB%A0%B9%EC%96%B4.png)

b. OfficeUpdate12에 모든 항목을 제거합니다.

c. 항목이 모두 제거되면 다시 업데이트를 실행해 봅니다. 4. Office Update ActiveX 컨트롤을 제거합니다.

a. Internet Explorer를 종료합니다.

b. 윈도우 시작 버튼을 클릭하여 검색 및 실행창에 opuc.dll을 검색합니다.

![](http://u07vqw.blu.livefilestore.com/y1pSDwva4MAh97uuuWTZbWPS6CwjdVoiMwABUmZzGUmAwXmEgqWHB2RGcQ5CZxIY6RC55chB1WamfJsd-EJ0nVwZSi6wRld2LmF/Win7]%EC%8B%9C%EC%9E%91-%EA%B2%80%EC%83%89 %EB%B0%8F %EB%AA%85%EB%A0%B9%EC%96%B4.png)

c. 검색된 opuc.dll을 삭제 합니다.

d. 파일이 삭제되면 다시 업데이트를 실행해 봅니다. 5. 개인 방화벽, 다운로드 관리자, 팝업 차단 및 웹 가속 제품을 임시로 해제합니다.

a. 윈도우 시작 버튼을 클릭하고, 제어판을 선택합니다.

b. 제어판 메뉴가 나타나면, 시스템 및 보안 메뉴를 선택합니다.

![](http://u07vqw.blu.livefilestore.com/y1ppor8LATktTWbsleFbOvZjp0RrdTDg2PI9YO0-hea09PwzUaNfjWg4hGVXqN-2xx1qEZl_v2dQNGRj5ZfNElgjjf7Zh80kADV/Win7]%EC%A0%9C%EC%96%B4%ED%8C%90-%EC%8B%9C%EC%8A%A4%ED%85%9C %EB%B0%8F %EB%B3%B4%EC%95%88.png)

c. 시스템 및 보안 메뉴가 나타나면 Windows 방화벽을 선택하여 방화벽을 해제합니다.

![](http://u07vqw.blu.livefilestore.com/y1pFh5Caj1fnrGpxaByxIy7PhzVLGsqckOveY-CJCg9M3imrWaKvnH9YU_LW-P5YJ1aRWCOKLzfmcO74V3C_QCaeka0WQLsOTLQ/win7]%EC%A0%9C%EC%96%B4%ED%8C%90-%EC%8B%9C%EC%8A%A4%ED%85%9C %EB%B0%8F %EB%B3%B4%EC%95%88-Windows %EB%B0%A9%ED%99%94%EB%B2%BD.png)

d. Internet Explorer를 실행합니다.

e. 우측 상단에 있는 도구 메뉴를 클릭하여 옵션을 선택합니다.

f. 옵션 메뉴 중 개인 정보 탭을 선택하고, 팝업 차단 메뉴의 [팝업 차단 사용]을 체크 해제합니다.

g. 팝업 차단의 [설정] 버튼을 선택하여 낮음:안전한 사이트의 팝업 허용을 선택 한 후 [확인] 버튼을 클릭합니다.

h. 허용할 웹 주소에 office.microsoft.com를 추가합니다.

![](http://u07vqw.blu.livefilestore.com/y1p0-hG2pUMk2zDbKUh_oGx_T1S_IBhUf40tc1n6DIynAyxVcTd8BTSKl_CBr9Lu_tHRYrshZ6T1h2OOG-mBdAxz3HrSZbKxTJc/Internet Explorer-%EB%8F%84%EA%B5%AC-%EC%98%B5%EC%85%98-%EA%B0%9C%EC%9D%B8 %EC%A0%95%EB%B3%B4-%ED%8C%9D%EC%97%85%EC%B0%A8%EB%8B%A8.png)

h. 모든 설정이 완료 되면 Office update 사이트를 이용하여, 업데이트 여부를 확인 합니다.

http://office.microsoft.com/officeupdate/default.aspx

[참고 자료]

http://support.microsoft.com/kb/304498/ko

http://support.microsoft.com/kb/928218/ko

http://support.microsoft.com/kb/971179/ko

제가 문제에 대해 더 알아야 할 것이 있다면 응답 주시면 감사하겠습니다.

제시해 드린 답변이 도움이 되었기를 바랍니다.

위의 방법으로 해결이 되지 않는 다면 Microsoft 고객 지원센터(1577-9700)으로 전화 연락 부탁드리겠습니다.

이 대답이 도움이 되었나요?

댓글 0개 설명 없음

4 추가 답변

정렬 기준: 가장 유용함
  1. 익명
    2010-04-01T08:13:36+00:00

    네...계속되는 답변에 감사드립니다..

    일단 위 3가지 방법 모두 시도하였으나  마찬가지 현상이 계속됩니다.

    다만 한가지 특이한 증상이 다시 발생되어 문의드립니다.

    엑셀파일을(한다어만 저장된) 실행하고 나서 안보이다가 창크기를 축소하거나 크게하면 그 파일이 보이는 현상이 있습니다...

    단순히 창크기를 작게 크게로 늘렸을 뿐인데 파일이 보입니다..

    계속되는 특이 증상때문에 좀 힘듭니다.

    답변주시면 감사드립니다.

    수고하세요.,.,

    이 대답이 도움이 되었나요?

    댓글 0개 설명 없음
  2. 익명
    2010-03-31T00:21:38+00:00

    안녕하십니까? nman21님

    Microsoft Office의 Excel사이트를 방문해 주셔서 감사합니다.

    앞서 설명 드린 방법이 별로 도움이 되지 않으셨다니 다른 방법을 더 알려 드리도록 하겠습니다.

    해당 문제는 프린터 드라이와의 충돌로 문제가 되는 경우도 있습니다. 해당 프린터 드라이브를 삭제하시고 기본 프린터로 설정 하거나 최신 드라이브로 업데이트하는 것을 권장 드립니다.

    다음과 같은 해결 방법을 해보시기를 권장 드립니다.

    1. 윈도우 시작 버튼을 클릭합니다.
    2. 윈도우 시작 메뉴 중 장치 및 프린터를 선택합니다.(XP버전의 경우 제어판 메뉴 중 [장치 및 프린터]가 있습니다.)

    ![](http://public.blu.livefilestore.com/y1pleGYZGbPwijDbk4_6JgO51Y2P7zsgR93pj7x6FZX-gazwVp7v6zvOP3AbEYWEgowEbtbe_K8fZBkRrZdXx236g/Win7]%EC%8B%9C%EC%9E%91-%EC%9E%A5%EC%B9%98 %EB%B0%8F %ED%94%84%EB%A6%B0%ED%84%B0.png) 3. 장치 및 프린터 드라이브 메뉴가 나타나면, 현재 설치 되어 있는 프린트 드라이브를 선택하시고, 마우스 우측 버튼을 클릭하여 [장치 제거]를 선택합니다.

    ![](http://public.blu.livefilestore.com/y1pVv3xh-t43PmE-dd6onILtVFdL6Zg1XJsFpLywmPNehalBIdX5F6-KhscagHW4JqbNHdxIQJ4wNy5-XUFPiOlOQ/Win7]%EC%8B%9C%EC%9E%91-%EC%9E%A5%EC%B9%98 %EB%B0%8F %ED%94%84%EB%A6%B0%ED%84%B0-%ED%94%84%EB%A6%B0%ED%84%B0 %EB%93%9C%EB%9D%BC%EC%9D%B4%EB%B8%8C %EC%A0%9C%EA%B1%B0.png) 4. 윈도우에서 기본으로 제공해 주는 기본 프린트 드라이브나, Microsoft Office에서 제공해주는 프린터 드라이브를 선택하시고, 마우스 우측 버튼을 클릭하여 [기본 프린터로 설정]을 선택합니다.

    ![](http://public.blu.livefilestore.com/y1pVv3xh-t43PmJYNhQwP0eKOyhIkU_-UZA_ozN_br9BnVHWPAZFHj3iVV-h3oMMh19drDMW-HFbm7dRBlGq0FYPw/Win7]%EC%8B%9C%EC%9E%91-%EC%9E%A5%EC%B9%98 %EB%B0%8F %ED%94%84%EB%A6%B0%ED%84%B0-%EA%B8%B0%EB%B3%B8 %ED%94%84%EB%A6%B0%ED%84%B0%EB%A1%9C %EC%84%A4%EC%A0%95.png) 5. 다시 Excel 프로그램을 실행하여 문제가 반복되는지 확인해 보시고, 문제가 계속 될 경우 아래의 전화 번호로 연락하시면, 문제 해결에 도움을 드릴 수 있을 것입니다.

    제가 문제에 대해 더 알아야 할 것이 있다면 응답 주시면 감사하겠습니다.

    제시해 드린 답변이 도움이 되었기를 바랍니다.

    계속 같은 문제가 반복 된다면, 1577-9700(Microsoft 고객 지원센터)로 연락주시기 바랍니다.

    이 대답이 도움이 되었나요?

    댓글 0개 설명 없음
  3. 익명
    2010-03-30T09:50:15+00:00

    성의있는 답변 정말 감사드립니다..

    아직 실행은 해보지 않았으나 도움이 되리라 믿습니다.

    다만,  한가지  위 첫번째 답변중에 수식된 그림등 개체가 많다고 하는 부분에서 제가 테스트로 5글자를 적고 저장한 다음 그 파일을 열려고 할 때에도

    동일한 현상(딜레이 또는 메뉴창 비활성화-메뉴버튼을 누르면 열기만 활성화되어있습니다.)이 발생합니다.

    두번째 인증문제도 정상적으로 인증을 받았습니다.  혹시 해서 2-3번 정도 프로그램을 다시 설치해보기도 하였습니다.

    제가 문의드린 질문도 위 답변에 해당되는지 제가 잘 몰라서 .... 혹 해당된다면 응답주시면 감사하겠습니다..

    도움주셔서 감사합니다...

    이 대답이 도움이 되었나요?

    댓글 0개 설명 없음
  4. 익명
    2010-03-30T06:07:19+00:00

    안녕하십니까? nman21님

    Microsoft Office의 Excel 사이트를 방문해 주셔서 감사합니다.

    문의 하신 파일을 열면, 열리지 않거나 지연되는 문제와 엑셀 창들이 비활성화 되는 문제에 대한 답변을 드리겠습니다.

    먼저 파일을 열때, 열리지 않거나 지연되는 문제에 대해서는 엑셀 파일 내에 너무 많은 개체(그림, 도형)이 삽입되어 있기 때문입니다.

    엑셀 창들이 비활성화 되는 문제에 대해서는 고객님의 정품인증이 정상적으로 작동하지 않아 View로써의 기능만 작동하시는 것입니다.

    해결 방법은

    1. 파일을 열때 열리지 않거나 지연되는 경우

    a. 해당 Excel파일을 실행합니다.

    b. 메뉴 중 도구탭의 매크로 그룹의 Visual Basic Editor를 실행 합니다.

    ![](http://public.blu.livefilestore.com/y1p2i9Uo7XibzUk8Xwjdluq8wckAiuNwrWVt77TL9HbbPSMc_mZ4DoqSkGdwG4oiXe4gOimY6PqSGBSHAtpEfS8iA/2003]%EB%8F%84%EA%B5%AC-%EB%A7%A4%ED%81%AC%EB%A1%9C-Visual Basic Editor.png)

    c. Visual Basic Editor가 실행되면 보기 탭의 [직접 실행 창]을 선택합니다.

    ![](http://public.blu.livefilestore.com/y1pZr8tHuWohDMJh3xqwXlRY4m_if7uxvopJjB77iNkyrw8sWzhvmdXexkcMShNdp62tJ0PBsFpHsdnA_V69N5U1Q/2003]Microsoft Visual Basic-%EB%B3%B4%EA%B8%B0-%EC%A7%81%EC%A0%91 %EC%8B%A4%ED%96%89 %EC%B0%BD.png)

    d. Visual Basic Editor의 삽입 탭의 [모듈]을 실행합니다.

    ![](http://public.blu.livefilestore.com/y1pPG_9ZR_AT1FlMyVOHFzA22enf53NpCfBi4BK6qPb4E0osJDt-RHJEBefRfK1Y1StZ5w2wlICtj142oOyAn1BrA/2003]Microsoft Visual Basic-%EC%82%BD%EC%9E%85-%EB%AA%A8%EB%93%88.png)

    e. 아래 내용을 삽입합니다.

    Sub CountShapes()
    
        Dim w As Worksheet
    
        Dim i As Integer
    
        Dim iCount As Integer
    
        For Each w In ThisWorkbook.Worksheets
    
            i = w.Shapes.Count
    
            Debug.Print "시트
    

    : " & w.Name & " (" & i & ")개"

            iCount = iCount + i
    
        Next w
    
        Debug.Print "총
    

    : " & iCount & "개의 개체"

    End Sub
    
    Sub DeleteShapes()
    
        Dim w As Worksheet
    
        Dim s As Shape
    
        On Error Resume Next
    
        For Each w In ThisWorkbook.Worksheets
    
            For Each s In w.Shapes
    
                s.Visible = True
    
                s.Delete
    
            Next s
    
        Next w
    
    End Sub
    

    ![](http://public.blu.livefilestore.com/y1penox4ZMhhWMGyc8eMa70Pv_WR4MLQhog3HcQDxBOE2z94aZEV8Zkzb8R0DlC0ln33BQ2bx3HWlcl2dThJ7F0zw/2003]Microsoft Visual Basic-%EB%AA%A8%EB%93%88 %EC%9E%85%EB%A0%A5.png)

    f. 첫번째 프러시저인 Sub countShapes()와 End Sub 사이에 마우스 커서를 위치한 상태에서 Sub/사용자 정의 폼을 싱행합니다.

    (F5키를 눌러도 됩니다.)

    ![](http://public.blu.livefilestore.com/y1pZr8tHuWohDOQAY1eZTY5J5UzIa3ByyKD9JfZ-ZowPJzcixtVhRSxPFSrgVLqKpb_JIDU_Rdk68tAP7ATkMroaQ/2003]Microsoft Visual Basic-%EC%82%AC%EC%9A%A9%EC%9E%90 %EC%A0%95%EC%9D%98 Sub.png)

    g. 직접 실행 창에 각 시트에 사용된 개체 수와 총 개체 수가 표시됩니다. 

    ![](http://vpksrq.blu.livefilestore.com/y1pH2BT0zP3wJDsMjjN8o6-1rvq64MsNnfcuuA1ngCRNwPzFOMkkv5fOzqaPYwaTvO4zuT2AfK_omjN18LvsQA98vofEEzVJH4N/2003]Microsoft Visual Basic-%EC%A7%81%EC%A0%91 %EC%8B%A4%ED%96%89 %EA%B2%B0%EA%B3%BC.png)

    h. 두번째 프러시저인 Sub DeleteShapes()와 End Sub 사이에 마우스 커서를 위치한 상태에서 Sub/사용자 정의 폼 실행

    (F5키를 눌러도 됩니다.) 각 시트의 모든 개체를 삭제하는 과정에서 수 분 정도의 시간이 소요 될 수도 있습니다.

    ![](http://vpksrq.blu.livefilestore.com/y1p19hAQg6Ml-8uY0D8Rz0F4JLW3Cfr7VV2AxB6A4UcXYQi6a97JmdZmS0JXUAanFeakCkEsCePFpYWk4tHP7nQIjYmgevAZg0z/2003]Microsoft Visual Basic-%EB%AA%A8%EB%93%88 %EC%9E%85%EB%A0%A52.png)

    i. 삭제 작업이 완료되면 5~6번 작업을 한 번 더 실행하여 각 개체들이 완전히 삭제된 것을 확인합니다.

    ![](http://vpksrq.blu.livefilestore.com/y1p3Elf145MI0_jDCzEckDnXAEVU8ERqU78ykk40bnWJztDe5_yUWjy1f93ZwZjJERFtQbYCd1NA4DIWRSrjJg6SS6wMutthguD/2003]Microsoft Visual Basic-%EC%A7%81%EC%A0%91 %EC%8B%A4%ED%96%89 %EA%B2%B0%EA%B3%BC2.png)

    j. 코드가 파일에 포함될 필요가 없기 때문에 삽입된 모듈의 이름을 선택한 후 마우스 우측 버튼을 클릭하여 [모듈제거]를 선택합니다.

    ![](http://vpksrq.blu.livefilestore.com/y1pSXUFwwXDhSTjj5cj90VJQizTtSqPeZGkrkm-Epa6WXPpjfGAOP4yt7NBKroGQUgGsERKBTDNo5p-x0niFd0kUVWn4om2G6EZ/2003]Microsoft Visual Basic-%EB%AA%A8%EB%93%88 %EC%A0%9C%EA%B1%B0.png)

    k. 모듈 내보내기 창이 나타나면 [아니오] 버튼을 선택합니다.

    ![](http://vpksrq.blu.livefilestore.com/y1p3Elf145MI0_0RjLbRRtsk8aQ58aO22ijg0Y00RZ3HiNWVrUIQykrEWEPlKtv9vxmXtN21di_vZ0HaALZq8Vb6pjNQ0fask-H/2003]Microsoft Visual Basic-%EB%AA%A8%EB%93%88 %EC%A0%9C%EA%B1%B0-%ED%99%95%EC%9D%B8.png)

    l. 이후 파일을 저장 하면 파일의 크기가 줄어들고 딜레이 현상도 사라지는 것을 확인 하실 수 있습니다. 2. 메뉴 창이 비활성화 되는 경우에는

    a. 전화, 인터넷을 이용하여 정품 인증을 받습니다.

    http://office.microsoft.com/ko-kr/excel/HA011187761042.aspx?pid=CL100570551042

    b. 정품 인증 파일이 손상된 경우

     - 윈도우 시작 버튼을 클릭한 후에 컴퓨터를 선택하여 윈도우 탐색기를 실행 합니다.

     - opa11.dat파일이 저장되어 있는 폴더로 이동 한 후 opa11.dat를 삭제 합니다.

     (C:\Users\All Users\Application Data\Microsoft\Office\Data)

     (C:\ProgramData\Microsoft\OFFICE\DATA)

    c. 정품 인증 레지스트리가 손상된 경우

     - 윈도우 시작 버튼을 클릭한 후에 검색 및 실행창에 regedit를 입력합니다.

    ![](http://u07vqw.blu.livefilestore.com/y1pSDwva4MAh97uuuWTZbWPS6CwjdVoiMwABUmZzGUmAwXmEgqWHB2RGcQ5CZxIY6RC55chB1WamfJsd-EJ0nVwZSi6wRld2LmF/Win7]%EC%8B%9C%EC%9E%91-%EA%B2%80%EC%83%89 %EB%B0%8F %EB%AA%85%EB%A0%B9%EC%96%B4.png)

     - 레지스트리 편집기가 실행되면

     - HKey_Local_Machine\Software\Microsoft\Office\11.0\Registration으로 이동합니다.

     - 해당 폴더를 선택한 후에 마우스 우측 버튼을 클릭하여 내보내기를 선택하여 해당 레지스트리를 백업합니다.

    ![](http://u07vqw.blu.livefilestore.com/y1p51DxAppn-UrmKmWNZxydx7iG0oegM1H_uu7o31uzK9qDk6dMvLXqmYeC-G2MKUEzhK-2gUxhj7Yptc9zebDur9ESX6lLIfbf/Win7]Regedit-Office-Registration %EB%82%B4%EB%B3%B4%EB%82%B4%EA%B8%B0.png)

     - Registration 폴더를 삭제 합니다.

    ![](http://u07vqw.blu.livefilestore.com/y1pqUd7pfUM__QdqHK9Qqhx0_9siyC_wEgq2BJmm9DobdNFbYYVtHqDY0kwtAL0rAZ5W2fuIlAxsOtkyVR69uvv1AQ_-kmSNZTT/Win7]Regedit-Office-Registration %EC%82%AD%EC%A0%9C.png)

     - 레지스트리를 종료하고 Excel 프로그램을 다시 실행 하면 정품 인증창이 나타납니다.

     - 처음 제품을 구매하실때 CD Case 뒷면에 나와있는 GUID를 통해 제품을 다시 인증을 받습니다.

    ![](http://u07wqw.blu.livefilestore.com/y1p39FQSQT6v6RiRJOorymkWKUUjrUo4jmX9htLkCERHyOeHZKPZ4V5_5OtJ5vmgZUV-GWwPyLKfQ4VGqRJXlyCauSYRz1o2zke/2007]Office %EC%A0%9C%ED%92%88%ED%82%A4 %EC%9E%85%EB%A0%A5.png)

    [참고 자료]

    http://office.microsoft.com/ko-kr/excel/HA011187761042.aspx?pid=CL100570551042

    1. Office 인증 및 기능 제한에 대한 정보

    http://support.microsoft.com/default.aspx?scid=kb;ko;293151

    http://support.microsoft.com/default.aspx?scid=kb;ko;827291 

    2, Microsoft Office 정품 인증/등록 개인 정보 보호 정책 

    http://office.microsoft.com/ko-kr/assistance/HP010069531042.aspx 

    1. Microsoft Office 시스템에서 프로그램 인증 및 등록 

    http://office.microsoft.com/ko-kr/assistance/HA011187761042.aspx

    1. 소프트웨어 정품 인증 

    http://www.microsoft.com/korea/piracy/activation.mspx

    1. 정품 인증 FAQ 

    http://www.microsoft.com/korea/piracy/activation\_faq.mspx

    제가 문제에 대해 더 알아야 할 것이 있다면 응답 주시면 감사하겠습니다.

    제시해 드린 답변이 도움이 되었기를 바랍니다.

    이 대답이 도움이 되었나요?

    댓글 0개 설명 없음