Data Lake Tools for Visual Studio를 사용하여 U-SQL 스크립트 개발

Azure Data Lake 및 Stream Analytics Tools는 두 가지 Azure 서비스, Azure Data Lake Analytics 및 Azure Stream Analytics와 관련된 기능을 포함합니다. Azure Stream Analytics 시나리오에 대한 자세한 내용은 Azure Stream Analytics Tools for Visual Studio를 참조하세요.

이 문서에서는 Visual Studio를 사용하여 Azure Data Lake Analytics 계정을 만드는 방법을 설명합니다. U-SQL 에서 작업을 정의하고 작업을 Data Lake Analytics 서비스로 제출할 수 있습니다. 데이터 레이크 분석에 대한 자세한 내용은 Azure 데이터 레이크 분석 개요를 참조하세요.

중요

Azure Data Lake Tools for Visual Studio 버전 2.3.3000.4 이상으로 업그레이드하는 것이 좋습니다. 이전 버전은 더 이상 다운로드할 수 없으며 이제 사용되지 않습니다.

  1. 사용 중인 Azure Data Lake Tools for Visual Studio 버전이 2.3.3000.4 미만인지 확인합니다.

    Check tool version

  2. 버전이 2.3.3000.4 미만이면 다운로드 센터를 방문하여 Azure Data Lake Tools for Visual Studio를 업데이트합니다.

사전 요구 사항

Azure Data Lake Tools for Visual Studio 설치

이 자습서를 실행하려면 Data Lake Tools for Visual Studio가 설치되어 있어야 합니다. 자세한 내용은 Data Lake Tools for Visual Studio 설치를 참조하세요.

Azure Data Lake Analytics 계정에 연결

  1. Visual Studio를 엽니다.

  2. 보기>Data Lake Analytics 탐색기를 선택하여 Data Lake Analytics 탐색기를 엽니다.

  3. Azure를 마우스 오른쪽 단추로 클릭한 다음, Microsoft Azure 구독에 연결을 선택합니다. 계정에 로그인에서 지침을 따릅니다.

  4. 서버 탐색기에서 Azure>Data Lake Analytics를 선택합니다. Data Lake Analytics 계정 목록이 표시됩니다.

첫 번째 U-SQL 스크립트 작성

다음 텍스트는 간단한 U-SQL 스크립트입니다. 작은 데이터 세트를 정의하고 이 데이터 세트를 /data.csv라는 파일로 기본 Data Lake Store에 기록합니다.

USE DATABASE master;
USE SCHEMA dbo;
@a  = 
    SELECT * FROM 
        (VALUES
            ("Contoso", 1500.0),
            ("Woodgrove", 2700.0)
        ) AS 
              D( customer, amount );
OUTPUT @a
    TO "/data.csv"
    USING Outputters.Csv();

데이터 레이크 분석 작업 제출

  1. Visual Studio에서 파일>새로 만들기>프로젝트를 선택합니다.

  2. U-SQL 프로젝트 유형을 선택하고 다음을 선택합니다. 새 프로젝트 구성에서 만들기를 선택합니다.

    Visual Studio는 Script.usql 파일을 포함하는 솔루션을 만듭니다.

  3. 첫 번째 U-SQL 스크립트 작성의 스크립트를 Script.usql 창에 붙여 넣습니다.

  4. 솔루션 탐색기에서 Script.usql을 마우스 오른쪽 클릭하고 스크립트 제출을 선택합니다.

  5. 작업 제출에서 Data Lake Analytics 계정을 선택하고 제출을 선택합니다.

    Submit U-SQL Visual Studio project

작업을 제출하면 작업 보기 탭이 열리고 작업 진행률이 표시됩니다.

  • 작업 요약에 작업의 요약 정보가 표시됩니다.
  • 작업 그래프는 작업의 진행률을 시각화합니다.
  • 메타데이터 작업에는 U-SQL 카탈로그에서 수행된 모든 작업이 표시됩니다.
  • 데이터에는 모든 입력 및 출력이 표시됩니다.
  • 상태 기록은 타임라인 및 상태 세부 정보를 보여줍니다.
  • AU 분석은 작업에 사용된 AU 수를 보여 주고 다른 AU 할당 전략의 시뮬레이션을 살펴봅니다.
  • 진단에서는 작업 실행 및 성능 최적화에 대한 고급 분석을 제공합니다.

U-SQL Visual Studio Data Lake Analytics job performance graph

최근 작업 상태를 보고 화면을 새로 고치려면 새로 고침을 선택합니다.

작업 상태 확인

  1. 서버 탐색기에서 Azure>Data Lake Analytics를 선택합니다.

  2. Data Lake Analytics 계정 이름을 확장합니다.

  3. 작업을 두 번 클릭합니다.

  4. 이전에 제출한 작업을 선택합니다.

작업 출력 보기

  1. 서버 탐색기에서 제출한 작업을 찾습니다.

  2. 데이터 탭을 클릭합니다.

  3. 작업 출력 탭에서 "/data.csv" 파일을 선택합니다.

다음 단계