소유자는 Exchange Server 2013 또는 Exchange Server 2016에서 Outlook을 사용하여 최신 공용 폴더를 만들 수 없습니다.
증상
사용자가 공용 폴더 사서함의 소유자이거나 Microsoft Exchange Server 2013 또는 Microsoft Exchange Server 2016 환경에서 공용 폴더를 만들 수 있는 충분한 액세스 권한이 있다고 가정합니다. 사서함은 보조 계층 구조를 기본 공용 폴더 사서함으로 사용합니다. 이 경우 Microsoft Outlook을 사용하여 공용 폴더를 만들려고 하면 다음과 같은 오류 메시지가 표시됩니다.
폴더를 만들 수 없습니다. 이 개체에 대해 이 작업을 수행할 수 있는 충분한 권한이 없습니다. 폴더 연락처 또는 시스템 관리자를 참조하세요.
참고
기본 공용 폴더 사서함이 기본 계층 구조를 포함하는 공용 폴더 사서함으로 변경된 경우 Outlook을 사용하여 공용 폴더를 만들 수 있습니다.
이 문서의 문제를 해결하는 방법에 대한 자세한 내용을 참조하세요.
원인
이 문제는 Exchange Server 사서함 서버 역할의 레지스트리 항목이 2보다 작은 값으로 구성되었기 때문에 LmCompatibilityLevel
발생합니다.
해결 방법
중요
주의를 기울여 이 절의 단계를 수행하십시오. 레지스트리를 잘못 수정하면 심각한 문제가 발생할 수 있습니다. 레지스트리를 수정하기 전에 문제가 발생할 경우에 대비하여 레지스트리를 복원 가능하도록 백업하세요.
이 문제를 해결하려면 보조 계층 공용 폴더 사서함을 호스팅하는 Exchange Server 사서함 서버 역할에서 다음 단계를 수행합니다.
레지스트리 항목의
LmCompatibilityLevel
값을 2 이상으로 변경합니다.참고
항목은 다음 레지스트리 경로 아래에 있습니다.
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa다음 서비스를 다시 시작합니다.
- Microsoft Exchange Information Store
- Microsoft Exchange RPC 클라이언트 액세스
- Microsoft Exchange Health Manager
추가 정보
LmCompatibilityLevel 설정에 대한 자세한 내용은 다음 문서를 참조하세요.
LmCompatibilityLevel 레지스트리 항목에 대한 일반 정보
보안 감시: 가장 오해의 소지가 있는 Windows 보안 설정
이 문제를 해결하기 위한 자세한 정보
이 문제가 발생하면 오류 메시지 외에 이 문제를 해결하는 데 도움이 될 수 있는 다음 정보를 찾을 수도 있습니다.
다음 메시지는 이벤트 뷰어 "RPC 클라이언트 액세스" 로그 아래에 기록됩니다.
Client=MSExchangeRPC,,,,-2147024891 (rop::AccessDenied),00:00:00.0310000,,"RopHandler: CreateFolder: [AccessDeniedException] Cannot open mailbox /o=Contoso/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=9f049c7972fb4d8ebe9f5ece73e136fe-PFHierarchy. -> [MapiExceptionNoAccess] Unable to make connection to the server. (hr=0x80070005, ec=-2147024891) [diag::AAAGAgAA/wAAAAAAAAAAA/gBAACYMvAvAQAAACwQAsAAAAAA6PIAEHA5FpCYP/AvBQAAAG4vYQBwORaQmCHwH/Q1AACYMfAvcDkWkAk00AEsEALAmCnwHw0AAACYOfAfLBACwJgl8B95BQAAmDXwHwAAAACYLfAfAAAAAOjyABBwORaQmD/wLwUAAABuL2EAcDkWkJgh8B/0NQAAmDHwL3A5FpAJNNABkQEAAJgp8B8NAAAAmDnwH5EBAACYJfAfiQUAAJg18B8AAAAAmC3wHwEAAACYIvA/AAAAAFVuYXV0aG9yaXplZAAAAADo8gAQcDkWkJg/8C8FAAAAbi9hAHA5FpCYIfAf9DUAAJgx8C9wORaQCTTQAQAAAACYKfAfDQAAAJg58B8AAAAAmCXwH+ELAACYNfAfAAAAAJgt8B8AAAAA6PIAEHA5FpCYP/AvBQAAAG4vYQBwORaQmCHwH/Q1AACYMfAvcDkWkAk00AHhCwAAmCnwHw0AAACYOfAfAAAAAJgl8B/hCwAAmDXwHwAAAACYLfAfAAAAAHHoQBAFAAeAcMVAIQAPFIQZAPAvBQAAAHDLQBAFAAeA0McAEPQ1AADxzEAQBQAHgKHqABAFAAAA8YNAEAUAB4Cd6QAQBQAAAAfNQBAFAAeAQk0AEAAAAABCbUAQBQAHgEJFABAAAAAAQmVAEAUAB4A=] at M.E.D.S.RPCPrimaryHierarchyProvider.GetHierarchyStore() at M.E.D.S.RPCPrimaryHierarchyProvider.CreateFolder(String folderName, String folderDescription, StoreId parentFolderId, CreateMode mode, Guid& contentMailboxGuid) at M.E.R.H.PublicFolderOperations.<>c__DisplayClass1.<CreateFolder>b__0(StoreId& folderIdToSync, Guid& contentMailboxGuid) at M.E.R.H.PublicFolderOperations.InvokeOnPrimaryHierarchyAndSync[T](Boolean isCompleteSync, PublicLogon publicLogon, PrimaryHierarchy",,,admin@contoso.com,
EMS(Exchange Management Shell)에서 Get-ServerHealth -Identity ServerIdParameter -HealthSet 'Outlook.Protocol' 명령을 실행하는 경우 Outlook.Protocol 상태 집합은 특히 Outlook 원격 프로시저 호출 RPC와 관련된 다음 모니터에 대해 비정상으로 보고합니다.
- OutlookRpcDeepTestMonitor
- OutlookRpcSelfTestMonitor
OutlookRpcDeepTestProbe 프로브의 실패는 다음 메시지를 기록합니다.
Microsoft.Exchange.Rpc.RpcException: Error 0x5 (Access is denied) from ClientAsyncCallState.CheckCompletion: RpcAsyncCompleteCall