Linux에 PowerShell 설치

PowerShell은 다양한 Linux 배포판에 설치할 수 있습니다. 대부분의 Linux 플랫폼과 배포판은 매년 주요 릴리스가 있으며, PowerShell을 설치하는 데 사용되는 패키지 관리자를 제공합니다. 이 문서에서는 현재 지원되는 버전과 사용되는 패키지 관리자에 대해 설명합니다.

이 문서의 나머지 부분에서는 PowerShell에서 지원하는 각 Linux 배포판에 대해 자세히 설명합니다. 모든 PowerShell 릴리스는 PowerShell 지원 종료 버전 또는 Linux 배포판 지원 종료 버전까지 계속 지원됩니다.

최상의 호환성을 원한다면 장기 릴리스(LTS) 버전을 선택합니다.

Alpine

다음 표에는 지원되는 PowerShell 릴리스 및 해당 릴리스가 지원되는 Alpine 버전이 나와 있습니다. 이러한 버전은 PowerShell 지원 종료 버전 또는 Alpine 지원 종료 버전까지 지원됩니다.

  • 지원되는 아이콘은 OS 또는 PowerShell 버전이 계속 지원됨을 나타냅니다.
  • 지원되지 않음 아이콘은 해당 버전의 OS에서 PowerShell 버전이 더 이상 지원되지 않음을 나타냅니다.
  • 테스트 중 아이콘은 해당 OS에서 PowerShell 테스트를 완료하지 않았음을 나타냅니다.
  • 지원되지 않음 아이콘은 OS 또는 PowerShell 버전이 지원되지 않음을 나타냅니다.
  • OS 버전과 PowerShell 버전 모두 지원되는 아이콘이 있는 경우 해당 조합이 지원됩니다.
Alpine 7.0(LTS) 7.1 7.2(LTS-current) 7.3
지원되는 3.15 지원되지 않음 지원되지 않음 테스트 중 테스트 중
지원되는 3.14 지원되지 않음 지원 중단 지원됨 지원됨
지원되지 않음 3.13 지원되지 않음 지원 중단 지원 중단 지원 중단
지원되지 않음 3.12 지원 중단 지원 중단 지원 중단 지원 중단
지원되지 않음 3.11 지원되지 않음 지원 중단 지원되지 않음 지원되지 않음
지원되지 않음 3.10 지원 중단 지원 중단 지원되지 않음 지원되지 않음
지원되지 않음 3.9 지원 중단 지원 중단 지원되지 않음 지원되지 않음

Alpine 3.15는 테스트 중입니다.

PowerShell은 Alpine에서 다음 프로세서 아키텍처에 대해 지원됩니다.

Alpine 7.0(LTS) 7.2(LTS-current) 7.3
지원되는 모든 버전 X64 X64 X64

PowerShell은 Arm 프로세서를 사용하여 Alpine에서 테스트되지 않았습니다.

자세한 내용은 에 PowerShell 설치를 참조하세요.

Debian

Debian은 패키지 관리자로 APT(고급 패키지 도구)를 사용합니다.

다음 표는 현재 지원되는 PowerShell 릴리스와 해당 릴리스가 지원되는 Debian 버전의 목록입니다. 이러한 버전은 PowerShell 지원 종료 버전 또는 Debian 지원 종료 버전까지 계속 지원됩니다.

  • 지원되는 아이콘은 OS 또는 PowerShell 버전이 계속 지원됨을 나타냅니다.
  • 지원되지 않음 아이콘은 해당 버전의 OS에서 PowerShell 버전이 더 이상 지원되지 않음을 나타냅니다.
  • 테스트 중 아이콘은 해당 OS에서 PowerShell 테스트를 완료하지 않았음을 나타냅니다.
  • 지원되지 않음 아이콘은 OS 또는 PowerShell 버전이 지원되지 않음을 나타냅니다.
  • OS 버전과 PowerShell 버전 모두 지원되는 아이콘이 있는 경우 해당 조합이 지원됩니다.
Debian 7.0(LTS) 7.1 7.2(LTS-current) 7.3
지원되는 11 지원 여부 지원 중단 지원됨 지원됨
지원되는 10 지원됨 지원 중단 지원됨 지원됨
지원되는 9 지원 중단 지원 중단 지원 중단 지원 중단
지원되지 않음 8 지원 중단 지원되지 않음 지원되지 않음 지원되지 않음

PowerShell은 Debian에서 다음 프로세서 아키텍처에 대해 지원됩니다.

Debian 7.0(LTS) 7.2(LTS-current) 7.3
버전 9+ x64, Arm32, Arm64 x64, Arm32, Arm64 x64, Arm32, Arm64

자세한 내용은 Debian에 PowerShell 설치를 참조하세요.

RHEL(Red Hat Enterprise Linux)

RHEL 7은 yum을 사용하고 RHEL 8은 dnf 패키지 관리자를 사용합니다.

다음 표는 현재 지원되는 PowerShell 버전 및 해당 버전이 지원되는 RHEL 버전의 목록입니다. 이러한 버전은 PowerShell 지원 종료 버전 또는 RHEL 지원 종료 버전까지 계속 지원됩니다.

  • 지원되는 아이콘은 OS 또는 PowerShell 버전이 계속 지원됨을 나타냅니다.
  • 지원되지 않음 아이콘은 해당 버전의 OS에서 PowerShell 버전이 더 이상 지원되지 않음을 나타냅니다.
  • 테스트 중 아이콘은 해당 OS에서 PowerShell 테스트를 완료하지 않았음을 나타냅니다.
  • 지원되지 않음 아이콘은 OS 또는 PowerShell 버전이 지원되지 않음을 나타냅니다.
  • OS 버전과 PowerShell 버전 모두 지원되는 아이콘이 있는 경우 해당 조합이 지원됩니다.
RHEL 7.0(LTS) 7.1 7.2(LTS-current) 7.3
지원되는 8 지원 여부 지원 중단 지원됨 지원 여부
지원되는 7 지원됨 지원 중단 지원됨 지원 여부

PowerShell은 RHEL에서 다음 프로세서 아키텍처에 대해 지원됩니다.

RHEL 7.0(LTS) 7.2(LTS-current) 7.3
지원되는 모든 버전 X64 x64, Arm64 x64, Arm64

자세한 내용은 RHEL에 PowerShell 설치를 참조하세요.

Ubuntu

Ubuntu는 패키지 관리자로 APT(고급 패키지 도구)를 사용합니다.

다음 표는 현재 지원되는 PowerShell 릴리스와 해당 릴리스가 지원되는 Ubuntu 버전의 목록입니다. 이러한 버전은 PowerShell 지원 종료 버전 또는 Ubuntu 지원 종료 버전까지 계속 지원됩니다.

  • 지원되는 아이콘은 OS 또는 PowerShell 버전이 계속 지원됨을 나타냅니다.
  • 지원되지 않음 아이콘은 해당 버전의 OS에서 PowerShell 버전이 더 이상 지원되지 않음을 나타냅니다.
  • 테스트 중 아이콘은 해당 OS에서 PowerShell 테스트를 완료하지 않았음을 나타냅니다.
  • 지원되지 않음 아이콘은 OS 또는 PowerShell 버전이 지원되지 않음을 나타냅니다.
  • OS 버전과 PowerShell 버전 모두 지원되는 아이콘이 있는 경우 해당 조합이 지원됩니다.
Ubuntu 7.0(LTS) 7.1 7.2(LTS-current) 7.3
지원되는 22.04(LTS) 지원되지 않음 지원 중단 지원됨 지원 여부
지원되는 20.04(LTS) 지원 여부 지원 중단 지원됨 지원 여부
지원되는 18.04(LTS) 지원 여부 지원 중단 지원됨 지원 여부
지원되지 않는 16.04(LTS) 지원 중단 지원 중단 지원되지 않음 지원되지 않음

Ubuntu의 LTS 릴리스만 공식적으로 지원됩니다. Microsoft는 중간 릴리스 또는 이와 동등한 릴리스를 지원하지 않습니다. 중간 릴리스는 커뮤니티에서 지원됩니다. 자세한 내용은 커뮤니티 지원 배포를 참조하세요.

PowerShell은 Ubuntu에서 다음 프로세서 아키텍처에 대해 지원됩니다.

Ubuntu 7.0(LTS) 7.2(LTS-current) 7.3
지원되는 모든 버전 x64, Arm32, Arm64 x64, Arm32, Arm64 x64, Arm32, Arm64

자세한 내용은 Ubuntu에 PowerShell 설치를 참조하세요.

Raspberry Pi OS

Raspberry Pi OS(이전의 Raspbian)는 Debian을 기반으로 하는 무료 운영 체제입니다.

중요

Raspberry Pi Zero 및 Raspberry Pi 2 이전의 Raspberry Pi 디바이스를 비롯한 ARMv6 아키텍처 디바이스에서는 .NET이 지원되지 않습니다.

자세한 내용은 Raspberry Pi OS에 PowerShell 설치를 참조하세요.

커뮤니티 지원 배포판

Microsoft에서 공식적으로 지원하지 않는 Linux 배포판이 많이 있습니다. 경우에 따라 커뮤니티에서 이러한 릴리스에 대한 PowerShell을 지원할 수 있습니다. 자세한 내용은Linux 기반 PowerShell에 대한 커뮤니티 지원을 참조하세요.

CentOS 및 Fedora 배포는 더 이상 지원되지 않습니다. 지원되었던 해당 운영 체제 버전이 수명 종료 날짜에 도달했습니다. 최신 버전은 모두 지원하지 않습니다.

대체 설치 방법

공식적으로 지원되지 않는 Linux 배포판 등 Linux에 PowerShell을 설치하는 세 가지 다른 방법이 있습니다. PowerShell 스냅 패키지를 사용하여 PowerShell을 설치할 수 있습니다. Linux tar.gz를 사용하여 PowerShell 이진 파일을 직접 배포할 수도 있습니다. 자세한 내용은 Linux에서 PowerShell을 설치하는 다른 방법을 참조하세요.