보안 게시판

Microsoft 보안 게시판 MS12-039 - 중요

Lync의 취약성으로 인해 원격 코드 실행을 허용할 수 있음(2707956)

게시 날짜: 2012년 6월 12일

버전: 1.0

일반 정보

이 보안 업데이트는 Microsoft Lync에서 공개적으로 공개된 취약성 1개와 비공개로 보고된 세 가지 취약성을 해결합니다. 가장 심각한 취약성은 사용자가 특별히 제작된 TrueType 글꼴이 포함된 공유 콘텐츠를 보는 경우 원격 코드 실행을 허용할 수 있습니다.

이 보안 업데이트는 Microsoft Lync 2010, Microsoft Lync 2010 Attendee, Microsoft Lync 2010 전화 교환(32비트) 및 Microsoft Lync 2010 전화 교환(64비트)에 중요 등급이 지정됩니다. 자세한 내용은 이 섹션의 하위 섹션인 영향을 받는 소프트웨어 및 영향을 받지 않는 소프트웨어를 참조하세요.

보안 업데이트는 특수하게 작성된 True Type Font 파일이 처리되는 방식을 수정하고, Microsoft Lync가 외부 라이브러리를 로드하는 방식을 수정하고, SafeHTML 함수가 HTML 콘텐츠를 삭제하는 방식을 수정하여 취약성을 해결합니다. 취약성에 대한 자세한 내용은 다음 섹션인 취약성 정보에서 특정 취약성 항목에 대한 FAQ(질문과 대답) 하위 섹션을 참조 하세요.

추천. 고객은 Microsoft 업데이트 서비스를 사용하여 Microsoft 업데이트의 업데이트를 위해 온라인으로 검사 자동 업데이트를 구성할 수 있습니다. Microsoft 업데이트의 업데이트를 위해 온라인으로 검사 자동 업데이트를 사용하도록 설정하고 구성한 고객은 일반적으로 이 보안 업데이트가 자동으로 다운로드 및 설치되므로 아무 작업도 수행할 필요가 없습니다. 자동 업데이트를 사용하도록 설정하지 않은 고객은 Microsoft 업데이트의 업데이트를 검사 이 업데이트를 수동으로 설치해야 합니다. Windows XP 및 Windows Server 2003의 지원되는 버전에서 자동 업데이트의 특정 구성 옵션에 대한 자세한 내용은 Microsoft 기술 자료 문서 294871 참조하세요. 지원되는 Windows Vista 버전, Windows Server 2008, Windows 7 및 Windows Server 2008 R2의 자동 업데이트에 대한 자세한 내용은 Windows 자동 업데이트 이해를 참조하세요.

관리자 및 엔터프라이즈 설치 또는 이 보안 업데이트를 수동으로 설치하려는 최종 사용자의 경우 고객은 업데이트 관리 소프트웨어를 사용하거나 Microsoft 업데이트 서비스를 사용하여 업데이트를 확인하여 최대한 빨리 업데이트를 적용하는 것이 좋습니다.

이 게시판의 뒷부분에 있는 검색 및 배포 도구 및 지침 섹션도 참조하세요.

알려진 문제.Microsoft 기술 자료 문서 2707956 이 보안 업데이트를 설치할 때 고객이 발생할 수 있는 현재 알려진 문제를 설명합니다. 또한 이 문서에서는 이러한 문제에 대한 권장 솔루션을 문서화합니다.

영향을 받는 소프트웨어 및 영향을 받지 않는 소프트웨어

영향을 받는 버전 또는 버전을 확인하기 위해 다음 소프트웨어가 테스트되었습니다. 다른 버전 또는 버전은 지원 수명 주기를 지나거나 영향을 받지 않습니다. 소프트웨어 버전 또는 버전의 지원 수명 주기를 확인하려면 Microsoft 지원 수명 주기를 방문하세요.

영향을 받는 소프트웨어

소프트웨어 최대 보안 영향 집계 심각도 등급 업데이트 바꾸기
Microsoft Communicator 2007 R2\(KB2708980) 정보 공개 중요 없음
Microsoft Lync 2010(32비트)\ (KB2693282) 원격 코드 실행 중요 없음
Microsoft Lync 2010(64비트)\ (KB2693282) 원격 코드 실행 중요 없음
Microsoft Lync 2010 Attendee\ (관리자 수준 설치)\ (KB2696031)\ \ Microsoft Lync 2010 Attendee[1]\ (사용자 수준 설치)\ (KB2693283) 원격 코드 실행 중요 없음
Microsoft Lync 2010 전화 교환(32비트)\ (KB2702444) 원격 코드 실행 중요 없음
Microsoft Lync 2010 전화 교환(64비트)\ (KB2702444) 원격 코드 실행 중요 없음

[1]이 업데이트는 Microsoft 다운로드 센터에서만 사용할 수 있습니다.

영향을 받지 않는 소프트웨어

Office 및 기타 소프트웨어
Microsoft Speech Server 2004
Microsoft Speech Server 2004 R2
Microsoft Live Meeting 2007 콘솔
Microsoft Live Communications Server 2003
Microsoft Live Communications Server 2005 서비스 팩 1
Microsoft Communicator 2005
Microsoft Communicator 2005 웹 액세스
Microsoft Communicator 2007
Microsoft Communicator 2007 웹 액세스
Microsoft Communications Server 2007
Microsoft Communications Server 2007 Speech Server
Microsoft Communications Server 2007 R2
Microsoft Communicator 2007 R2 전화 교환
Microsoft Communicator 2007 R2 그룹 채팅 관리
Microsoft Communicator 2007 R2 그룹 채팅 클라이언트
Mac용 Microsoft Communicator 2011
Mac용 Microsoft Lync 2011
Microsoft Lync Server 2010
Microsoft Lync Server 2010 소프트웨어 개발 키트

파일 정보 세부 정보는 어디에 있나요?
파일 정보 세부 정보의 위치는 보안 업데이트 배포 섹션의 참조 테이블을 참조하세요.

Lync2010 참석자(사용자 수준 설치) 업데이트는 Microsoft 다운로드 센터에서만 사용할 수 있는 이유는 무엇인가요?
Microsoft는 Lync 2010 참석자(사용자 수준 설치)에 대한 업데이트를 Microsoft 다운로드 센터에 만 릴리스합니다. Lync 2010 참석자의 사용자 수준 설치는 Lync 세션을 통해 처리되므로 자동 업데이트와 같은 배포 방법은 이러한 유형의 설치 시나리오에 적합하지 않습니다.

이 보안 업데이트는 MS12-034와 어떻게 관련되어 있나요?
이 공지에 설명된 대로 Microsoft Lync 및 관련 소프트웨어에 영향을 주는 TrueType 글꼴 구문 분석 취약성( CVE-2011-3402)은 MS12-034에 설명된 대로 다른 Microsoft 소프트웨어에도 영향을 줍니다. 그러나 시스템에 설치한 소프트웨어에 해당하는 업데이트만 설치할 수 있습니다. Microsoft Lync 또는 관련 영향을 받는 소프트웨어를 설치한 경우 이 공지에 따라 필요한 업데이트를 적용합니다. Microsoft Windows, Microsoft Office 및 Microsoft Silverlight의 경우 MS12-034에 따라 필요한 업데이트를 적용합니다.

이 보안 업데이트는 MS12-037과 어떻게 관련되어 있나요?
이 게시판에 설명된 HTML 삭제 취약성(CVE-2012-1858)도 인터넷 Explorer 영향을 줍니다. 그러나 시스템에 설치한 소프트웨어에 해당하는 업데이트만 설치할 수 있습니다. Microsoft Lync를 설치한 경우 이 공지에 따라 필요한 업데이트를 적용합니다. 인터넷 Explorer 설치한 경우 MS12-037에 따라 필요한 업데이트를 적용합니다.

이 업데이트는 Microsoft 보안 공지 2269637 관련되어 있나요?
예, 이 업데이트에서 해결된 취약성은 애플리케이션이 외부 라이브러리를 로드하는 방식에 영향을 주는 Microsoft 보안 권고 2269637 설명된 취약성 클래스와 관련이 있습니다. 이 보안 업데이트는 이러한 유형의 취약성에 대한 특정 instance 해결합니다.

이 업데이트가 보고된 몇 가지 보안 취약성을 해결하는 이유는 무엇인가요?
이 업데이트에는 이러한 문제를 해결하는 데 필요한 수정 사항이 관련 파일에 있으므로 몇 가지 취약성에 대한 지원이 포함되어 있습니다. 고객은 거의 동일한 여러 업데이트를 설치하는 대신 이 업데이트만 설치해야 합니다.

이 업데이트에 기능에 대한 보안 관련 변경 내용이 포함되어 있나요?  
예. 이 공지의 취약성 정보 섹션에 나열된 변경 내용 외에도 이 업데이트에는 Microsoft Communicator 및 Microsoft Lync의 보안 관련 기능을 개선하는 데 도움이 되는 심층 방어 업데이트가 포함되어 있습니다.

심층 방어란?
정보 보안에서 심층 방어는 공격자가 네트워크 또는 시스템의 보안을 손상시키는 것을 방지하기 위해 여러 방어 계층이 배치되는 접근 방식을 의미합니다.

이 보안 게시판에 설명된 이전 버전의 소프트웨어를 사용하고 있습니다.   어떻게 해야 합니까?
이 공지에 나열된 영향을 받는 소프트웨어는 영향을 받는 릴리스를 확인하기 위해 테스트되었습니다. 다른 릴리스는 지원 수명 주기를 지났습니다. 제품 수명 주기에 대한 자세한 내용은 Microsoft 지원 수명 주기 웹 사이트를 방문하세요.

소프트웨어의 이전 릴리스가 있는 고객은 취약성에 대한 잠재적 노출을 방지하기 위해 지원되는 릴리스로 마이그레이션하는 것이 우선 순위여야 합니다. 소프트웨어 릴리스에 대한 지원 수명 주기를 확인하려면 수 명 주기 정보용 제품 선택을 참조하세요. 이러한 소프트웨어 릴리스의 서비스 팩에 대한 자세한 내용은 서비스 팩 수명 주기 지원 정책을 참조하세요.

이전 소프트웨어에 대한 사용자 지정 지원이 필요한 고객은 Microsoft 계정 팀 담당자, 기술 계정 관리자 또는 적절한 Microsoft 파트너 담당자에게 사용자 지정 지원 옵션에 문의해야 합니다. Alliance, Premier 또는 Authorized Contract가 없는 고객은 현지 Microsoft 영업 사무소에 문의할 수 있습니다. 연락처 정보는 Microsoft Worldwide Information 웹 사이트를 방문하여 연락처 정보 목록에서 국가를 선택한 다음 이동을 클릭하여 전화 번호 목록을 확인합니다. 전화를 걸 때 로컬 프리미어 지원 영업 관리자에게 문의하세요. 자세한 내용은 Microsoft 지원 수명 주기 정책 FAQ를 참조하세요.

취약성 정보

심각도 등급 및 취약성 식별자

다음 심각도 등급은 취약성의 잠재적 최대 영향을 가정합니다. 이 보안 공지가 릴리스된 후 30일 이내에 심각도 등급 및 보안 영향과 관련된 취약성의 악용 가능성에 대한 자세한 내용은 6월 게시판 요약의 악용 가능성 지수를 참조하세요. 자세한 내용은 Microsoft Exploitability Index를 참조하세요.

영향을 받는 소프트웨어 TrueType 글꼴 구문 분석 취약성 - CVE-2011-3402 TrueType 글꼴 구문 분석 취약성 - CVE-2012-0159 Lync 안전하지 않은 라이브러리 로드 취약성 - CVE-2012-1849 HTML 삭제 취약성 - CVE-2012-1858 집계 심각도 등급
Microsoft Communicator 2007 R2 해당 사항 없음 해당 사항 없음 해당 사항 없음 중요 정보 공개 중요
Microsoft Lync 2010(32비트) 중요 원격 코드 실행 중요 원격 코드 실행 중요 원격 코드 실행 중요 정보 공개 중요
Microsoft Lync 2010(64비트) 중요 원격 코드 실행 중요 원격 코드 실행 중요 원격 코드 실행 중요 정보 공개 중요
Microsoft Lync 2010 Attendee 중요 원격 코드 실행 중요 원격 코드 실행 중요 원격 코드 실행 중요 정보 공개 중요
Microsoft Lync 2010 전화 교환(32비트) 해당 사항 없음 해당 사항 없음 중요 원격 코드 실행 해당 사항 없음 중요
Microsoft Lync 2010 전화 교환(64비트) 해당 사항 없음 해당 사항 없음 중요 원격 코드 실행 해당 사항 없음 중요

TrueType 글꼴 구문 분석 취약성 - CVE-2011-3402

영향을 받는 구성 요소가 특별히 제작된 TrueType 글꼴을 포함하는 공유 콘텐츠를 처리하는 방식으로 원격 코드 실행 취약성이 존재합니다. 이 취약성은 사용자가 특별히 제작된 TrueType 글꼴이 포함된 공유 콘텐츠를 보는 경우 원격 코드 실행을 허용할 수 있습니다. 이 취약성을 성공적으로 악용한 공격자는 영향을 받는 시스템을 완전히 제어할 수 있습니다. 그렇게 되면 공격자는 프로그램을 설치할 수 있고, 데이터를 열람하거나 변경 또는 삭제할 수 있으며, 모든 사용자 권한을 갖고 새 계정을 만들 수 있습니다. 자신의 계정이 시스템 관련 사용자 권한이 거의 없도록 구성되어있는 사용자는, 관리자 권한으로 작업하도록 구성되어있는 사용자보다 영향을 덜 받을 것입니다.

이 취약성을 일반적인 취약성 및 노출 목록에서 표준 항목으로 보려면 CVE-2011-3402를 참조하세요.

TrueType 글꼴 구문 분석 취약성에 대한 요소 완화 - CVE-2011-3402

완화는 취약성 악용의 심각도를 줄일 수 있는 기본 상태에 존재하는 설정, 일반적인 구성 또는 일반적인 모범 사례를 나타냅니다. 다음과 같은 완화 요인이 상황에 도움이 될 수 있습니다.

  • 이 취약성을 성공적으로 악용한 공격자는 현재 사용자와 동일한 사용자 권한을 얻을 수 있습니다. 자신의 계정이 시스템 관련 사용자 권한이 거의 없도록 구성되어있는 사용자는, 관리자 권한으로 작업하도록 구성되어있는 사용자보다 영향을 덜 받을 것입니다.

TrueType 글꼴 구문 분석 취약성에 대한 해결 방법 - CVE-2011-3402

Microsoft는 이 취약성에 대한 해결 방법을 확인하지 않았습니다.

TrueType 글꼴 구문 분석 취약성에 대한 FAQ - CVE-2011-3402

취약성의 scope 무엇인가요?
원격 코드 실행 취약성입니다.

취약성의 원인은 무엇인가요?
이 취약성은 특별히 작성된 TTF(True Type Font) 파일이 잘못 처리될 때 발생합니다.

공격자가 취약성을 사용하여 수행할 수 있는 작업은 무엇인가요?
이 취약성을 성공적으로 악용한 공격자는 현재 사용자와 동일한 사용자 권한을 얻을 수 있습니다. 현재 사용자가 관리자 권한으로 로그온한 경우 공격자는 영향을 받는 시스템을 완전히 제어할 수 있습니다. 그렇게 되면 공격자는 프로그램을 설치할 수 있고, 데이터를 열람하거나 변경 또는 삭제할 수 있으며, 모든 사용자 권한을 갖고 새 계정을 만들 수 있습니다. 자신의 계정이 시스템 관련 사용자 권한이 거의 없도록 구성되어있는 사용자는, 관리자 권한으로 작업하도록 구성되어있는 사용자보다 영향을 덜 받을 것입니다.

공격자가 취약성을 어떻게 악용할 수 있나요?
공격자는 특별히 제작된 TrueType 글꼴이 포함된 콘텐츠를 공유할 수 있습니다. 사용자가 특별히 제작된 TrueType 글꼴이 포함된 공유 콘텐츠를 볼 때 취약성이 악용될 수 있습니다.

주로 취약성으로 인한 위험에 처한 시스템은 무엇인가요?
워크스테이션 및 터미널 서버는 주로 위험에 처해 있습니다. 관리자가 사용자가 서버에 로그온하고 프로그램을 실행할 수 있도록 허용하면 서버가 더 위험할 수 있습니다. 그러나 모범 사례에서는 이를 허용하지 않습니다.

업데이트는 무엇을 수행하나요?
이 업데이트는 특별히 제작된 TTF 파일이 처리되는 방법을 수정하여 취약성을 해결합니다.

이 보안 공지가 발행되었을 때 이 취약성이 공개적으로 공개되었습니까?
예. 이 취약성은 공개적으로 공개되었습니다. 일반적인 취약성 및 노출 번호 CVE-2011-3402가 할당되었습니다.

이 보안 공지가 발행되었을 때 Microsoft는 이 취약성이 악용되고 있다는 보고를 받았습니까?
이 취약성은 이전에 제한된 대상 공격을 통해 악용되었지만 악용된 공격 벡터는 MS11-087, Windows Kernel-Mode 드라이버의 취약성으로 2639417(원격 코드 실행을 허용할 수 있음)에서 해결되었습니다. Microsoft는 이 공지에 언급된 공격 벡터가 이 보안 공지가 원래 발행되었을 때 고객을 공격하는 데 공개적으로 사용되었음을 나타내는 정보를 받지 못했습니다.

TrueType 글꼴 구문 분석 취약성 - CVE-2012-0159

영향을 받는 구성 요소가 특별히 제작된 TrueType 글꼴을 포함하는 공유 콘텐츠를 처리하는 방식으로 원격 코드 실행 취약성이 존재합니다. 이 취약성은 사용자가 특별히 제작된 TrueType 글꼴이 포함된 공유 콘텐츠를 보는 경우 원격 코드 실행을 허용할 수 있습니다. 이 취약성을 성공적으로 악용한 공격자는 영향을 받는 시스템을 완전히 제어할 수 있습니다. 그렇게 되면 공격자는 프로그램을 설치할 수 있고, 데이터를 열람하거나 변경 또는 삭제할 수 있으며, 모든 사용자 권한을 갖고 새 계정을 만들 수 있습니다. 자신의 계정이 시스템 관련 사용자 권한이 거의 없도록 구성되어있는 사용자는, 관리자 권한으로 작업하도록 구성되어있는 사용자보다 영향을 덜 받을 것입니다.

이 취약성을 일반적인 취약성 및 노출 목록에서 표준 항목으로 보려면 CVE-2012-0159를 참조하세요.

TrueType 글꼴 구문 분석 취약성에 대한 요소 완화 - CVE-2012-0159

완화는 취약성 악용의 심각도를 줄일 수 있는 기본 상태에 존재하는 설정, 일반적인 구성 또는 일반적인 모범 사례를 나타냅니다. 다음과 같은 완화 요인이 상황에 도움이 될 수 있습니다.

  • 이 취약성을 성공적으로 악용한 공격자는 현재 사용자와 동일한 사용자 권한을 얻을 수 있습니다. 자신의 계정이 시스템 관련 사용자 권한이 거의 없도록 구성되어있는 사용자는, 관리자 권한으로 작업하도록 구성되어있는 사용자보다 영향을 덜 받을 것입니다.

TrueType 글꼴 구문 분석 취약성에 대한 해결 방법 - CVE-2012-0159

Microsoft는 이 취약성에 대한 해결 방법을 확인하지 않았습니다.

TrueType 글꼴 구문 분석 취약성에 대한 FAQ - CVE-2012-0159

취약성의 scope 무엇인가요?
원격 코드 실행 취약성입니다.

취약성의 원인은 무엇인가요?
이 취약성은 특별히 작성된 TTF(True Type Font) 파일이 잘못 처리될 때 발생합니다.

공격자가 취약성을 사용하여 수행할 수 있는 작업은 무엇인가요?
이 취약성을 성공적으로 악용한 공격자는 현재 사용자와 동일한 사용자 권한을 얻을 수 있습니다. 현재 사용자가 관리자 권한으로 로그온한 경우 공격자는 영향을 받는 시스템을 완전히 제어할 수 있습니다. 그렇게 되면 공격자는 프로그램을 설치할 수 있고, 데이터를 열람하거나 변경 또는 삭제할 수 있으며, 모든 사용자 권한을 갖고 새 계정을 만들 수 있습니다. 자신의 계정이 시스템 관련 사용자 권한이 거의 없도록 구성되어있는 사용자는, 관리자 권한으로 작업하도록 구성되어있는 사용자보다 영향을 덜 받을 것입니다.

공격자가 취약성을 어떻게 악용할 수 있나요?
공격자는 특별히 제작된 TrueType 글꼴이 포함된 콘텐츠를 공유할 수 있습니다. 사용자가 특별히 제작된 TrueType 글꼴이 포함된 공유 콘텐츠를 볼 때 취약성이 악용될 수 있습니다.

주로 취약성으로 인한 위험에 처한 시스템은 무엇인가요?
워크스테이션은 주로 이 취약성의 위험에 노출됩니다.

업데이트는 무엇을 수행하나요?
이 업데이트는 특별히 제작된 TTF 파일이 처리되는 방법을 수정하여 취약성을 해결합니다.

이 보안 공지가 발행되었을 때 이 취약성이 공개적으로 공개되었습니까?
아니요. Microsoft는 조정된 취약성 공개를 통해 이 취약성에 대한 정보를 수신했습니다.

이 보안 공지가 발행되었을 때 Microsoft는 이 취약성이 악용되고 있다는 보고를 받았습니까?
아니요. Microsoft는 이 보안 공지가 원래 발급되었을 때 이 취약성이 고객을 공격하는 데 공개적으로 사용되었음을 나타내는 정보를 받지 못했습니다.

Lync 안전하지 않은 라이브러리 로드 취약성 - CVE-2012-1849

원격 코드 실행 취약성은 Microsoft Lync가 DLL 파일 로드를 처리하는 방식으로 존재합니다. 이 취약성을 성공적으로 악용한 공격자는 영향을 받는 시스템을 완전히 제어할 수 있습니다. 그렇게 되면 공격자는 프로그램을 설치할 수 있고, 데이터를 열람하거나 변경 또는 삭제할 수 있으며, 모든 사용자 권한을 갖고 새 계정을 만들 수 있습니다. 자신의 계정이 시스템 관련 사용자 권한이 거의 없도록 구성되어있는 사용자는, 관리자 권한으로 작업하도록 구성되어있는 사용자보다 영향을 덜 받을 것입니다.

이 취약성을 일반적인 취약성 및 노출 목록에서 표준 항목으로 보려면 CVE-2012-1849를 참조하세요.

Lync 안전하지 않은 라이브러리 로드 취약성에 대한 완화 요소 - CVE-2012-1849

완화는 취약성 악용의 심각도를 줄일 수 있는 기본 상태에 존재하는 설정, 일반적인 구성 또는 일반적인 모범 사례를 나타냅니다. 다음과 같은 완화 요인이 상황에 도움이 될 수 있습니다.

  • 공격이 성공하려면 사용자가 신뢰할 수 없는 원격 파일 시스템 위치 또는 WebDAV 공유를 방문하여 이 위치에서 합법적인 파일(예: .ocsmeet 파일)을 열어 취약한 애플리케이션에 의해 로드되어야 합니다.
  • 파일 공유 프로토콜인 SMB(서버 메시지 블록)는 종종 경계 방화벽에서 사용하지 않도록 설정됩니다. 이렇게 하면 이 취약성에 대한 잠재적인 공격 벡터가 제한됩니다.
  • 이 취약성을 성공적으로 악용한 공격자는 로그온한 사용자와 동일한 사용자 권한을 얻을 수 있습니다. 자신의 계정이 시스템 관련 사용자 권한이 거의 없도록 구성되어있는 사용자는, 관리자 권한으로 작업하도록 구성되어있는 사용자보다 영향을 덜 받을 것입니다.

Lync 안전하지 않은 라이브러리 로드 취약성에 대한 해결 방법 - CVE-2012-1849

해결 방법은 기본 취약성을 수정하지 않지만 업데이트를 적용하기 전에 알려진 공격 벡터를 차단하는 데 도움이 되는 설정 또는 구성 변경을 나타냅니다. Microsoft는 다음 해결 방법을 테스트하고 해결 방법으로 기능을 줄일 수 있는지 여부를 설명했습니다.

  • WebDAV 및 원격 네트워크 공유에서 라이브러리 로드 사용 안 함

    참고 고객이 원격 네트워크 또는 WebDAV 공유에서 라이브러리 로드를 사용하지 않도록 설정할 수 있는 해결 방법 도구를 배포하려면 Microsoft 기술 자료 문서 2264107 참조하세요. 이 도구는 애플리케이션별 또는 전역 시스템 기준으로 안전하지 않은 로드를 허용하지 않도록 구성할 수 있습니다.

    애플리케이션이 취약하다는 공급업체의 정보를 받은 고객은 이 도구를 사용하여 이 문제를 악용하려는 시도로부터 보호할 수 있습니다.

    참고 자동화된 Microsoft Fix it 솔루션을 사용하여 레지스트리 키를 배포하여 SMB 및 WebDAV 공유에 대한 라이브러리 로드를 차단하려면 Microsoft 기술 자료 문서 2264107 참조하세요. 이 해결 솔루션을 사용하려면 먼저 Microsoft 기술 자료 문서 2264107 설명된 해결 방법 도구를 설치해야 합니다. 이 해결 솔루션은 레지스트리 키만 배포하고 효과적인 해결 방법이 필요합니다. 이 해결 솔루션을 배포하기 전에 관리자가 KB 문서를 면밀히 검토하는 것이 좋습니다.

  • WebClient서비스사용 안 함

    WebClient 서비스를 사용하지 않도록 설정하면 WebDAV(Web Distributed Authoring and Versioning) 클라이언트 서비스를 통해 가장 가능성이 높은 원격 공격 벡터를 차단하여 영향을 받는 시스템이 이 취약성을 악용하려는 시도로부터 보호할 수 있습니다. 이 해결 방법을 적용한 후에도 이 취약성을 성공적으로 악용한 원격 공격자가 시스템이 대상 사용자의 컴퓨터 또는 LAN(로컬 영역 네트워크)에 있는 프로그램을 실행하도록 할 수 있지만, 인터넷에서 임의 프로그램을 열기 전에 사용자에게 확인 메시지가 표시됩니다.

    WebClient 서비스를 사용하지 않도록 설정하려면 다음 단계를 수행합니다.

    1. 시작을 클릭하고 실행을 클릭하고 Services.msc를 입력한 다음 확인을 클릭합니다.
    2. WebClient 서비스를 마우스 오른쪽 단추로 클릭하고 속성을 선택합니다.
    3. 시작 유형을 사용 안 함으로 변경합니다. 서비스가 실행 중인 경우 중지를 클릭합니다.
    4. 확인을 클릭하고 관리 애플리케이션을 종료합니다.

    해결 방법의 영향. WebClient 서비스를 사용하지 않도록 설정하면 WebDAV(Web Distributed Authoring and Versioning) 요청이 전송되지 않습니다. 또한 웹 클라이언트 서비스에 명시적으로 의존하는 서비스는 시작되지 않으며 시스템 로그에 오류 메시지가 기록됩니다. 예를 들어 WebDAV 공유는 클라이언트 컴퓨터에서 액세스할 수 없습니다.

    해결 방법을 실행 취소하는 방법입니다.

    WebClient 서비스를 다시 사용하도록 설정하려면 다음 단계를 수행합니다.

    1. 시작을 클릭하고 실행을 클릭하고 Services.msc를 입력한 다음 확인을 클릭합니다.
    2. WebClient 서비스를 마우스 오른쪽 단추로 클릭하고 속성을 선택합니다.
    3. 시작 유형을 자동으로 변경합니다. 서비스가 실행되고 있지 않으면 시작을 클릭합니다.
    4. 확인을 클릭하고 관리 애플리케이션을 종료합니다.
  • 방화벽에서 TCP 포트 139 및 445 차단

    이러한 포트는 영향을 받는 구성 요소와의 연결을 시작하는 데 사용됩니다. 방화벽에서 TCP 포트 139 및 445를 차단하면 해당 방화벽 뒤에 있는 시스템이 이 취약성을 악용하려는 시도로부터 보호하는 데 도움이 됩니다. 다른 포트를 사용할 수 있는 공격을 방지하기 위해 인터넷에서 원치 않는 모든 인바운드 통신을 차단하는 것이 좋습니다. 포트에 대한 자세한 내용은 TechNet 문서, TCP 및 UDP 포트 할당을 참조하세요.

    해결 방법의 영향. 여러 Windows 서비스에서 영향을 받는 포트를 사용합니다. 포트에 대한 연결을 차단하면 다양한 애플리케이션 또는 서비스가 작동하지 않을 수 있습니다. 영향을 받을 수 있는 애플리케이션 또는 서비스 중 일부는 다음과 같습니다.

    • SMB(CIFS)를 사용하는 애플리케이션
    • mailslot 또는 명명된 파이프를 사용하는 애플리케이션(SMB를 통해 RPC)
    • 서버(파일 및 인쇄 공유)
    • 그룹 정책
    • Net Logon
    • 분산 파일 시스템(DFS)
    • 터미널 서버 라이선스
    • 인쇄 스풀러
    • 컴퓨터 브라우저
    • 원격 프로시저 호출 로케이터
    • 팩스 서비스
    • 인덱싱 서비스
    • 성능 로그 및 경고
    • 시스템 관리 서버
    • 라이선스 로깅 서비스

    해결 방법을 실행 취소하는 방법입니다. 방화벽에서 TCP 포트 139 및 445의 차단을 해제합니다. 포트에 대한 자세한 내용은 TCP 및 UDP 포트 할당을 참조하세요.

Lync 안전하지 않은 라이브러리 로드 취약성에 대한 FAQ - CVE-2012-1849

취약성의 scope 무엇인가요?
원격 코드 실행 취약성입니다.

취약성의 원인은 무엇인가요?
이 취약성은 Microsoft Lync가 외부 라이브러리를 로드하는 데 사용되는 경로를 잘못 제한할 때 발생합니다.

공격자가 취약성을 사용하여 수행할 수 있는 작업은 무엇인가요?
이 취약성을 성공적으로 악용한 공격자는 임의의 코드를 현재 사용자로 실행할 수 있습니다. 현재 사용자가 관리자 권한으로 로그온된 경우 공격자는 영향을 받는 시스템을 완전히 제어할 수 있습니다. 그렇게 되면 공격자는 프로그램을 설치할 수 있고, 데이터를 열람하거나 변경 또는 삭제할 수 있으며, 모든 사용자 권한을 갖고 새 계정을 만들 수 있습니다. 자신의 계정이 시스템 관련 사용자 권한이 거의 없도록 구성되어있는 사용자는, 관리자 권한으로 작업하도록 구성되어있는 사용자보다 영향을 덜 받을 것입니다.

공격자가 취약성을 어떻게 악용할 수 있나요?
공격자는 사용자가 특별히 제작된 DLL(동적 링크 라이브러리) 파일과 동일한 네트워크 디렉터리에 있는 합법적인 Microsoft Lync 관련 파일(예: .ocsmeet 파일)을 열도록 설득할 수 있습니다. 그런 다음, 합법적인 파일을 여는 동안 Microsoft Lync는 DLL 파일을 로드하고 포함된 모든 코드를 실행하려고 시도할 수 있습니다.

이메일 공격 시나리오에서 공격자는 합법적인 Microsoft Lync 관련 파일(예: .ocsmeet 파일)을 사용자에게 보내고, 사용자가 첨부 파일을 특별히 제작된 DLL 파일이 포함된 디렉터리에 배치하고 합법적인 파일을 열도록 설득하여 취약성을 악용할 수 있습니다. 그런 다음, 합법적인 파일을 여는 동안 Microsoft Lync는 DLL 파일을 로드하고 포함된 모든 코드를 실행하려고 시도할 수 있습니다.

네트워크 공격 시나리오에서 공격자는 합법적인 Microsoft Lync 관련 파일과 특별히 제작된 DLL을 네트워크 공유, UNC 또는 WebDAV 위치에 배치한 다음 사용자에게 파일을 열도록 설득할 수 있습니다.

주로 취약성으로 인한 위험에 처한 시스템은 무엇인가요?
워크스테이션 및 터미널 서버를 포함하여 Microsoft Lync가 사용되는 시스템은 주로 위험에 처해 있습니다. 관리자가 사용자가 서버에 로그온하고 프로그램을 실행할 수 있도록 허용하면 서버가 더 위험할 수 있습니다. 그러나 모범 사례에서는 이를 허용하지 않습니다.

업데이트는 무엇을 수행하나요?
업데이트는 Microsoft Lync가 외부 라이브러리를 로드하는 방법을 수정하여 이 취약성을 해결합니다.

이 취약성은 Microsoft 보안 공지 2269637 관련되어 있나요? 예, 이 취약성은 애플리케이션이 외부 라이브러리를 로드하는 방식에 영향을 주는 Microsoft 보안 공지 2269637 설명된 취약성 클래스와 관련이 있습니다.

이 보안 공지가 발행되었을 때 이 취약성이 공개적으로 공개되었습니까?
아니요. Microsoft는 조정된 취약성 공개를 통해 이 취약성에 대한 정보를 수신했습니다.

이 보안 공지가 발행되었을 때 Microsoft는 이 취약성이 악용되고 있다는 보고를 받았습니까?
아니요. Microsoft는 이 보안 공지가 원래 발급되었을 때 이 취약성이 고객을 공격하는 데 공개적으로 사용되었음을 나타내는 정보를 받지 못했습니다.

HTML 삭제 취약성 - CVE-2012-1858

정보 공개 취약성은 공격자가 사이트 간 스크립팅 공격을 수행하고 현재 사용자의 보안 컨텍스트에서 스크립트를 실행할 수 있도록 HTML을 필터링하는 방식으로 존재합니다.

이 취약성을 일반적인 취약성 및 노출 목록에서 표준 항목으로 보려면 CVE-2012-1858을 참조하세요.

HTML 삭제 취약성 완화 요소 - CVE-2012-1858

Microsoft는 이 취약성에 대한 완화 요인을 확인하지 않았습니다.

HTML 삭제 취약성에 대한 해결 방법 - CVE-2012-1858

Microsoft는 이 취약성에 대한 해결 방법을 확인하지 않았습니다.

HTML 삭제 취약성에 대한 FAQ - CVE-2012-1858

취약성의 scope 무엇인가요?
정보 공개 취약성입니다. 취약성을 성공적으로 악용한 공격자는 Lync 또는 Microsoft Communicator 사용자에 대해 사이트 간 스크립팅 공격을 수행할 수 있습니다. 그러면 공격자가 잠재적으로 피해자 사용자를 대신하여 스크립트를 실행할 수 있습니다.

취약성의 원인은 무엇인가요?
이 취약성은 SafeHTML이 HTML을 삭제하는 방식으로 인해 발생합니다.

이 취약성은 MS12-037의 CVE-2012-1858,인터넷 Explorer 대한 누적 보안 업데이트와 관련이 있나요?
예, HTML 삭제 취약성 CVE-2012-1858도 인터넷 Explorer 영향을 줍니다.

공격자가 취약성을 사용하여 수행할 수 있는 작업은 무엇인가요?
취약성을 성공적으로 악용한 공격자는 Lync 또는 Microsoft Communicator 사용자에 대해 사이트 간 스크립팅 공격을 수행할 수 있습니다. 그러면 공격자가 잠재적으로 피해자 사용자를 대신하여 스크립트를 실행할 수 있습니다.

공격자가 취약성을 어떻게 악용할 수 있나요?
이 취약성을 악용하려면 공격자가 특별히 제작된 스크립트를 Lync 또는 Microsoft Communicator 채팅 창에 제출할 수 있어야 합니다. 취약성으로 인해 특수하게 제작된 스크립트가 제대로 삭제되지 않아 악의적인 콘텐츠를 보는 사용자의 보안 컨텍스트에서 공격자가 제공한 스크립트가 실행될 수 있습니다.

사이트 간 스크립팅 공격의 경우 이 취약성을 사용하려면 악의적인 작업이 발생할 수 있도록 사용자가 특별히 제작된 채팅 메시지를 수신해야 합니다.

주로 취약성으로 인한 위험에 처한 시스템은 무엇인가요?
워크스테이션 또는 터미널 서버와 같이 Lync 또는 Microsoft Communicator가 자주 사용되는 시스템은 이 취약성으로 인한 위험이 가장 큽니다.

업데이트는 무엇을 수행하나요?
이 업데이트는 SafeHTML이 HTML 콘텐츠를 삭제하는 방법을 수정하여 취약성을 해결합니다.

이 보안 공지가 발행되었을 때 이 취약성이 공개적으로 공개되었습니까?
아니요. Microsoft는 조정된 취약성 공개를 통해 이 취약성에 대한 정보를 수신했습니다.

이 보안 공지가 발행되었을 때 Microsoft는 이 취약성이 악용되고 있다는 보고를 받았습니까?
아니요. Microsoft는 이 보안 공지가 원래 발급되었을 때 이 취약성이 고객을 공격하는 데 공개적으로 사용되었음을 나타내는 정보를 받지 못했습니다.

업데이트 정보

검색 및 배포 도구 및 지침

Security Central

organization 서버, 데스크톱 및 모바일 시스템에 배포해야 하는 소프트웨어 및 보안 업데이트를 관리합니다. 자세한 내용은 TechNet 업데이트 관리 센터를 참조하세요. Microsoft TechNet Security 웹 사이트에서는 Microsoft 제품의 보안에 대한 추가 정보를 제공합니다.

보안 업데이트는 Microsoft 업데이트Windows 업데이트 사용할 수 있습니다. 보안 업데이트는 Microsoft 다운로드 센터에서도 사용할 수 있습니다. "보안 업데이트"에 대한 키워드(keyword) 검색을 수행하여 가장 쉽게 찾을 수 있습니다.

Mac용 Microsoft Office 고객의 경우 Mac용 Microsoft 자동 업데이트는 Microsoft 소프트웨어를 최신 상태로 유지하는 데 도움이 될 수 있습니다. Mac용 Microsoft 자동 업데이트 사용에 대한 자세한 내용은 자동으로 소프트웨어 업데이트 확인을 참조하세요.

마지막으로 Microsoft 업데이트 카탈로그에서 보안 업데이트를 다운로드할 수 있습니다. Microsoft 업데이트 카탈로그는 보안 업데이트, 드라이버 및 서비스 팩을 포함하여 Windows 업데이트 및 Microsoft 업데이트를 통해 사용할 수 있는 검색 가능한 콘텐츠 카탈로그를 제공합니다. 보안 공지 번호(예: "MS07-036")를 사용하여 검색하면 바구니에 적용 가능한 모든 업데이트(업데이트에 대한 다른 언어 포함)를 추가하고 선택한 폴더에 다운로드할 수 있습니다. Microsoft 업데이트 카탈로그에 대한 자세한 내용은 Microsoft 업데이트 카탈로그 FAQ를 참조하세요.

검색 및 배포 지침

Microsoft는 보안 업데이트에 대한 검색 및 배포 지침을 제공합니다. 이 지침에는 IT 전문가가 보안 업데이트 검색 및 배포를 위해 다양한 도구를 사용하는 방법을 이해하는 데 도움이 되는 권장 사항 및 정보가 포함되어 있습니다. 자세한 내용은 Microsoft 기술 자료 문서 961747.

Microsoft Baseline Security Analyzer

Microsoft 기준 보안 분석기(MBSA)를 사용하면 관리자가 로컬 및 원격 시스템에서 누락된 보안 업데이트와 일반적인 보안 구성을 검사할 수 있습니다. MBSA에 대한 자세한 내용은 Microsoft 기준 보안 분석기를 참조하세요.

다음 표에서는 이 보안 업데이트에 대한 MBSA 검색 요약을 제공합니다.

소프트웨어 Mbsa
Microsoft Communicator 2007 R2 Yes
Microsoft Lync 2010(32비트) Yes
Microsoft Lync 2010(64비트) Yes
Microsoft Lync 2010 Attendee(관리자 수준 설치) Yes
Microsoft Lync 2010 Attendee(사용자 수준 설치) No
Microsoft Lync 2010 전화 교환(32비트) Yes
Microsoft Lync 2010 전화 교환(64비트) Yes

참고 MBSA, Microsoft 업데이트 및 Windows Server Update Services 최신 릴리스에서 지원되지 않는 레거시 소프트웨어를 사용하는 고객의 경우 Microsoft 기준 보안 분석기를 방문하여 레거시 도구를 사용하여 포괄적인 보안 업데이트 검색을 만드는 방법에 대한 레거시 제품 지원 섹션을 참조하세요.

Windows Server Update Services

WSUS(Windows Server Update Services)를 사용하면 정보 기술 관리자가 Windows 운영 체제를 실행하는 컴퓨터에 최신 Microsoft 제품 업데이트를 배포할 수 있습니다. Windows Server Update Services 사용하여 보안 업데이트를 배포하는 방법에 대한 자세한 내용은 TechNet 문서 Windows Server Update Services 참조하세요.

시스템 관리 서버

다음 표에서는 이 보안 업데이트에 대한 SMS 검색 및 배포 요약을 제공합니다.

소프트웨어 ITMU를 사용하여 SMS 2003 System Center Configuration Manager
Microsoft Communicator 2007 R2 Yes Yes
Microsoft Lync 2010(32비트) Yes Yes
Microsoft Lync 2010(64비트) Yes Yes
Microsoft Lync 2010 Attendee(관리자 수준 설치) Yes Yes
Microsoft Lync 2010 Attendee(사용자 수준 설치)
Microsoft Lync 2010 전화 교환(32비트) Yes Yes
Microsoft Lync 2010 전화 교환(64비트) Yes Yes

참고 Microsoft는 2011년 4월 12일에 SMS 2.0에 대한 지원을 중단했습니다. SMS 2003의 경우 Microsoft는 2011년 4월 12일에 SUIT(보안 업데이트 인벤토리 도구)에 대한 지원도 중단했습니다. 고객은 System Center Configuration Manager 업그레이드하는 것이 좋습니다. SMS 2003 서비스 팩 3에 남아 있는 고객의 경우 ITMU(Microsoft 업데이트 인벤토리 도구)도 옵션입니다.

SMS 2003의 경우 SMS에서 ITMU(Microsoft 업데이트용 SMS 2003 인벤토리 도구)를 사용하여 Microsoft 업데이트에서 제공하고 Windows Server Update Services 지원하는 보안 업데이트를 검색할 수 있습니다. SMS 2003 ITMU에 대한 자세한 내용은 Microsoft 업데이트 SMS 2003 인벤토리 도구를 참조하세요. SMS 검사 도구에 대한 자세한 내용은 SMS 2003 소프트웨어 업데이트 검사 도구를 참조하세요. 시스템 관리 서버 2003에 대한 다운로드도 참조하세요.

System Center Configuration Manager 업데이트 검색에 WSUS 3.0을 사용합니다. System Center Configuration Manager 소프트웨어 업데이트 관리에 대한 자세한 내용은 System Center를 참조하세요.

SMS에 대한 자세한 내용은 SMS 웹 사이트를 방문하세요.

자세한 내용은 Microsoft 기술 자료 문서 910723: 월별 검색 및 배포 지침 문서의 요약 목록을 참조하세요.

호환성 평가기 및 애플리케이션 호환성 도구 키트 업데이트

업데이트 애플리케이션을 실행하는 데 필요한 동일한 파일 및 레지스트리 설정에 쓰는 경우가 많습니다. 이로 인해 비호환성이 트리거되고 보안 업데이트를 배포하는 데 걸리는 시간이 늘어나게 됩니다. 애플리케이션 호환성 도구 키트에 포함된 업데이트 호환성 평가기 구성 요소를 사용하여 설치된 애플리케이션에 대한 Windows 업데이트 테스트를 간소화하고 유효성을 검사할 수 있습니다.

ACT(애플리케이션 호환성 도구 키트)에는 사용자 환경에서 Windows Vista, Windows 업데이트, Microsoft 보안 업데이트 또는 새 버전의 Windows 인터넷 Explorer 배포하기 전에 애플리케이션 호환성 문제를 평가하고 완화하는 데 필요한 도구와 설명서가 포함되어 있습니다.

보안 업데이트 배포

영향을 받는 소프트웨어

영향을 받는 소프트웨어의 특정 보안 업데이트에 대한 자세한 내용은 적절한 링크를 클릭합니다.

Microsoft Communicator 2007 R2, Microsoft Lync 2010, Microsoft Lync 2010 Attendee, Microsoft Lync 2010 Attendant

참조 테이블

다음 표에는 이 소프트웨어에 대한 보안 업데이트 정보가 포함되어 있습니다. 이 섹션의 하위 섹션인 배포 정보에서 추가 정보를 찾을 수 있습니다.

향후 서비스 팩에 포함 이 문제에 대한 업데이트는 향후 서비스 팩 또는 업데이트 롤업에 포함됩니다.
배포
사용자 개입 없이 설치 Microsoft Lync 2007 R2의 경우(KB2708980):\ communicator.msp /passive
Microsoft Lync 2010(32비트)(KB2693282)의 경우:\ lync.msp /passive
Microsoft Lync 2010(64비트)(KB2693282)의 경우:\ lync.msp /passive
Microsoft Lync 2010 Attendee(관리자 수준 설치)(KB2696031):\ attendeeadmin.msp /passive
Microsoft Lync 2010 Attendee(사용자 수준 설치)(KB2693283)의 경우:\ attendeeuser.msp /passive
Microsoft Lync 2010 전화 교환(32비트)(KB2702444)의 경우:\ attendantconsole.msp /passive
Microsoft Lync 2010 전화 교환(64비트)(KB2702444)의 경우:\ attendantconsole.msp /passive
다시 시작하지 않고 설치 Microsoft Lync 2007 R2의 경우(KB2708980):\ communicator.msp /norestart
Microsoft Lync 2010(32비트)(KB2693282)의 경우:\ lync.msp /norestart
Microsoft Lync 2010(64비트)(KB2693282)의 경우:\ lync.msp /norestart
Microsoft Lync 2010 Attendee(관리자 수준 설치)(KB2696031):\ attendeeadmin.msp /norestart
Microsoft Lync 2010 Attendee(사용자 수준 설치)(KB2693283)의 경우:\ attendeeuser.msp /norestart
Microsoft Lync 2010 전화 교환(32비트)(KB2702444)의 경우:\ attendantconsole.msp /norestart
Microsoft Lync 2010 전화 교환(64비트)(KB2702444)의 경우:\ attendantconsole.msp /norestart
로그 파일 업데이트 해당 사항 없음
추가 정보 검색 및 배포에 대한 자세한 내용은 이전 섹션인 검색 및 배포 도구 및 지침을 참조하세요.
다시 시작 요구 사항
다시 시작해야 합니까? 경우에 따라 이 업데이트를 다시 시작할 필요가 없습니다. 필요한 파일을 사용하는 경우 이 업데이트를 다시 시작해야 합니다. 이 동작이 발생하면 다시 시작하라는 메시지가 나타납니다.\ \ 다시 시작해야 할 가능성을 줄이려면 영향을 받는 모든 서비스를 중지하고 보안 업데이트를 설치하기 전에 영향을 받는 파일을 사용할 수 있는 모든 애플리케이션을 닫습니다. 다시 시작하라는 메시지가 표시되는 이유에 대한 자세한 내용은 Microsoft 기술 자료 문서 887012 참조하세요.
핫패칭을 해당 사항 없음
제거 정보 제어판 프로그램 추가 또는 제거 항목을 사용합니다.
파일 정보 For Microsoft Lync 2007 R2:\ Microsoft 기술 자료 문서 2708980 참조하세요.
Microsoft Lync 2010:\ Microsoft 기술 자료 문서 2693282 참조하세요.
Microsoft Lync 2010 Attendee(관리자 수준 설치):\ microsoft 기술 자료 문서 2696031\ \ Microsoft Lync 2010 Attendee(사용자 수준 설치)를 참조하세요. Microsoft 기술 자료 문서 2693283 참조하세요.
Microsoft Lync 2010 전화 교환(32비트 및 64비트)의 경우:\ Microsoft 기술 자료 문서 2702444 참조하세요.
레지스트리 키 확인 해당 사항 없음

배포 정보

업데이트 설치

영향을 받는 소프트웨어 및 영향을 받지 않는 소프트웨어 섹션의 적절한 다운로드 링크에서 업데이트를 설치할 수 있습니다. 서버 위치에서 애플리케이션을 설치한 경우 서버 관리자는 대신 관리 업데이트로 서버 위치를 업데이트하고 해당 업데이트를 시스템에 배포해야 합니다. 관리 설치 지점에 대한 자세한 내용은 검색 및 배포 도구 및 지침 하위 섹션의 Office 관리 설치 지점 정보를 참조하세요.

이 보안 업데이트를 사용하려면 Windows Installer 3.1 이상 버전을 시스템에 설치해야 합니다.

3.1 이상 버전의 Windows Installer를 설치하려면 다음 Microsoft 웹 사이트 중 하나를 방문하세요.

핫픽스와 같이 이 게시판에 표시되는 용어에 대한 자세한 내용은 Microsoft 기술 자료 문서 824684 참조하세요.

이 보안 업데이트는 다음 설정 스위치를 지원합니다.

스위치 Description
/help 명령줄 옵션을 표시합니다.
/quiet 또는 **/q[n b r f]** 자동 모드, 사용자 상호 작용 없음 또는 \/q[n b r f] 사용자 인터페이스 수준 설정:\ n - 사용자 인터페이스 없음\ b - 기본 사용자 인터페이스\ r - 사용자 인터페이스 감소\ f - 전체 사용자 인터페이스(기본값)
/passive 무인 모드 - 진행률 표시줄에만 해당합니다.
/norestart 설치가 완료된 후에는 다시 시작하지 마세요.
**/l[i w e a r u c o p v x + ! *] <LogFile>** 로깅을 사용하도록 설정합니다. 옵션:\ i - Status messages\ w - Nonfatal warnings\ e - All error messages\ a - start up of actions\ r - Action-specific records\ u - User requests\ c - Initial UI parameters\ m - out-of-memory or fatal exit information\ o - out-of-disk-space messages\ p - Terminal properties\ v - Verbose output\ x - Extra debugging information\ + - 추가 디버깅 정보\ - 기존 로그 파일에 추가\ ! - 각 줄을 로그에 플러시\ * - v 및 x 옵션을 제외한 모든 정보 기록
/log<LogFile> /l* <LogFile>에 해당합니다.

참고 이러한 스위치를 하나의 명령으로 결합할 수 있습니다. 이전 버전과의 호환성을 위해 보안 업데이트는 이전 버전의 설치 프로그램에서 사용하는 많은 설정 스위치도 지원합니다. 지원되는 설치 스위치에 대한 자세한 내용은 Microsoft 기술 자료 문서 262841 참조하세요.

업데이트 제거

이 보안 업데이트를 제거하려면 제어판 프로그램 추가 또는 제거 항목을 사용합니다.

참고 이 업데이트를 제거하면 CD 드라이브에 2007 Microsoft Office CD를 삽입하라는 메시지가 표시될 수 있습니다. 또한 제어판 프로그램 추가 또는 제거 항목에서 업데이트를 제거하는 옵션이 없을 수도 있습니다. 이 문제에는 몇 가지 가능한 원인이 있습니다. 제거에 대한 자세한 내용은 Microsoft 기술 자료 문서 903771 참조하세요.

업데이트가 적용되었는지 확인

  • Microsoft Baseline Security Analyzer
    영향을 받는 시스템에 보안 업데이트가 적용되었는지 확인하려면 Microsoft 기준 보안 분석기(MBSA) 도구를 사용할 수 있습니다. 자세한 내용은 이 공지 앞부분에 있는 검색 및 배포 도구 및 지침 섹션을 참조하세요.

  • 파일 버전 확인
    Microsoft Windows에는 여러 버전이 있으므로 시스템에서 다음 단계가 다를 수 있습니다. 이 경우 제품 설명서를 참조하여 이러한 단계를 완료합니다.

    1. 시작을 클릭한 다음 검색 시작 상자에 업데이트 파일 이름을 입력합니다.
    2. 프로그램 아래에 파일이 나타나면 파일 이름을 마우스 오른쪽 단추로 클릭하고 속성을 클릭합니다.
    3. 일반 탭에서 파일 크기를 공지 KB 문서에 제공된 파일 정보 테이블과 비교합니다.
      참고 운영 체제 버전 또는 시스템에 설치된 프로그램에 따라 파일 정보 테이블에 나열된 일부 파일이 설치되지 않을 수 있습니다.
    4. 세부 정보 탭을 클릭하고 파일 버전 및 수정된 날짜와 같은 정보를 공지 KB 문서에 제공된 파일 정보 테이블과 비교할 수도 있습니다.
      참고 설치하는 동안 파일 버전 이외의 특성이 변경 될 수 있습니다. 다른 파일 특성을 파일 정보 테이블의 정보와 비교하는 것은 업데이트가 적용되었는지 확인하는 지원되는 방법이 아닙니다. 또한 경우에 따라 설치하는 동안 파일의 이름을 바꿀 수 있습니다. 파일 또는 버전 정보가 없는 경우 사용 가능한 다른 방법 중 하나를 사용하여 업데이트 설치를 확인합니다.
    5. 마지막으로 이전 버전 탭을 클릭하고 파일의 새 버전 또는 업데이트된 버전에 대한 파일 정보와 이전 버전의 파일 정보를 비교할 수도 있습니다.

기타 정보

감사의 글

Microsoft는 고객을 보호하기 위해 Microsoft와 협력해 주셔서 감사합니다 .

  • Lync 안전하지 않은 라이브러리 로드 취약성을 보고하기 위한 Secunia SVCRP를 통한 햄버거 maccoy(CVE-2012-1849)
  • IBM 보안 시스템의 Adi Cohen - HTML 삭제 취약성을 보고하기 위한 애플리케이션 보안(CVE-2012-1858)
  • TrueType 글꼴 구문 분석 취약성 보고(CVE-2012-0159) 팁 포인트의제로 데이 이니셔티브와 함께 작업하는 Alin Rad Pop

MAPP(Microsoft 활성 보호 프로그램)

고객을 위한 보안 보호를 개선하기 위해 Microsoft는 매월 보안 업데이트 릴리스마다 주요 보안 소프트웨어 공급자에게 취약성 정보를 제공합니다. 그런 다음 보안 소프트웨어 공급자는 이 취약성 정보를 사용하여 바이러스 백신, 네트워크 기반 침입 탐지 시스템 또는 호스트 기반 침입 방지 시스템과 같은 보안 소프트웨어 또는 디바이스를 통해 고객에게 업데이트된 보호를 제공할 수 있습니다. 보안 소프트웨어 공급자로부터 활성 보호를 사용할 수 있는지 여부를 확인하려면 MAPP(Microsoft Active Protections Program) 파트너에 나열된 프로그램 파트너가 제공하는 활성 보호 웹 사이트를 방문하세요.

지원

이 보안 업데이트에 대한 도움말 및 지원을 받는 방법

고지 사항

Microsoft 기술 자료에 제공된 정보는 어떠한 종류의 보증도 없이 "있는 그대로" 제공됩니다. Microsoft는 특정 목적에 대한 상품성 및 적합성에 대한 보증을 포함하여 명시적이거나 묵시적인 모든 보증을 부인합니다. 어떠한 경우에도 Microsoft Corporation 또는 해당 공급업체는 Microsoft Corporation 또는 해당 공급업체가 그러한 손해의 가능성에 대해 통보를 받은 경우에도 직접, 간접, 부수적, 결과적, 비즈니스 이익 손실 또는 특별 손해를 포함한 모든 손해에 대해 책임을 지지 않습니다. 일부 주에서는 결과적 또는 부수적 손해에 대한 책임의 배제 또는 제한을 허용하지 않으므로 앞에서 설명한 제한이 적용되지 않을 수 있습니다.

수정 내용

  • V1.0(2012년 6월 12일): 공지가 게시되었습니다.

빌드 날짜: 2014-04-18T13:49:36Z-07:00