Microsoft 보안 공지 MS13-012 - 긴급

Microsoft Exchange Server의 취약점으로 인한 원격 코드 실행 문제점 (2809279)

게시된 날짜: 2013년 2월 13일 수요일 | 업데이트된 날짜: 2013년 2월 14일 목요일

버전: 1.1

일반 정보

요약

이 보안 업데이트는 Microsoft Exchange Server에서 발견되어 공개적으로 보고된 취약점을 해결합니다. 가장 심각한 취약점은 Microsoft Exchange Server WebReady 문서 보기에 있으며, 사용자가 OWA(Outlook Web App)를 사용하여 특수하게 조작된 파일을 미리보는 경우 Exchange 서버에 있는 코드 변환 서비스의 보안 컨텍스트에서 원격 코드를 실행하도록 허용할 수 있습니다. WebReady 문서 보기에 사용되는 Exchange에 있는 코드 변환 서비스는 LocalService 계정에서 실행되고 있습니다. LocalService 계정에는 로컬 컴퓨터의 최소 권한이 있으며 네트워크에서 익명 자격 증명을 제시합니다.

이 보안 업데이트의 심각도는 지원되는 모든 Microsoft Exchange Server 2007 및 Microsoft Exchange Server 2010 에디션에 대해 긴급입니다. 자세한 내용은 이 섹션에서 영향을 받는 소프트웨어 및 영향을 받지 않는 소프트웨어를 참조하십시오.

이 보안 업데이트는 영향을 받는 Oracle Outside In 라이브러리를 비보안 버전으로 업데이트하여 취약점을 해결합니다. 취약점에 대한 자세한 내용은 다음 섹션, 취약점 정보에서 각 취약점 항목의 자주 제기되는 질문 사항(FAQ) 섹션을 참조하십시오.

권장 사항. 고객은 Microsoft Update 서비스를 사용하여 Microsoft Update에서 업데이트를 온라인으로 확인하도록 자동 업데이트를 구성할 수 있습니다. 자동 업데이트 기능을 사용하고 있으며 Microsoft Update에서 업데이트를 온라인으로 확인하도록 구성한 고객은 일반적으로 따로 조치를 취할 필요가 없습니다. 이 보안 업데이트가 자동으로 다운로드되고 설치됩니다. 자동 업데이트를 사용하고 있지 않은 고객은 Microsoft Update에서 수동으로 업데이트를 확인하고 이 업데이트를 설치해야 합니다. 지원 대상인 Windows XP 및 Windows Server 2003 에디션에서 자동 업데이트의 특정 구성 옵션에 대한 자세한 내용은 Microsoft 기술 자료 문서 294871을 참조하십시오. 지원 대상인 Windows Vista, Windows Server 2008, Windows 7 및 Windows Server 2008 R2 에디션에서 자동 업데이트에 대한 자세한 내용은 Windows 자동 업데이트 이해를 참조하십시오.

관리자 및 기업 설치의 경우나 이 보안 업데이트를 수동으로 설치하려는 최종 사용자의 경우에는 고객이 업데이트 관리 소프트웨어를 사용하거나 Microsoft Update 서비스를 통해 업데이트를 확인하여 업데이트를 즉시 적용하는 것이 좋습니다.

이 공지 뒷부분에 있는 검색, 탐지 도구 및 지침 섹션도 참조하십시오.

알려진 문제점. 없음

영향을 받는 소프트웨어 및 영향을 받지 않는 소프트웨어

다음 소프트웨어는 테스트를 거쳐 영향을 받는 버전 또는 에디션이 확인되었습니다. 다른 버전은 지원 기간이 끝났거나 영향을 받지 않습니다. 사용 중인 소프트웨어 버전에 대한 지원 기간을 확인하려면 Microsoft 지원 기간 정책 웹 사이트를 참조하십시오.

영향을 받는 소프트웨어

소프트웨어 최대 보안 영향 전체 심각도 대체된 업데이트
Microsoft Server 소프트웨어
[Microsoft Exchange Server 2007 서비스 팩 3](https://www.microsoft.com/download/details.aspx?familyid=316a1aff-b72d-4d96-8ee5-bd86b0e29e6f&displaylang=ko)  (KB2788321) 원격 코드 실행 긴급 [MS12-080](https://go.microsoft.com/fwlink/?linkid=272389)의 KB2746157
[Microsoft Exchange Server 2010 서비스 팩 2](https://www.microsoft.com/download/details.aspx?familyid=498e7612-73b5-4e28-99a4-b3157ac69932&displaylang=ko)  (KB2746164) 원격 코드 실행 긴급 [MS12-080](https://go.microsoft.com/fwlink/?linkid=272389)의 KB2785908
영향을 받지 않는 소프트웨어
Microsoft Server 소프트웨어
Microsoft Exchange Server 2003 서비스 팩 2 
Microsoft Exchange Server 2010 서비스 팩 3 
Microsoft Exchange Server 2013 RTM

이 보안 업데이트와 관련된 자주 제기되는 질문 사항

Oracle Critical Patch Update Advisory - January 2013에 설명된 취약점이 다양합니다 . 이 업데이트로 취약점의 문제가 어떻게 해결됩니까?
Oracle Critical Patch Update Advisory - January 2013(영문)에 설명된 CVE-2013-0393 및 CVE-2013-0418은 Microsoft Exchange Server에 영향을 미치며, 이 업데이트에 의해 해결됩니다.

이 업데이트에 기능에 대한 다른 비보안 관련 변경 사항이 포함되어 있습니까?
예. 이 공지의 취약점 정보 섹션에 나열된 변경 사항에 더불어 이 업데이트는 각 업데이트 롤업에 대한 관련 KB 문서에서 설명된 다른 기능 변경 사항을 포함합니다.

타사 코드인 Oracle Outside In 라이브러리의 취약점인데, Microsoft가 보안 업데이트를 배포하는 이유는 무엇입니까?
Microsoft는 타사 코드를 사용한 제품에 한하여 Oracle Outside In 라이브러리의 수정 구현 허가를 받았습니다. Microsoft는 이 보안 업데이트를 배포하여 Microsoft Exchange에서 이 타사 코드를 사용하는 모든 고객들이 이 취약점으로부터 보호받을 수 있도록 합니다.

파일 정보 세부 사항은 어디에 있습니까?
파일 정보 세부 사항의 위치에 대해서는 보안 업데이트 배포 섹션에서 참조 표를 참조하십시오.

보안 업데이트의 해시는 어디에 있습니까?
이 보안 업데이트의 SHA1 및 SHA2 해시는 다운로드한 보안 업데이트 패키지의 진위 여부를 검증하는 데 사용할 수 있습니다. 이 업데이트와 관련된 해시 정보는 Microsoft 기술 자료 문서 2809279를 참조하십시오.

이 보안 공지에서 설명하는 소프트웨어의 이전 버전을 사용하고 있습니다. 어떻게 해야 합니까?
이 공지에 나열된 영향을 받는 소프트웨어는 테스트를 거쳐 해당 버전이 영향을 받는지 확인되었습니다. 다른 버전은 지원 기간이 끝났습니다. 제품 지원 기간에 대한 자세한 내용은 Microsoft 지원 기간 정책 웹 사이트를 참조하십시오.

이전 버전의 소프트웨어를 사용 중인 고객은 이후의 취약점에 노출되지 않도록 지원되는 버전으로 마이그레이션을 우선적으로 고려하십시오. 사용 중인 소프트웨어 버전에 대한 지원 기간을 확인하려면 지원 기간 제품 선택을 참조하십시오. 이러한 소프트웨어 버전의 서비스 팩에 대한 자세한 내용은 서비스 팩 지원 기간 정책을 참조하십시오.

이전 버전의 소프트웨어에 대한 사용자 지정 지원이 필요한 고객은 자신의 Microsoft 계정 관리 팀 담당자나 TAM(기술 계정 관리자) 또는 해당 Microsoft 파트너 담당자에게 사용자 지정 지원 옵션에 대해 문의하십시오. Alliance, Premier 또는 Authorized Contract가 없는 고객은 해당 지역의 Microsoft 판매처에 문의하십시오. 연락처 정보는 Microsoft 정보(영문) 웹 사이트를 방문하여 Contact Information 목록에서 국가를 선택한 다음 Go를 클릭하면 나타나는 전화 번호 목록을 참조하십시오. 전화를 할 경우에는 해당 지역의 프리미어 지원 영업 담당자와 상담을 요청하십시오. 자세한 내용은 Microsoft 지원 기간 정책 FAQ를 참조하십시오.

취약점 정보

심각도 및 취약점

다음의 심각도는 취약점의 잠재적인 최대 영향을 가정합니다. 이 보안 공지 발표 후 30일 이내의 심각도 및 보안 영향과 관련된 취약점 악용 가능성에 대해서는 2월 공지 요약의 악용 가능성 인덱스를 참조하십시오. 자세한 내용은 Microsoft 악용 가능성 인덱스를 참조하십시오.

영향을 받는 소프트웨어별 취약점 심각도 및 최대 심각도 영향
영향을 받는 소프트웨어 Oracle Outside In에 포함되어 있는 악용 가능한 여러 취약점:
CVE-2013-0393
Oracle Outside In에 포함되어 있는 악용 가능한 여러 취약점:
CVE-2013-0418
전체 심각도
Microsoft Exchange Server 2007 서비스 팩 3  중요 
서비스 거부
긴급 
원격 코드 실행
긴급
Microsoft Exchange Server 2010 서비스 팩 2  중요 
서비스 거부
긴급 
원격 코드 실행
긴급
Oracle Outside In에 포함되어 있는 악용 가능한 여러 취약점 ---------------------------------------------------------

두 가지 취약점이 WebReady 문서 보기 기능을 통해 Microsoft Exchange Server에 존재합니다. 사용자가 브라우저에서 Outlook Web Access를 통해 특수하게 조작된 파일을 보는 경우 보다 심각한 취약점(CVE-2013-0418)은 원격 코드 실행을 LocalService 계정으로 허용할 수 있습니다. 이 취약점을 성공적으로 악용하는 공격자는 영향을 받는 Exchange Server에서 코드를 LocalService 계정으로만 실행할 수 있습니다. LocalService 계정에는 로컬 컴퓨터의 최소 권한이 있으며 네트워크에서 익명 자격 증명을 제시합니다. 사용자가 브라우저에서 Outlook Web Access를 통해 특수하게 조작된 파일을 보는 경우 또 다른 취약점(CVE-2013-0393)으로 인해 영향을 받는 시스템이 응답하지 않을 수 있습니다. 공격자가 이 취약점(CVE-2013-0393)을 악용하더라도 코드를 실행하거나 사용자 권한을 승격시킬 수는 없습니다.

이 취약점을 CVE(Common Vulnerabilities and Exposures) 목록의 표준 항목으로 보려면 CVE-2013-0418(영문) 및 CVE-2013-0393(영문)을 참조하십시오.

Oracle Outside In에 포함되어 있는 악용 가능한 여러 취약점에 대한 완화 요소

완화란 취약점의 악용 심각도를 낮출 수 있는 설정, 일반적인 구성 또는 최선책, 기본 상태를 지칭합니다. 다음과 같은 완화 요소가 현재 상황에서 유용할 수 있습니다.

  • WebReady 문서 보기에 사용되는 Exchange에 있는 코드 변환 서비스는 LocalService 계정에서 실행되고 있습니다. LocalService 계정에는 로컬 컴퓨터의 최소 권한이 있으며 네트워크에서 익명 자격 증명을 제시합니다. 다음은 CVE-2013-0418 취약점에 대한 완화 요소입니다.

Oracle Outside In에 포함되어 있는 악용 가능한 여러 취약점에 대한 대안

대안이란 기본적인 취약점을 수정하지는 않지만 업데이트를 적용하기 전에 알려진 공격 경로를 차단하는 데 유용한 설정 또는 구성 변경을 지칭합니다. Microsoft는 다음과 같은 대안을 테스트했으며, 대안으로 인한 기능 저하 여부를 해당 항목에서 설명합니다.

  • WebReady 문서 보기 비활성화

    1. Exchange 관리 셸에 Exchange 조직 관리자로 로그인합니다.
    2. 다음 PowerShell 명령을 실행합니다.
      Get-OwaVirtualDirectory | where {$_.OwaVersion -eq 'Exchange2007' -or $_.OwaVersion -eq 'Exchange2010'} | Set-OwaVirtualDirectory -WebReadyDocumentViewingOnPublicComputersEnabled:$False -WebReadyDocumentViewingOnPrivateComputersEnabled:$False

    대안의 영향. OWA 사용자가 메일 첨부 파일의 내용을 미리 볼 수 없습니다.

    대안을 실행 취소하려면 어떻게 해야 합니까?

    1. Exchange 관리 셸에 Exchange 조직 관리자로 로그인합니다.
    2. 다음 PowerShell 명령을 실행합니다.
      Get-OwaVirtualDirectory | where {$_.OwaVersion -eq 'Exchange2007' -or $_.OwaVersion -eq 'Exchange2010'} | Set-OwaVirtualDirectory -WebReadyDocumentViewingOnPublicComputersEnabled:$True -WebReadyDocumentViewingOnPrivateComputersEnabled:$True

Oracle Outside In에 포함되어 있는 악용 가능한 여러 취약점에 대한 FAQ

이 취약점을 악용하면 어느 작업까지 가능합니까?
두 가지 취약점이 WebReady 문서 보기 기능을 통해 Microsoft Exchange Server에 존재합니다. 보다 심각한 취약점(CVE-2013-0418)은 원격 코드 실행 취약점입니다. 또 다른 취약점(CVE-2013-0393)은 서비스 거부 취약점입니다.

취약점의 원인은 무엇입니까?
WebReady 서비스는 브라우저에서 문서의 미리 보기를 제공하기 위해 Oracle Outside In 라이브러리를 사용하여 파일을 구문 분석합니다. 이 취약점은 특수하게 조작된 파일을 미리 보기 위해 WebReady 문서 뷰어를 사용하는 경우 발생합니다.

취약한 파일 구문 분석기로 CVE 식별자를 매핑하는 요소는 다음과 같습니다.

CVE 식별자 영향을 받는 파일 구문 분석기
CVE-2013-0418 Paradox DB
CVE-2013-0393 Paradox DB

Microsoft Exchange Server는 OWA에서 렌더링 파일 유형으로 Paradox 데이터베이스를 지원하지 않습니다. 그래 도 이 업데이트를 적용해야 합니까?
예. 공격자는 Paradox 데이터베이스를 포함하는 전자 메일 메시지를 Exchange에서 지원하는 파일 유형이 포함된 첨부 파일로 보낼 수 있습니다.

Oracle Outside In 라이브러리란 무엇입니까?
Microsoft Exchange Server 2007 및 Microsoft Exchange Server 2010의 OWA(Outlook Web App) 사용자는 WebReady 문서 보기라는 기능을 제공받습니다. 이 기능은 사용자가 특정 첨부파일을 볼 때 로컬 응용 프로그램으로 열거나 보는 대신 웹페이지로 볼 수 있도록 해줍니다. Oracle Outside In 라이브러리는 서버 백엔드에서의 변환 과정에 의해 사용되어 WebReady 기능을 지원합니다. Microsoft는 Oracle로부터 이러한 라이브러리의 사용 허가를 받았습니다.

WebReady 문서 보기란 무엇입니까?
WebReady 문서 보기는 특정 첨부 파일을 웹페이지로 볼 수 있도록 해줍니다. Microsoft Exchange 2007 및 Microsoft Exchange 2010에서 변환하여 사용자는 웹 브라우저만 사용하면 됩니다.

공격자는 이 취약점을 악용하여 무엇을 할 수 있습니까?
CVE-2013-0418 취약점 악용에 성공한 공격자는 영향을 받은 Exchange 서버에서 임의의 코드를 LocalService로 실행할 수 있습니다. 서버 프로세스를 장악한 공격자는 다양한 프로그램을 설치하여 데이터를 보고, 변경하거나 삭제할 수 있으며, 서버에서 수행할 수 있는 모든 작업을 수행할 수 있습니다. LocalService 계정에는 로컬 컴퓨터의 최소 권한이 있으며 네트워크에서 익명 자격 증명을 제시합니다.

사용자가 브라우저에서 Outlook Web Access를 통해 특수하게 조작된 파일을 보는 경우 CVE-2013-0393을 성공적으로 악용하는 공격자가 영향을 받는 시스템이 응답하지 않도록 만들 수 있습니다. 공격자가 이 취약점(CVE-2013-0393)을 악용하더라도 코드를 실행하거나 사용자 권한을 승격시킬 수는 없습니다.

공격자는 어떤 방식으로 이러한 취약점을 악용할 수 있습니까?
공격자는 영향을 받는 Exchange 버전 사용자에게 특수하게 조작된 파일이 포함된 전자 메일 메시지를 보낼 수 있습니다. 사용자가 브라우저에서 특수하게 조작된 파일을 미리 볼 때 취약점이 악용될 수 있습니다.

취약점으로 인해 위험에 노출되는 시스템은 주로 무엇입니까?
Exchange 서버 시스템이 이 취약점으로 인한 위험에 주로 노출됩니다.

업데이트는 어떤 기능을 수행합니까?
이 업데이트는 영향을 받는 Oracle Outside In 라이브러리를 비보안 버전으로 업데이트하여 취약점을 해결합니다.

이 보안 공지를 게시했을 때 이 취약점이 공개되었습니까?
예. 이 취약점은 공개되었습니다. 이 취약점에는 다음 CVE(Common Vulnerability and Exposure) 번호가 지정되었습니다.

이 보안 공지를 게시했을 때 Microsoft는 이 취약점이 악용되었다는 보고를 받았습니까?
아니요. Microsoft는 이 보안 공지를 처음에 게시했을 때 이 취약점이 고객을 공격하는 데 공개적으로 사용되었다는 정보를 확인하지 못했습니다.

업데이트 정보

검색, 배포 도구 및 지침

보안 센터

해당 조직에서 서버, 데스크톱, 모바일 시스템에 적용해야 하는 소프트웨어 및 보안 업데이트를 관리합니다. 자세한 내용은 TechNet Update Management Center를 참조하십시오. Microsoft TechNet Security 웹 사이트에서 Microsoft 제품의 보안에 관한 추가 정보를 제공합니다.

보안 업데이트는 Microsoft UpdateWindows Update를 통해 제공됩니다. 보안 업데이트는 Microsoft 다운로드 센터에서도 다운로드할 수 있으며 "security update"라는 키워드를 사용하여 쉽게 찾을 수 있습니다.

Microsoft Office for Mac의 경우 Microsoft AutoUpdate for Mac을 통해 Microsoft 소프트웨어를 최신으로 유지할 수 있습니다. Microsoft AutoUpdate for Mac 사용에 대한 자세한 내용은 자동으로 소프트웨어 업데이트 확인을 참조하십시오.

마지막으로, 보안 업데이트는 Microsoft Update 카탈로그에서 다운로드할 수 있습니다. Microsoft Update 카탈로그는 보안 업데이트, 드라이버, 서비스 팩을 포함하여 Windows Update 및 Microsoft Update에서 제공하는 콘텐츠의 검색 가능한 목록입니다. 보안 공지 번호(예: "MS12-001")를 사용하여 검색하면 적용 가능한 모든 업데이트(다른 언어의 업데이트 포함)를 장바구니에 추가하고, 선택한 업데이트를 로컬 폴더에 다운로드할 수 있습니다. Microsoft Update 카탈로그에 대한 자세한 내용은 Microsoft Update 카탈로그 FAQ를 참조하십시오.

검색 및 배포 지침

Microsoft는 보안 업데이트를 위한 검색 및 배포 지침을 제공합니다. 이 지침에는 IT 전문가가 다양한 도구를 사용하여 보안 업데이트를 검색하고 배포하는 방법을 이해하는 데 도움이 되는 권장 사항과 정보가 포함되어 있습니다. 자세한 내용은 Microsoft 기술 자료 문서 961747을 참조하십시오.

Microsoft Baseline Security Analyzer

관리자는 MBSA(Microsoft Baseline Security Analyzer)를 사용하여 로컬 및 원격 시스템에서 누락된 보안 업데이트 및 일반적인 보안 설정 오류를 검색할 수 있습니다. 자세한 내용을 보려면 Microsoft Baseline Security Analyzer를 방문하십시오.

다음 표는 이 보안 업데이트에 대한 MBSA 검색 요약입니다.

소프트웨어 MBSA
Microsoft Exchange Server 2007 서비스 팩 3 
Microsoft Exchange Server 2010 서비스 팩 2 

참고 최신 MBSA, Microsoft Update 및 Windows Server Update Services에서 지원하지 않는 레거시 소프트웨어를 사용하는 고객은 Microsoft Baseline Security Analyzer를 방문하고 레거시 제품 지원 섹션을 참조하여 레거시 도구로 종합 보안 업데이트 검색을 만드는 방법을 찾으십시오.

Windows Server Update Services

Windows Server Update Services(WSUS)를 사용하면 정보 기술 관리자가 최신 Microsoft 제품 업데이트를 Windows 운영 체제를 실행하는 컴퓨터에 배포할 수 있습니다. Windows Server Update Services를 사용하여 보안 업데이트를 신속하게 배포하는 방법에 대한 자세한 내용은 TechNet 문서의 Windows Server Update Services를 참조하십시오.

Systems Management Server

다음 표는 이 보안 업데이트에 대한 SMS 검색 및 배포 요약입니다.

소프트웨어 SMS 2003(ITMU 포함) System Center Configuration Manager(지원 대상인 모든 버전)
Microsoft Exchange Server 2007 서비스 팩 3
Microsoft Exchange Server 2010 서비스 팩 2

참고 Microsoft는 2011년 4월 12일자로 SMS 2.0에 대한 지원을 중단했습니다. 또한 SMS 2003의 경우에도 Microsoft는 2011년 4월 12일자로 SUIT(Security Update Inventory Tool)에 대한 지원을 중단했습니다. Microsoft는 System Center Configuration Manager로 업그레이드할 것을 권장합니다. SMS 2003 서비스 팩 3을 계속 사용하는 고객의 경우 Inventory Tool for Microsoft Updates(ITMU)(영문)도 선택사항입니다.

SMS 2003의 경우 SMS 2003 Inventory Tool for Microsoft Updates(ITMU)를 사용하여 Microsoft Update에서 제공하고 Windows Server Update Services에서 지원하는 보안 업데이트를 검색할 수 있습니다. SMS 2003 ITMU에 대한 자세한 내용은 Microsoft Updates용 SMS 2003 Inventory Tool(영문)을 참조하십시오. SMS 검사 도구에 대한 자세한 내용은 SMS 2003 Software Update Scanning Tools(영문)를 참조하십시오. Systems Management Server 2003용 다운로드(영문)도 참조하십시오.

System Center Configuration Manager는 업데이트 검색에 WSUS 3.0을 사용합니다. 자세한 내용은 System Center를 참조하십시오.

자세한 내용은 Microsoft 기술 자료 문서 910723을 참조하십시오. 월별 검사 및 배포 가이드 문서의 요약 목록입니다.

UCE(Update Compatibility Evaluator) 및 ACT(Application Compatibility Toolkit)

업데이트는 응용 프로그램을 실행하는 데 필요한 같은 파일 및 레지스트리 설정에 기록하는 경우가 많습니다. 이에 따라 비호환성이 발생하고 보안 업데이트 배포 시간이 길어질 수 있습니다. ACT(Application Compatibility Toolkit)(영문)에 포함된 UCE(Update Compatibility Evaluator) 구성 요소를 사용하면 설치된 응용 프로그램에 대한 Windows 업데이트 테스트 및 유효성 검사를 능률화할 수 있습니다.

ACT(Application Compatibility Toolkit)에는 Windows Vista, Windows Update, Microsoft 보안 업데이트 또는 Windows Internet Explorer의 새 버전을 사용자 환경에 배포하기 전에 응용 프로그램 호환성 문제점을 평가 및 완화하는 데 필요한 도구와 설명서가 들어 있습니다.

보안 업데이트 배포

영향을 받는 소프트웨어

영향을 받는 소프트웨어에 해당하는 보안 업데이트에 대한 내용을 보려면 적절한 링크를 클릭하십시오.

Microsoft Exchange Server 2007 서비스 팩 3

참조 표

다음 표에는 이 소프트웨어에 대한 보안 업데이트 정보가 포함되어 있습니다. 추가 정보는 이 섹션의 배포 정보에서 찾아 볼 수 있습니다.

향후 서비스 팩에 포함 이 문제점에 대한 업데이트는 향후 서비스 팩 또는 업데이트 롤업에 포함될 예정입니다.
배포
사용자 개입 없이 설치 지원 대상인 Microsoft Exchange Server 2007 에디션:
Exchange2007-KB2788321-x64-en.msp /quiet
다시 시작하지 않고 설치 지원 대상인 Microsoft Exchange Server 2007 에디션:
Exchange2007-KB2788321-x64-en.msp /norestart
로그 파일 업데이트 KB2788321.log
추가 정보 검색 및 배포에 대한 자세한 내용은 이전 섹션의 검색, 배포 도구 및 지침을 참조하십시오.
다시 시작 요구 사항
다시 시작 필요 여부 아니요, 이 업데이트를 적용하기 위해 다시 시작할 필요는 없습니다. 설치 프로그램이 필요한 서비스를 중지하고 업데이트를 적용한 다음 서비스를 다시 시작합니다. 그러나 필요한 서비스를 중지할 수 없거나 필수 파일이 사용 중이면 다시 시작해야 합니다. 이러한 경우에는 다시 시작해야 한다는 메시지가 표시됩니다.

다시 시작의 필요성을 줄이려면 영향을 받은 서비스를 모두 중지하고 보안 업데이트를 설치하기 전에 영향을 받은 파일을 사용하는 모든 응용 프로그램을 닫으십시오. 컴퓨터를 다시 시작하라는 메시지가 나타나는 이유에 대한 자세한 내용은 Microsoft 기술 자료 문서 887012를 참조하십시오.
핫패칭 해당 사항 없음
제거 정보 제어판의 프로그램 추가/제거 도구를 사용하십시오.
파일 정보 Microsoft 기술 자료 문서 2809279 참조
레지스트리 키 확인 Microsoft Exchange Server 2007 서비스 팩 2(x64 기반 시스템용):
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Exchange 2007\SP2\KB2788321

배포 정보

업데이트 설치

이 보안 업데이트를 설치할 때 설치 관리자는 해당 컴퓨터에서 하나 이상의 업데이트할 파일이 Microsoft Exchange 핫픽스에 의해 이미 업데이트되었는지 확인합니다.

핫픽스와 같이 이 게시판에 나타나는 용어에 대한 자세한 내용은 Microsoft 기술 자료 문서 824684를 참조하십시오.

이 보안 업데이트는 다음 설치 스위치를 지원합니다.

지원되는 보안 업데이트 설치 스위치
스위치 설명
/help 명령줄 옵션을 표시합니다.
설치 모드
/q\[n|b|r|f\] 또는 /quiet 사용자 인터페이스 수준을 설정합니다. n - 사용자 개입 없음 b - 기본적인 사용자 개입 r - 감소된 사용자 개입 f - 완전한 사용자 개입(기본값)
다시 시작 옵션
/norestart 설치가 완료되면 다시 시작하지 않습니다.
/forcerestart 설치 후 컴퓨터를 다시 시작하고, 종료 시 기타 응용 프로그램을 닫고 열린 파일은 저장하지 않습니다.
/promptrestart 로컬 사용자에게 다시 시작할 것인지 묻는 대화 상자를 표시합니다.
로그 옵션
/l\[i|w|e|a|r|u|c|m|o|p|v|x|+|!|\*\] <LogFile> i - 상태 메시지 w - 치명적이지 않은 경고 e - 모든 오류 메시지 a - 작업 시작 r - 작업 관련 기록 u - 사용자 요청 c - 초기 UI 매개 변수 m - 메모리 부족 또는 치명적인 종료 정보 o - 디스크 여유 공간 부족 메시지 p - 터미널 속성 v - 자세한 정보 출력 x - 추가 디버깅 정보 + - 기존 로그 파일에 추가 ! - 로그의 각 줄에 플러시 \* - v 및 x 옵션을 제외한 모든 정보를 기록
/log<LogFile> /l\* <LogFile>과 동일
참고 한 명령에서 이러한 스위치를 조합하여 사용할 수 있습니다. 보안 업데이트에서는 이전 버전과의 호환성을 위해 이전 버전의 설치 프로그램에서 사용하는 다양한 설치 스위치도 지원합니다. 지원되는 설치 스위치에 대한 자세한 내용은 [Microsoft 기술 자료 문서 262841](https://support.microsoft.com/kb/262841)을 참조하십시오.

적용된 업데이트 확인

  • Microsoft Baseline Security Analyzer

    MBSA(Microsoft Baseline Security Analyzer) 도구를 사용하면 영향을 받는 시스템에 보안 업데이트가 적용되었는지 확인할 수 있습니다. 자세한 내용은 이 공지 앞부분에 있는 검색, 탐지 도구 및 지침 섹션을 참조하십시오.

  • 파일 버전 확인

    Microsoft Windows에는 여러 버전이 있으므로 사용자의 컴퓨터에서 다음 단계가 다르게 적용될 수 있습니다. 이러한 경우 제품 설명서를 참조하여 작업 단계를 완료하십시오.

    1. 시작을 클릭한 다음 검색 시작 상자에 업데이트 파일 이름을 입력합니다.
    2. 프로그램에 해당 파일이 나타나면 파일 이름을 마우스 오른쪽 단추로 클릭하고 속성을 클릭합니다.
    3. 일반 탭에 표시된 파일 크기를 공지 KB 문서에 제공된 파일 정보 표와 비교합니다.
    4. 참고 운영 체제 에디션 또는 시스템에 설치된 프로그램에 따라 파일 정보 표에 나열된 파일 중 일부가 설치되어 있지 않을 수도 있습니다.
    5. 세부 정보 탭 및 비교 정보를 클릭하여 파일 버전과 수정된 날짜를 공지 KB 문서에 제공된 파일 정보 표와 비교할 수도 있습니다.
    6. 참고 파일 버전 이외의 특성은 설치 중 변경될 수 있습니다. 다른 파일 특성과 파일 정보 표에 있는 정보를 비교하는 것은 지원되는 업데이트 적용 확인 방법이 아닙니다. 경우에 따라 파일 이름이 설치 도중 변경될 수도 있습니다. 파일 또는 버전 정보가 없으면 사용 가능한 다른 방법 중 하나를 사용하여 업데이트 설치를 확인하십시오.
    7. 마지막으로, 이전 버전 탭을 클릭하여 표시된 이전 파일 버전의 파일 정보를 새 파일 또는 업데이트된 파일 버전의 파일 정보와 비교할 수도 있습니다.
  • 레지스트리 키 확인

    이 섹션의 참조 표에 나열된 레지스트리 키를 검토하여 이 보안 업데이트가 설치한 파일을 확인할 수도 있습니다.

    이 레지스트리 키에 설치된 파일의 전체 목록 중 일부가 들어 있지 않을 수 있습니다. 또한 관리자나 OEM이 보안 업데이트를 Windows 설치 원본 파일에 통합하거나 포함시키는 경우 이러한 레지스트리 키가 제대로 만들어지지 않을 수 있습니다.

Microsoft Exchange Server 2010 서비스 팩 2

참조 표

다음 표에는 이 소프트웨어에 대한 보안 업데이트 정보가 포함되어 있습니다. 추가 정보는 이 섹션의 배포 정보에서 찾아 볼 수 있습니다.

향후 서비스 팩에 포함 이 문제점에 대한 업데이트는 향후 서비스 팩 또는 업데이트 롤업에 포함될 예정입니다.
배포
사용자 개입 없이 설치 Microsoft Exchange Server 2010 서비스 팩 2:
Exchange2010-KB2746164-x64-EN.msp /quiet
다시 시작하지 않고 설치 Microsoft Exchange Server 2010 서비스 팩 2:
Exchange2010-KB2746164-x64-EN.msp /norestart
로그 파일 업데이트 KB2746164.log
추가 정보 검색 및 배포에 대한 자세한 내용은 이전 섹션의 검색, 배포 도구 및 지침을 참조하십시오.
다시 시작 요구 사항
다시 시작 필요 여부 아니요, 이 업데이트를 적용하기 위해 다시 시작할 필요는 없습니다. 설치 프로그램이 필요한 서비스를 중지하고 업데이트를 적용한 다음 서비스를 다시 시작합니다. 그러나 필요한 서비스를 중지할 수 없거나 필수 파일이 사용 중이면 다시 시작해야 합니다. 이러한 경우에는 다시 시작해야 한다는 메시지가 표시됩니다.

다시 시작의 필요성을 줄이려면 영향을 받은 서비스를 모두 중지하고 보안 업데이트를 설치하기 전에 영향을 받은 파일을 사용하는 모든 응용 프로그램을 닫으십시오. 컴퓨터를 다시 시작하라는 메시지가 나타나는 이유에 대한 자세한 내용은 Microsoft 기술 자료 문서 887012를 참조하십시오.
핫패칭 해당 사항 없음
제거 정보 제어판의 프로그램 추가/제거 도구를 사용하십시오.
파일 정보 Microsoft 기술 자료 문서 2809279 참조
레지스트리 키 확인 지원 대상인 Microsoft Exchange Server 2010 에디션:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Exchange 2010\SP1\KB2746164

배포 정보

업데이트 설치

이 보안 업데이트를 설치할 때 설치 관리자는 해당 컴퓨터에서 하나 이상의 업데이트할 파일이 Microsoft Exchange 핫픽스에 의해 이미 업데이트되었는지 확인합니다.

핫픽스와 같이 이 게시판에 나타나는 용어에 대한 자세한 내용은 Microsoft 기술 자료 문서 824684를 참조하십시오.

이 보안 업데이트는 다음 설치 스위치를 지원합니다.

지원되는 보안 업데이트 설치 스위치
스위치 설명
/help 명령줄 옵션을 표시합니다.
설치 모드
/q\[n|b|r|f\] 또는 /quiet 사용자 인터페이스 수준을 설정합니다. n - 사용자 개입 없음 b - 기본적인 사용자 개입 r - 감소된 사용자 개입 f - 완전한 사용자 개입(기본값)
다시 시작 옵션
/norestart 설치가 완료되면 다시 시작하지 않습니다.
/forcerestart 설치 후 컴퓨터를 다시 시작하고, 종료 시 기타 응용 프로그램을 닫고 열린 파일은 저장하지 않습니다.
/promptrestart 로컬 사용자에게 다시 시작할 것인지 묻는 대화 상자를 표시합니다.
로그 옵션
/l\[i|w|e|a|r|u|c|m|o|p|v|x|+|!|\*\] <LogFile> i - 상태 메시지 w - 치명적이지 않은 경고 e - 모든 오류 메시지 a - 작업 시작 r - 작업 관련 기록 u - 사용자 요청 c - 초기 UI 매개 변수 m - 메모리 부족 또는 치명적인 종료 정보 o - 디스크 여유 공간 부족 메시지 p - 터미널 속성 v - 자세한 정보 출력 x - 추가 디버깅 정보 + - 기존 로그 파일에 추가 ! - 로그의 각 줄에 플러시 \* - v 및 x 옵션을 제외한 모든 정보를 기록
/log<LogFile> /l\* <LogFile>과 동일
참고 한 명령에서 이러한 스위치를 조합하여 사용할 수 있습니다. 보안 업데이트에서는 이전 버전과의 호환성을 위해 이전 버전의 설치 프로그램에서 사용하는 다양한 설치 스위치도 지원합니다. 지원되는 설치 스위치에 대한 자세한 내용은 [Microsoft 기술 자료 문서 262841](https://support.microsoft.com/kb/262841)을 참조하십시오.

적용된 업데이트 확인

  • Microsoft Baseline Security Analyzer

    MBSA(Microsoft Baseline Security Analyzer) 도구를 사용하면 영향을 받는 시스템에 보안 업데이트가 적용되었는지 확인할 수 있습니다. 자세한 내용은 이 공지 앞부분에 있는 검색, 탐지 도구 및 지침 섹션을 참조하십시오.

  • 파일 버전 확인

    Microsoft Windows에는 여러 버전이 있으므로 사용자의 컴퓨터에서 다음 단계가 다르게 적용될 수 있습니다. 이러한 경우 제품 설명서를 참조하여 작업 단계를 완료하십시오.

    1. 시작을 클릭한 다음 검색 시작 상자에 업데이트 파일 이름을 입력합니다.
    2. 프로그램에 해당 파일이 나타나면 파일 이름을 마우스 오른쪽 단추로 클릭하고 속성을 클릭합니다.
    3. 일반 탭에 표시된 파일 크기를 공지 KB 문서에 제공된 파일 정보 표와 비교합니다.
    4. 참고 운영 체제 에디션 또는 시스템에 설치된 프로그램에 따라 파일 정보 표에 나열된 파일 중 일부가 설치되어 있지 않을 수도 있습니다.
    5. 세부 정보 탭 및 비교 정보를 클릭하여 파일 버전과 수정된 날짜를 공지 KB 문서에 제공된 파일 정보 표와 비교할 수도 있습니다.
    6. 참고 파일 버전 이외의 특성은 설치 중 변경될 수 있습니다. 다른 파일 특성과 파일 정보 표에 있는 정보를 비교하는 것은 지원되는 업데이트 적용 확인 방법이 아닙니다. 경우에 따라 파일 이름이 설치 도중 변경될 수도 있습니다. 파일 또는 버전 정보가 없으면 사용 가능한 다른 방법 중 하나를 사용하여 업데이트 설치를 확인하십시오.
    7. 마지막으로, 이전 버전 탭을 클릭하여 표시된 이전 파일 버전의 파일 정보를 새 파일 또는 업데이트된 파일 버전의 파일 정보와 비교할 수도 있습니다.
  • 레지스트리 키 확인

    이 섹션의 참조 표에 나열된 레지스트리 키를 검토하여 이 보안 업데이트가 설치한 파일을 확인할 수도 있습니다.

    이 레지스트리 키에 설치된 파일의 전체 목록 중 일부가 들어 있지 않을 수 있습니다. 또한 관리자나 OEM이 보안 업데이트를 Windows 설치 원본 파일에 통합하거나 포함시키는 경우 이러한 레지스트리 키가 제대로 만들어지지 않을 수 있습니다.

기타 정보

MAPP(Microsoft Active Protections Program)

고객에 대한 보안을 강화하기 위해 Microsoft는 월별 보안 업데이트를 배포하기 전에 주요 보안 소프트웨어 제공업체에 취약점 정보를 제공합니다. 보안 소프트웨어 제공업체는 이 취약점 정보를 사용하여 안티바이러스, 네트워크 기반 침입 탐지 시스템 또는 호스트 기반 침임 방지 시스템 등 자사의 보안 소프트웨어나 장치를 통해 업데이트된 보호 기능을 고객에게 제공할 수 있습니다. 보안 소프트웨어 제공업체가 활성 보호 기능을 제공하는지 확인하려면 Microsoft MAPP(Active Protections Program) 파트너(영문)에 나열된 프로그램 파트너가 제공하는 활성 보호 기능 웹 사이트를 참조하십시오.

지원

이 보안 업데이트에 대한 도움말 및 지원을 얻는 방법

부인

Microsoft 기술 자료에서 제공되는 정보는 어떠한 보증도 없이 "있는 그대로" 제공됩니다. Microsoft는 상품성 및 특정 목적에의 적합성에 대한 보증을 포함하여 명시적이거나 묵시적인 어떤 보증도 하지 않습니다. Microsoft Corporation 또는 그 공급자는 모든 직접적, 간접적, 부수적, 파생적 손해 또는 영업 이익 손실 또는 특수한 손실에 대하여 어떠한 경우에도 책임을 지지 않으며, 이는 Microsoft Corporation과 그 공급자가 그와 같은 손해의 가능성을 사전에 알고 있던 경우에도 마찬가지입니다. 일부 지역에서는 파생적 또는 부수적 손해에 대한 책임의 배제 또는 제한을 허용하지 않으므로 위 제한은 귀하에게 적용되지 않을 수도 있습니다.

개정 내역

  • V1.0(2013년 2월 13일): 공지가 게시되었습니다.
  • V1.1(2013년 2월 14일): Microsoft Exchange Server 2010 서비스 팩 3는 이 공지에 설명된 취약점의 영향을 받지 않는다는 설명이 추가되었습니다. 이 변경 사항은 정보에만 해당됩니다.

Built at 2014-04-18T12:27:44Z-07:00