증상
다음 시나리오를 고려하세요.
시나리오 1
- Exchange Server 2010 환경에 Microsoft Exchange Server 2016 또는 Exchange Server 2013이 공존합니다.
- User1에는 Exchange Server 2016 또는 Exchange Server 2013의 사서함이 있습니다.
- User2에는 Exchange Server 2010의 사서함이 있습니다.
- User1에는 User2의 사서함에 대한 모든 액세스 권한이 있습니다.
시나리오 2
- 하이브리드 Microsoft 365 환경이 있습니다.
- User1에는 클라우드에 사서함이 있습니다.
- User2에는 온-프레미스 사서함이 있습니다.
- User1에는 User2의 사서함에 대한 모든 액세스 권한이 있습니다.
이러한 시나리오에서는 User1이 공유 폴더 추가 옵션을 사용하여 사서함을 추가한 후 User1에서 User2의 사서함을 확장할 수 없습니다. 또한 User1은 다음과 같은 오류 메시지를 받습니다.
요청을 완료할 수 없습니다.
이 작업을 수행할 수 있는 권한이 없을 수 있습니다.
메모 시나리오 2에서 User1에 온-프레미스 사서함이 있고 User2에 클라우드에 사서함이 있는 경우(즉, 어떤 환경에서 어떤 사서함을 호스트하는지에 관계없이) User1은 User2의 사서함을 확장할 수 없습니다.
원인
AddSharedFolder 요청이 성공하고 공유 사서함을 폴더 목록에 추가합니다. 그러나 공유 사서함 확장 요청은 사용자의 사서함 서버로 프록시됩니다. 그러면 "WrongServerVersionException" 메시지와 HTTP 500 상태가 트리거됩니다. HTTP 응답에는 다음이 포함될 수 있습니다.
{"Body":{"ErrorCode":500,"ExceptionName":"WrongServerVersionException","FaultMessage":"The Client Access server version doesn't match the Mailbox server version of the resource that was being accessed. To determine the correct URL to use to access the resource, use Autodiscover with the address of the resource.", "IsTransient":false,"StackTrace":"Microsoft.Exchange.Services.Core.Types.WrongServerVersionException: The Client Access server version doesn't match the Mailbox server version of the resource that was being accessed. To determine the correct URL to use to access the resource, use Autodiscover with the address of the resource. \u000d\u000a at Microsoft.Exchange.Services.Core.Types.StoreSessionCacheBase.ConnectOnce(ExchangePrincipal mailboxToAccess, CallContext callContext, Boolean unifiedLogon)\u000d\u000a at
해결 방법
이 문제를 해결하려면 웹용 Outlook에서 다른 사서함 열기 옵션을 사용하여 모든 권한이 있는 공유 사서함을 엽니다. 메모: 그러면 사서함에 액세스하기 전에 리디렉션 링크 및 자격 증명 프롬프트가 생성됩니다. 자세한 내용은 이 문서의 하이브리드 환경 섹션에서 지원되는 사서함 권한을 읽어보세요.