증상
Microsoft 365 그룹의 그룹을 위해 삭제된 항목 폴더를 비우려고 합니다. 그러나 지운 편지함 폴더는 웹용 Microsoft Outlook 및 Outlook에 없습니다.
원인
하나 이상의 사용자가 만든 폴더가 없는 한 웹용 Outlook에는 지운 편지함 폴더와 같은 기본 제공 Microsoft 365 그룹 폴더가 표시되지 않습니다. 클래식 Windows용 Outlook을 사용하여 Microsoft 365 Groups 폴더를 볼 수 없습니다.
해결 방법
지운 편지함 폴더를 비우려면 다음 방법 중 하나를 사용합니다.
선택한 메서드는 지운 편지함 폴더의 크기에 따라 달라질 수 있습니다. 예를 들어 Microsoft 365 그룹 사서함이 기본 스토리지 할당량에 도달하고 지운 편지함 폴더가 큰 경우 빠른 해결을 위해 방법 1을 사용하는 것이 좋습니다. 지운 편지함 폴더에서 차지하는 그룹 사서함 스토리지 할당량의 양을 확인하려면 다음 단계를 수행합니다.
Get-EXOMailboxFolderStatistics cmdlet을 사용하여 그룹 사서함에 대한 폴더 크기 정보를 가져옵니다.
Get-EXOMailboxFolderStatistics -Identity "<group name>" -FolderScope NonIPMRoot | Where { $_.TargetQuota -like 'User' } | FT Name,FolderType,FolderAndSubfolderSize
방법 1: 웹용 Outlook 또는 새 Windows용 Outlook 사용
지운 편지함 폴더에 액세스할 Microsoft 365 그룹 하위 폴더를 만듭니다. 아래 단계를 수행하세요.
다음 명령을 실행하여 폴더 만들기를 사용할 수 있는지 확인합니다.
Get-OrganizationConfig | FL IsGroupFoldersAndRulesEnabled폴더 만들기를 사용하도록 설정하지 않은 경우 다음 명령을 실행하여 사용하도록 설정합니다.
Set-OrganizationConfig -IsGroupFoldersAndRulesEnabled $True그룹의 소유자 자격 증명을 사용하여 웹용 Outlook에 로그인하거나 새 Windows용 Outlook을 엽니다.
Groups 아래에서 그룹을 찾으세요.
그룹을 마우스 오른쪽 단추로 클릭하고 새 하위 폴더 만들기를 선택하고 폴더의 이름을 입력한 다음 확인을 선택합니다.
비고
새 하위 폴더 만들기 옵션을 사용할 수 없는 경우 그룹 소유자 자격 증명을 사용하여 웹용 Outlook에 로그인했는지 확인합니다. 그룹의 소유자가 아닌 경우 소유자에게 문의하여 이 문제를 해결하세요. 그룹 소유자는 그룹 구성원에게 폴더를 만들고, 폴더 이름을 바꾸고, 메시지를 삭제할 수 있는 권한을 부여 할 수 있습니다.
기본 제공 지운 편지함 폴더가 나타나면 폴더를 선택하고 메시지 목록 맨 위에 있는 모든 메시지 선택을 선택한 다음 빈 폴더를 선택합니다.
방법 2: 보존 정책 또는 보존 레이블 정책 사용
이 메서드는 지운 편지함 폴더를 관리하기 위한 장기 솔루션을 제공합니다.
지운 편지함 폴더에서 메시지의 보존 및 삭제를 관리하는 규칙을 만듭니다. 다음 옵션 중 하나를 선택합니다:
Microsoft Purview 규정 준수 포털에서 또는 New-RetentionCompliancePolicy, New-ComplianceTag 및 New-RetentionComplianceRule Exchange Online PowerShell cmdlet을 사용하여 보존 레이블 정책을 만듭니다. 특정 폴더 또는 전체 사서함에 이러한 종류의 정책을 적용할 수 있습니다.
Microsoft Purview 규정 준수 포털에서 또는 New-RetentionPolicyTag 및 New-RetentionPolicy Exchange Online PowerShell cmdlet을 사용하여 MRM(메시징 레코드 관리) 보존 정책을 만듭니다. 특정 폴더 또는 전체 사서함에 이러한 종류의 정책을 적용할 수 있습니다.
Microsoft Purview 규정 준수 포털에서 또는 New-RetentionCompliancePolicy 및 New-RetentionComplianceRule Exchange Online PowerShell cmdlet을 사용하여 보존 정책을 만듭니다. 이러한 종류의 정책은 전체 사서함에만 적용할 수 있습니다.
비고
Microsoft Purview는 보존 정책을 사서함 위치에 배포하는 데 최대 1일이 걸릴 수 있습니다. 보존 정책 배포에 대한 자세한 내용은 보존 정책이 적용되는 데 걸리는 시간을 참조하세요.
Microsoft Purview가 보존 정책을 배포한 후 MFA( Managed Folder Assistant )에서 지정된 사서함에 보존 정책을 적용하도록 합니다. 이렇게 하려면 다음 명령을 실행합니다.
Start-ManagedFolderAssistant -Identity "<group name>"비고
MFA는 일반적으로 일정에 따라 사서함을 처리합니다. 예약된 사서함 처리를 완료하는 데 며칠이 걸릴 수 있습니다. 그러나 Start-ManagedFolderAssistant cmdlet은 MFA가 보존 정책을 신속하게 처리하기 위해 지정된 사서함 처리를 즉시 시작하도록 합니다.
MFA가 완료되기를 기다립니다. MFA가 사서함 처리를 완료했는지 확인하려면 다음 명령을 실행합니다.
$log=Export-MailboxDiagnosticLogs "<group name>" -ExtendedProperties $xml=[xml]($Log.MailboxLog) $xml.Properties.MailboxTable.Property | ?{$_.Name -like "ELC*"}MFA가 사서함
ELCLastSuccessTimestamp처리를 성공적으로 완료한 경우 속성에는 MFA를 트리거할 때보다 나중의 타임스탬프 값이 있습니다.문제가 발생하는 경우:
보존에 영향을 주는 사서함 설정을 확인합니다. 이렇게 하려면 다음 명령을 실행합니다.
Get-Mailbox -GroupMailbox "<group name>" | FL ELCProcessingDisabled,Retention*다음 속성 값을 확인합니다.
RetentionPolicy는 1단계에서 만든 보존 정책의 이름이어야 합니다.RetentionHoldEnabled은 이어야False합니다.ELCProcessingDisabled은 이어야False합니다.
사서함을 처리하는 동안 MFA에서 오류가 발생했는지 확인합니다. 이렇게 하려면 다음 명령을 실행하여 사서함 진단 로그를 가져옵니다.
Export-MailboxDiagnosticLogs -Identity "<group name>" -ComponentName MRM가장 최근 오류에 대한 항목은 로그 맨 위에 있습니다.
MFA 및 보존 문제를 해결하는 방법에 대한 자세한 내용은 보존 정책을 사용할 때 전자 메일 보관 및 삭제 문제 해결을 참조하세요.