Notitie
Voor toegang tot deze pagina is autorisatie vereist. U kunt proberen u aan te melden of de directory te wijzigen.
Voor toegang tot deze pagina is autorisatie vereist. U kunt proberen de mappen te wijzigen.
Dit artikel is de derde in een reeks over herstel na noodgevallen (DR) voor een Azure-gegevensplatform. Hierin worden de impact op herstel na noodgevallen en de vereiste activiteiten voor elk onderdeel in het gegevensplatform beschreven in verschillende foutscenario's, waaronder storingen in het Azure-datacenter, fouten in de beschikbaarheidszone en regionale fouten.
Topologie van gegevensservice
In het volgende diagram ziet u de belangrijkste functies van het Contoso-gegevensecosysteem op hoog niveau. Het biedt context voor de implementaties van de DR-scenario's die in de volgende secties worden beschreven, waaronder de selectie van een DR-strategie en de verdeling van herstelverantwoordelijkheden.
Impact van disaster recovery versus klantactiviteiten
In de volgende secties wordt beschreven wat Contoso moet doen voor dr-gebeurtenissen van verschillende omvang en impact.
Gebied: Basisonderdelen
Microsoft Entra-id inclusief rolrechten
- Selectie Contoso-SKU: Premium P1
- DR-impact
- Fout in Azure-datacenter: niet van toepassing
- Fout in beschikbaarheidszone: niet van toepassing
- Azure regionale fout: niet van toepassing
Beheergroepen
- Selectie contoso-SKU: niet van toepassing
- DR-impact
- Fout in Azure-datacenter: niet van toepassing
- Fout in beschikbaarheidszone: niet van toepassing
- Azure regionale fout: niet van toepassing
Subscriptions
- Selectie contoso-SKU: niet van toepassing
- DR-impact
- Fout in Azure-datacenter: niet van toepassing
- Fout in beschikbaarheidszone: niet van toepassing
- Azure regionale fout: niet van toepassing
Azure Key Vault-
- Selectie Contoso-SKU: Standaard
- DR-impact
- Fout in Azure-datacenter: niet van toepassing
- Fout in beschikbaarheidszone: niet van toepassing
- Azure regionale fout: niet van toepassing
Azure Monitor
- Selectie contoso-SKU: niet van toepassing
- DR-impact
- Fout in Azure-datacenter: niet van toepassing
- Fout in beschikbaarheidszone: niet van toepassing
- Azure regionale fout: niet van toepassing
Microsoft Defender voor de Cloud
- Selectie contoso-SKU: niet van toepassing
- DR-impact
- Fout in Azure-datacenter: niet van toepassing
- Fout in beschikbaarheidszone: niet van toepassing
- Azure regionale fout: niet van toepassing
Microsoft Cost Management
- Selectie contoso-SKU: niet van toepassing
- DR-impact
- Fout in Azure-datacenter: niet van toepassing
- Fout in beschikbaarheidszone: niet van toepassing
- Azure regionale fout: niet van toepassing
Azure DNS
- Selectie contoso-SKU: niet van toepassing
- DR-impact
- Fout in Azure-datacenter: niet van toepassing
- Fout in beschikbaarheidszone: niet van toepassing
- Azure regionale fout: niet van toepassing
Virtuele netwerken, waaronder subnetten, door de gebruiker gedefinieerde routes (UDR's) en netwerkbeveiligingsgroepen (NSG's)
- Selectie contoso-SKU: niet van toepassing
- DR-impact
- Fout in Azure-datacenter: niet van toepassing
- Fout in beschikbaarheidszone: niet van toepassing
- Azure regionale storing: Contoso moet de virtuele netwerken van het basis- en dataplatform opnieuw implementeren naar de secundaire regio, met de daaraan gekoppelde UDR's en NSG's.
- Opmerkingen:
- Gebruik Azure Traffic Manager om verkeer via georouting te verdelen over regio's die replicas van virtuele netwerkstructuren bevatten.
- Als beide virtuele netwerken dezelfde adresruimte delen, kunt u ze niet tegelijkertijd verbinden met uw on-premises netwerk omdat dit routeringsconflicten veroorzaakt. Wanneer een ramp het virtuele netwerk van een regio platlegt, verbindt u het andere virtuele netwerk in de nog beschikbare regio met uw on-premises netwerk.
Resourcegroepen
- Selectie contoso-SKU: niet van toepassing
- DR-impact
- Fout in Azure-datacenter: niet van toepassing
- Fout in beschikbaarheidszone: niet van toepassing
- Azure regionale fout: Contoso moet de basis- en gegevensplatformresourcegroepen opnieuw implementeren in de secundaire regio.
- Opmerkingen:
- Een warme reservestrategie elimineert deze stap door de topologie van de netwerk- en resourcegroep vooraf geïmplementeerd te houden in de secundaire regio.
Azure VPN-gateway
- Selectie Contoso-SKU: VpnGw1
- DR-impact
- Fout in Azure-datacenter: niet van toepassing
- Fout in beschikbaarheidszone: Contoso moet de beschikbaarheid valideren en indien nodig opnieuw implementeren.
- Azure regionale fout: Contoso moet de basis-VPN-gateways opnieuw implementeren in de secundaire regio.
- Opmerkingen:
- Maak VPN-gateways met zoneredundantie om de beschikbaarheid te verbeteren.
- Een warme reservestrategie elimineert deze stap.
Azure DevOps
- Selectie Contoso SKU: DevOps Services
- DR-impact
- Fout in Azure-datacenter: niet van toepassing
- Fout in beschikbaarheidszone: niet van toepassing
- Azure regionale fout: niet van toepassing
- Opmerkingen:
- DevOps Services wordt uitgevoerd op de Azure backbone en maakt gebruik van Azure Blob Storage met geo-replicatie voor betrouwbaarheid.
Gebied: Onderdelen van gegevensplatform
Opslagaccount : Azure Data Lake Storage
- Selectie Contoso-SKU: lokaal redundante opslag (LRS)
- DR-impact
- Fout in Azure-datacenter: niet van toepassing
- Fout in beschikbaarheidszone: Contoso moet de beschikbaarheid valideren en indien nodig opnieuw implementeren.
- Azure regionale fout: Contoso moet de opslagaccounts van het gegevensplatform opnieuw implementeren in de secundaire regio en ze opnieuw reactiveren met gegevens.
- Opmerkingen:
- Opslagaccounts ondersteunen een reeks opties voor gegevensredundantie , van redundantie van primaire regio's tot secundaire regioredundantie.
- Met redundantie van secundaire regio's worden gegevens asynchroon gerepliceerd naar de secundaire regio. Een fout die van invloed is op de primaire regio kan leiden tot gegevensverlies als de primaire regio niet kan worden hersteld. Azure Storage heeft doorgaans een RPO (Recovery Point Objective) van minder dan 15 minuten.
- Tijdens een regionale storing komen geografisch redundante opslagaccounts beschikbaar in de secundaire regio als LRS. Pas extra configuratie toe om georedundantie in de secundaire regio te herstellen.
Microsoft Fabric - OneLake
- Contoso SKU-selectie: Fabric Storage
- DR-impact
- Fout in Azure-datacenter: niet van toepassing
- Fout in beschikbaarheidszone: Contoso moet de beschikbaarheid valideren en indien nodig opnieuw implementeren.
- Azure regionale fout: Microsoft verwerkt regionale storingen. OneLake-gegevens blijven beschikbaar via de API tijdens het herstel. Zie DR en gegevensbescherming voor OneLake voor meer informatie.
Fabric Data Warehouse
- Selectie Contoso-SKU: Netwerkcapaciteit
- DR-impact
- Fout in Azure-datacenter: niet van toepassing
- Fout in beschikbaarheidszone: niet van toepassing
- Azure regionale fout: Contoso moet het Fabric gegevensplatform implementeren in de secundaire regio en het magazijn herstellen.
- Opmerkingen:
- Beperkingen voor herstel tussen regio's:
- U kunt een magazijn niet herstellen van de ene regio of werkruimte naar een andere. U moet het schema opnieuw implementeren en gegevens opnieuw opnemen.
- Na het herstel kunt u de Fabric-capaciteit pauzeren. Alleen opslagkosten zijn verschuldigd tijdens de gepauzeerde status, waardoor dit een kostenefficiënte manier is om een live momentopname te behouden.
- Beperkingen voor herstel tussen regio's:
Fabric – Pijplijnen
- Selectie Contoso-SKU: Netwerkcapaciteit
- DR-impact
- Fout in Azure-datacenter: niet van toepassing
- Fout in beschikbaarheidszone: niet van toepassing
- Azure regionale fout: Contoso moet het Fabric gegevensplatform implementeren in de secundaire regio en de pijplijnen herstellen.
Azure Event Hubs
- Selectie Contoso-SKU: Standaard
- DR-impact
- Fout in Azure-datacenter: niet van toepassing
- Fout in beschikbaarheidszone: niet van toepassing
- Azure regionale fout: Contoso moet de Event Hubs-instantie opnieuw implementeren in de secundaire regio.
- Opmerkingen:
- Wanneer u de Azure-portal gebruikt, wordt zoneredundantie automatisch ingeschakeld. U kunt het uitschakelen met behulp van de Azure CLI of PowerShell.
- Zoneredundantie biedt lokale tolerantie tijdens een zonestoring. Gebruik bij regiobrede verstoringen de functie geo-noodherstel van Event Hubs om de activiteiten in een secundaire regio te herstellen.
Azure IoT Hub
- Selectie Contoso-SKU: Standaard
- DR-impact
- Fout in Azure-datacenter: niet van toepassing
- Fout in beschikbaarheidszone: niet van toepassing
- Azure regionale fout: Contoso moet de IoT Hub opnieuw implementeren in de secundaire regio.
- Opmerkingen:
- IoT Hub biedt hoge beschikbaarheid binnen regio's en maakt automatisch gebruik van een beschikbaarheidszone wanneer deze is gemaakt in een vooraf gedefinieerde set Azure regio's.
Azure Stream Analytics
- Selectie Contoso-SKU: Standaard
- DR-impact
- Fout in Azure-datacenter: niet van toepassing
- Fout in beschikbaarheidszone: niet van toepassing
- Azure regionale fout: Contoso moet de Azure Stream Analytics taak opnieuw implementeren in de secundaire regio.
- Opmerkingen:
- Stream Analytics kan automatisch herstellen van knooppuntfouten.
Azure Machine Learning
- Selectie Contoso-SKU: Algemeen gebruik – D-reeksinstanties
- DR-impact
- Azure datacenterfout: Contoso moet de beschikbaarheid valideren en indien nodig opnieuw implementeren.
- Fout in beschikbaarheidszone: Contoso moet de beschikbaarheid valideren en indien nodig opnieuw implementeren.
- Azure regionale fout: Contoso moet Machine Learning opnieuw implementeren in de secundaire regio.
- Opmerkingen:
- Microsoft beheert de Machine Learning infrastructuur, maar u beheert de bijbehorende resources. Alleen Azure Key Vault is standaard maximaal beschikbaar.
- Voor kritieke diensten raadt Microsoft een multiregionale implementatie aan.
Microsoft Foundry
- Selectie van Contoso-SKU: Ingerichte doorvoereenheden (PTUs) of betalen per gebruik
- DR-impact
- Azure datacenterfout: Contoso moet de beschikbaarheid van de service valideren en indien nodig foundry-resources opnieuw implementeren.
- Fout in beschikbaarheidszone: Contoso moet beschikbaarheid valideren en workloads opnieuw implementeren naar een andere zone binnen dezelfde regio.
- Azure regionale fout: Contoso moet foundry-resources opnieuw implementeren in de secundaire regio.
- Opmerkingen:
- Microsoft beheert de Foundry-platforminfrastructuur, maar Contoso beheert gekoppelde resources, zoals opslagaccounts, rekenclusters en netwerken om hoge beschikbaarheid en herstel na noodgevallen te behouden.
- Ontwerp voor Foundry Agent Service DR.
- Implementeer back-upstrategieën voor aangepaste modellen, gegevenssets en configuratieartefacten omdat het platform deze niet automatisch repliceert in verschillende regio's.
Infrastructuur – Eventhouse
- Selectie Contoso-SKU: Netwerkcapaciteit
- DR-impact
- Fout in Azure-datacenter: niet van toepassing
- Fout in beschikbaarheidszone: niet van toepassing
- Azure regionale storing: Contoso moet Fabric Eventhouses en pijplijnen in de secundaire regio opnieuw implementeren.
Fabric – Lakehouse
- Selectie Contoso-SKU: Netwerkcapaciteit
- DR-impact
- Fout in Azure-datacenter: niet van toepassing
- Fout in beschikbaarheidszone: niet van toepassing
- Azure regionale fout: Contoso moet het Fabric gegevensplatform in de secundaire regio opnieuw implementeren en de lakehouses en pijplijnen herstellen.
Power BI
- Selectie contoso-SKU: Infrastructuurcapaciteit of Power BI Pro
- DR-impact
- Fout in Azure-datacenter: niet van toepassing
- Fout in beschikbaarheidszone: niet van toepassing
- Azure regionale fout: Contoso moet wachten op bevestiging van Microsoft voordat ze publiceren of bewerken.
- Opmerkingen:
- U hoeft geen failover te initiëren. Het Power BI team verwerkt failover wanneer ze een storing declareren. Houd rekening met deze beperkingen tijdens de failover:
- Een exemplaar waarvoor een failover is uitgevoerd , ondersteunt alleen leesbewerkingen. Rapporten die Direct Query of Live Connect gebruiken, werken niet tijdens een failover.
- Publiceer of wijzig rapporten pas nadat Microsoft bevestigt dat het failover-exemplaar beschrijfbaar is of dat de primaire regio wordt hersteld.
- On-premises gegevensvernieuwingen via Power BI-gateways zijn onderbroken.
- U hoeft geen failover te initiëren. Het Power BI team verwerkt failover wanneer ze een storing declareren. Houd rekening met deze beperkingen tijdens de failover:
Azure Cosmos DB
- Contoso SKU Selectie: Schrijven in één regio met periodieke backup
- DR-impact
- Fout in Azure-datacenter: niet van toepassing
- Fout in beschikbaarheidszone: niet van toepassing
- Uitval van een Azure-regio: Contoso moet in de resterende regio's ingerichte aanvraageenheden (RU's) monitoren om te bevestigen dat deze regio's lees- en schrijfbewerkingen kunnen ondersteunen.
- Opmerkingen:
- Accounts met één regio verliezen mogelijk de beschikbaarheid na een regionale storing. Als u een hoge beschikbaarheid van uw Azure Cosmos DB-exemplaar wilt garanderen, configureert u deze met één schrijfregio en ten minste één leesregio en schakelt u door de service beheerde failover in.
- Als u de beschikbaarheid voor schrijfbewerkingen wilt behouden, schakelt u failover in die door de service wordt beheerd voor productieworkloads. Deze benadering biedt automatische failover voor beschikbare regio's.
Azure Data Share
- Selectie contoso-SKU: niet van toepassing
- DR-impact
- Azure datacenterfout: Contoso moet de beschikbaarheid valideren en indien nodig opnieuw implementeren.
- Fout in beschikbaarheidszone: Contoso moet de beschikbaarheid valideren en indien nodig opnieuw implementeren.
- Azure regionale fout: Contoso moet Data Share opnieuw implementeren in de secundaire regio.
- Opmerkingen:
- Data Share biedt geen ondersteuning voor beschikbaarheidszones.
- Het implementeren van Data Share in een configuratie met hoge beschikbaarheid elimineert elk van deze storingsrisico's.
Microsoft Purview
- Selectie contoso-SKU: niet van toepassing
- DR-impact
- Fout in Azure-datacenter: niet van toepassing
- Fout in beschikbaarheidszone: Contoso moet de beschikbaarheid valideren en indien nodig opnieuw implementeren.
- Azure regionale fout: Contoso moet een Microsoft Purview exemplaar implementeren in de secundaire regio.
- Opmerkingen:
- Een warme reservestrategie elimineert deze stap door een tweede Microsoft Purview exemplaar in de secundaire regio vooraf te implementeren.
- Een warme reservebenadering heeft de volgende beperkingen:
- De primaire en secundaire Microsoft Purview-accounts kunnen niet dezelfde Azure Data Factory, Data Share of Fabric accounts delen. Als gevolg hiervan is herkomst van Azure Data Factory en Data Share niet zichtbaar in het secundaire Microsoft Purview-account.
- Integratieruntimes zijn beperkt tot één Microsoft Purview-account. Als scans gelijktijdig moeten worden uitgevoerd in primaire en secundaire Microsoft Purview-accounts, moet u meerdere zelf-hostende Integration Runtimes (SHIR's) onderhouden.
Opmerking
Deze sectie bevat algemene richtlijnen. Raadpleeg de documentatie van de leverancier voor herstel na noodgevallen, redundantie en back-up voor nieuwe onderdelen of services om de juiste aanpak te bepalen.
Azure datacenterfout is van toepassing op regio's waar beschikbaarheidszones niet beschikbaar zijn.
Als er configuratiewijzigingen of releases zijn opgetreden op het moment van de noodgeval, controleert en implementeert u deze zo nodig opnieuw om het platform naar de huidige status te brengen.
Volgende stap
Meer informatie over aanbevelingen met betrekking tot dit scenario.