Problemen met regioservers in Azure HDInsight
In dit artikel worden stappen beschreven voor probleemoplossing en mogelijke oplossingen voor problemen bij interactie met Azure HDInsight-clusters.
Scenario: Niet-toegewezen regio's
Probleem
Wanneer u de opdracht uitvoert hbase hbck
, ziet u een foutbericht dat lijkt op:
multiple regions being unassigned or holes in the chain of regions
In de Hoofdgebruikersinterface van Apache HBase kunt u het aantal regio's zien dat niet in balans is voor alle regioservers. Vervolgens kunt u de opdracht uitvoeren hbase hbck
om gaten in de regioketen te zien.
Oorzaak
Gaten kunnen het gevolg zijn van offline regio's.
Oplossing
Herstel de toewijzingen. Volg de onderstaande stappen om de niet-toegewezen regio's weer normaal te maken:
Meld u aan bij het HDInsight HBase-cluster met behulp van SSH.
Voer de opdracht uit
hbase zkcli
om verbinding te maken met de ZooKeeper-shell.Voer
rmr /hbase/regions-in-transition
ofrmr /hbase-unsecure/regions-in-transition
opdracht uit.Sluit de zookeeper-shell af met behulp van de
exit
opdracht .Open de Gebruikersinterface van Apache Ambari en start de Active HBase Master-service opnieuw.
Voer
hbase hbck
de opdracht opnieuw uit (zonder verdere opties). Controleer de uitvoer en zorg ervoor dat alle regio's worden toegewezen.
Scenario: servers in dode regio's
Probleem
Regioservers kunnen niet worden gestart.
Oorzaak
Meerdere gesplitste WAL-mappen.
Haal een lijst met huidige WAN's op:
hadoop fs -ls -R /hbase/WALs/ > /tmp/wals.out
.Inspecteer het
wals.out
bestand. Als er te veel gesplitste mappen zijn (te beginnen met *-splitsen), mislukt de regioserver waarschijnlijk vanwege deze mappen.
Oplossing
Stop HBase vanuit de Ambari-portal.
Voer uit
hadoop fs -ls -R /hbase/WALs/ > /tmp/wals.out
om een nieuwe lijst met WAL's op te halen.Verplaats de *-gesplitste mappen naar een tijdelijke map,
splitWAL
, en verwijder de *-gesplitste mappen.Voer de opdracht uit
hbase zkcli
om verbinding te maken met zookeeper-shell.Voer uit
rmr /hbase-unsecure/splitWAL
.Start de HBase-service opnieuw.
Volgende stappen
Als u het probleem niet ziet of als u het probleem niet kunt oplossen, gaat u naar een van de volgende kanalen voor meer ondersteuning:
Krijg antwoorden van Azure-experts via Ondersteuning voor de Azure-community.
Maak verbinding met @AzureSupport : het officiƫle Microsoft Azure-account voor het verbeteren van de klantervaring. De Azure-community verbinden met de juiste resources: antwoorden, ondersteuning en experts.
Als u meer hulp nodig hebt, kunt u een ondersteuningsaanvraag indienen vanuit de Azure Portal. Selecteer Ondersteuning in de menubalk of open de Help en ondersteuningshub . Zie How to create an ondersteuning voor Azure request (Een ondersteuning voor Azure-aanvraag maken) voor meer gedetailleerde informatie. Toegang tot abonnementsbeheer en factureringsondersteuning is inbegrepen in uw Microsoft Azure-abonnement en technische ondersteuning wordt geboden via een van de Azure-ondersteuningsplannen.