Updateconsistentie van Microsoft Dynamics 365-portaloplossing voor implementaties met meerdere portals
Dit artikel bevat een oplossing voor een fout die optreedt wanneer u naar een portal navigeert die is gekoppeld aan een Dynamics 365-exemplaar met enkele oplossingen die nog niet zijn bijgewerkt.
Van toepassing op: Microsoft Dynamics CRM
Oorspronkelijk KB-nummer: 4020942
Symptomen
Na een upgrade naar de oplossingen die ondersteuning bieden voor een portalinvoegtoepassing in het Dynamics 365-beheercentrum, kunnen klanten met meerdere portalinvoegtoepassingen die zijn gekoppeld aan hetzelfde Dynamics 365-exemplaar fouten ondervinden als de oplossingen voor andere portaltypen nog niet zijn bijgewerkt. Gebruikers die naar een portal navigeren die is gekoppeld aan een Dynamics 365-exemplaar met enkele oplossingen die nog niet zijn bijgewerkt, krijgen mogelijk een foutmelding die vergelijkbaar is met het volgende voorbeeld:
Er is iets misgegaan.
[00000000-0000-0000-0000-000000000000]
We zijn op de hoogte gesteld van dit probleem en we bekijken het binnenkort.
Bedankt voor uw geduld.
Oorzaak
Wanneer een portalinvoegtoepassing wordt geïmplementeerd in een Dynamics 365-exemplaar, worden meerdere oplossingen geïnstalleerd ter ondersteuning van de functionaliteit van de portal. Updates voor deze oplossingen worden beschikbaar gesteld als er verbeteringen en oplossingen worden uitgebracht en klanten kunnen deze updates implementeren door de juiste actie te ondernemen in het Dynamics 365-beheercentrum.
Omdat er meerdere oplossingen worden gedeeld door meerdere portaltypen, kan het upgraden van één portaltype zonder dat er andere portaltypen worden gegraded die zijn geïmplementeerd in hetzelfde Dynamics 365-exemplaar, fouten veroorzaken en kunnen een of meer portals onbruikbaar worden gemaakt.
Oplossing
Om problemen met niet-overeenkomende oplossingsversies te voorkomen, moeten de oplossingen voor alle portaltypen die zijn geïmplementeerd in één Dynamics 365-exemplaar later en tijdens hetzelfde tijdsinterval worden bijgewerkt. Als u de portalinvoegtoepassingsoplossingen wilt upgraden voor geïmplementeerde portaltypen, moet u de volgende stappen uitvoeren:
- Meld u aan bij het Dynamics 365-beheercentrum met voldoende machtigingen voor het upgraden van Dynamics 365-oplossingen.
- Selecteer op het tabblad Exemplaren het exemplaar waarop twee of meer portals zijn geïmplementeerd.
- Selecteer het pictogram Oplossingen in het deelvenster rechts terwijl het exemplaar is geselecteerd.
- Selecteer in de weergave Oplossingen een portaltype (zoals communityportal) dat in dit exemplaar is geïmplementeerd.
- Als de knop Upgrade wordt weergegeven in het rechterdeelvenster, selecteert u deze om de respectieve oplossingen in het Dynamics 365-exemplaar bij te werken.
- Zodra de upgrade is voltooid, selecteert u het volgende beschikbare portaltype in de weergave Oplossingen en herhaalt u stap 5.
Wanneer alle portaltypen zijn bijgewerkt, treden er geen fouten meer op met de oplossingsversie.