Oefening: een Excel-rapport maken met behulp van een Power BI-gegevensset

Voltooid

Overzicht

De geschatte tijd voor het voltooien van deze oefening is 30 minuten.

In deze oefening voert u de volgende taken uit:

  1. Een Power BI Desktop-gegevenssetrapport & publiceren naar de Power BI-service
  2. Analyseren in Excel downloaden, installeren en gebruiken
  3. Een Excel-rapport maken met een Power BI-gegevensset

Notitie

Deze oefening is gemaakt op basis van de verkoopactiviteiten van het fictieve Wi-Fi bedrijf met de naam SureWi, dat is geleverd door P3 Adaptive. De gegevens zijn eigendom van P3 Adaptive en zijn gedeeld met het doel om excel- en Power BI-functionaliteit te demonstreren met voorbeeldgegevens uit de branche. Elk gebruik van deze gegevens moet deze toewijzing aan P3 Adaptive omvatten. Als u dat nog niet hebt gebeurd, downloadt u de labbestanden en pakt u deze uit https://aka.ms/modern-analytics-labs in de map C:\ANALYST-LABS .

Oefening 1: Een Power BI Desktop-gegevenssetrapport & publiceren naar de Power BI-service

In deze oefening gebruikt u Power BI Desktop om uw gegevensset en rapport te publiceren naar Mijn werkruimte in de Power BI-service.

Taak 1: Power BI Desktop starten

In deze taak start u Power BI Desktop en opent u een PBIX-bestand.

  1. Start Power BI Desktop.
  2. Gebruik indien van toepassing de 'x' in de rechterbovenhoek om het welkomstvenster te sluiten.

Taak 2: Het PBIX-bestand openen

In deze taak navigeert u en opent u het PBIX-beginbestand met de gegevensset en het rapport die zijn gemaakt op basis van lab 02.

  1. Selecteer Bestand>Rapport openen>Bladeren in rapporten.

    Schermopname van het geopende rapportvenster met de knop Bladeren in rapporten.

  2. Navigeer naar de map C:\ANALYST-LABS\Lab 03A .

  3. Selecteer het bestand MAIAD Lab 03A - Power BI Model.pbix en kies Openen.

Taak 3: het PBIX-bestand publiceren naar de service

In deze taak publiceert u de gegevensset en het rapport uit het Power BI Desktop-bestand naar de Power BI-service.

  1. Eerst moet u zich aanmelden bij Power BI. Klik op Aanmelden in de rechterbovenhoek van Power BI Desktop.

    Schermopname van aanmelden in de rechterbovenhoek van Power BI Desktop.

  2. Vervolgens moet u uw Power BI-gebruikersnaam en -wachtwoord invoeren. Zodra u bent aangemeld, ziet u dat de aanmelding verandert in uw naam.

    Schermopname van het aanmeldingsvenster.

  3. Selecteer op het tabblad Start in het hoofdmenu de knop Publiceren .

    Schermopname van het hoofdmenu van Power BI, tabblad Start en de knop Publiceren.

  4. Selecteer Mijn werkruimte.

    Schermopname van het venster Publiceren naar Power BI met Mijn werkruimte.

  5. Kies de knop Selecteren om het gegevensmodel en de rapportpagina te publiceren naar de Power BI-service.

    Notitie

    Alle gebruikers hebben Mijn werkruimte in Power BI-service. Dit is uw persoonlijke sandbox. Elke organisatie heeft verschillende werkruimten. Werkruimten kunnen worden gemaakt en gebruikers kunnen worden toegevoegd aan werkruimten om gegevenssets en rapporten in de hele organisatie te delen.

  6. Zodra de publicatie is voltooid, ziet u het bericht Geslaagd! met een koppeling waarop u kunt klikken om het rapport te openen in de Power BI-service.

  7. Klik op de koppeling MAIAD Lab 03A - Power BI Model.pbix in Power BI openen.

    Schermopname van het venster Publiceren naar Power BI met het bericht Geslaagd.

    Nadat u op de koppeling hebt geklikt, wordt u naar uw browser genavigeerd, waar het rapport wordt gepubliceerd naar Power BI-service in de locatie Mijn werkruimte.

    Notitie

    Als u rechtstreeks naar Power BI-service voert u de URL in: https://app.powerbi.com in uw browser in.

    Schermopname van De Power BI-service met M A I D - Power BI-rapport weergegeven.

    Notitie

    Geselecteerde rapportpagina, slicers en filters worden vastgelegd als standaardinstellingen wanneer ze worden gepubliceerd naar de Power BI-service.

Oefening 2: Analyseren in Excel downloaden, installeren en gebruiken

In deze oefening downloadt u analyseren in Excel-bibliotheken en gebruikt u Analyseren in Excel om vanuit de Excel-toepassing verbinding te maken met het gepubliceerde MAIAD Lab 03A - Power BI-model in Power BI.

Taak 1: Updates voor Analyseren in Excel downloaden

In deze taak downloadt u een eenmalige download van Excel-bibliotheken waarmee Excel verbinding kan maken met Power BI-gegevenssets.

  1. Selecteer in de Power BI-service Analyseren in Excel-updates in het menu Downloads in de rechterbovenhoek.

  2. Selecteer de knop Downloaden .

    Schermopname met animatie van een demonstratie over het downloaden van Updates voor Analyseren in Excel vanuit de Power BI-service.

Taak 2: Analyze installeren in Excel

In deze taak installeert u de Excel-bibliotheken waarmee Excel verbinding kan maken met Power BI-gegevenssets.

  1. Zodra het downloaden is voltooid, bevindt het installatiebestand zich in de standaardmap Downloads. Navigeer naar het gedownloade bestand en dubbelklik op het bestand om de wizard (.msi) te starten.

    Schermopname van de map Mijn downloads en het gedownloade M S I-bestand.

    Notitie

    U kunt dit bestand rechtstreeks openen vanuit de sectie Downloads van uw browser. Voor Firefox bevindt dit zich in de rechterbovenhoek. Voor Internet Explorer is dit linksonder. De downloadlocatie verschilt per browser.

  2. Volg de stappen van de wizard om analyseren in Excel-bibliotheken te installeren.

    Schermopname van het venster Analyseren in de installatiewizard van Excel.

Taak 3: Analyseren in Excel starten vanuit gegevenssets en gegevensstromen

In deze taak navigeert u naar de locatie Gegevenssets en gegevensstromen in de Power BI-service om Analyseren in Excel te starten met behulp van de gegevensset MAIAD Lab 03A - Power BI Model.

  1. Selecteer mijn werkruimte in het navigatiedeelvenster aan de linkerkant.

  2. Selecteer de navigatieoptie Gegevenssets + gegevensstromen .

    Schermopname van Power BI-service met M A I D - Lab 03 - Power BI Model weergegeven in Gegevenssets van Mijn werkruimte.

    Notitie

    Wanneer u uw PBIX-bestand naar de service publiceert, worden er twee Power BI-artefacten gemaakt: het gegevensmodel bevindt zich in Gegevenssets + gegevensstromen en Rapportpagina's in Rapporten.

  3. Selecteer meer opties in de MAIAD Lab 03A - Power BI Model-gegevensset en kies vervolgens de menuoptie Analyseren in Excel.

    Schermopname van het menu Meer van de Power BI-servicegegevensset met de optie Analyseren in Excel.

Taak 4: Het bestand Analyseren in Excel starten

In deze taak start u het Excel-bestand dat is verbonden met het MAIAD Lab 03A - Power BI Model Data Model.

  1. Navigeer naar de map Downloads, zoek het gedownloade Excel-bestand en dubbelklik op het bestand om het te openen.

    Schermafbeelding van de map Mijn downloads met het Excel-bestand geselecteerd in Windows Verkenner.

    Notitie

    U kunt dit bestand rechtstreeks openen vanuit de sectie Downloads van uw browser. Voor Firefox bevindt dit zich in de rechterbovenhoek. Voor Internet Explorer is dit linksonder. De downloadlocatie verschilt per browser.

  2. Zodra Excel wordt gestart, moet u mogelijk op de knoppen voor Bewerken inschakelen en Inhoud inschakelen klikken. Hierdoor kan Excel verbinding maken met het gegevensmodel dat is gepubliceerd naar de Power BI-service. Dit is een externe gegevensverbinding met de Azure-opslag van Microsoft in de cloud.

    Schermopname van bericht en knoppen Bewerken inschakelen en Inhoud inschakelen.

    Notitie

    Als u niet wordt gevraagd om zowel de berichten Bewerken inschakelen als Inhoud inschakelen, moet u mogelijk de instellingen van het Vertrouwenscentrum > van Opties > controleren... om ervoor te zorgen dat de instellingen van de berichtenbalk zijn ingeschakeld.

Oefening 3: Een Excel-rapport maken met behulp van een Power BI-gegevensset

In deze oefening maakt u een rapport in Excel met behulp van de Power BI-gegevensset die is verbonden met 'MAIAD Lab 03A - Power BI Model' dat is gemaakt met Behulp van Analyseren in Excel. Het Excel-rapport bevat een draaitabel, een draaigrafiek en kubusformules.

Taak 1: Metingen toevoegen aan de waarden van de draaitabelvelden

In deze taak vult u de draaitabel met metingvelden uit de verbinding met de Power BI-gegevensset.

  1. Selecteer in het venster Draaitabelvelden het tandwielpictogram en ga naar de optie Veldensectie en Sectie Gebieden naast elkaar.

    Schermopname van draaitabelvelden met het tandwielpictogram gemarkeerd.

    Notitie

    Standaard worden de draaitabelvelden weergegeven met de sectie Velden en De sectie Gebieden gestapeld. In de volgende instructies worden de draaitabelvelden weergegeven als Velden Sectie en Sectie Gebieden naast elkaar.

  2. Sleep vanuit de meettabel Kantoren de meting [# of Offices] naar de sectie Waarden in de lijst met draaitabelvelden.

  3. Klik in de meettabel Contracten op het selectievakje voor de metingen [Totaal aantal contracten] & [MRR Gewonnen - Contracten] naar de sectie Waarden in de lijst met draaitabelvelden.

    Schermopname van het venster Lijst met draaitabelvelden met de metingen in de sectie Waarden.

    Notitie

    Wanneer u velden in de metingstabellen selecteert, wordt het veld standaard met het selectievakje verplaatst naar de sectie Waarden. Dit komt omdat alleen metingen naar de sectie Waarden van een lijst met draaitabelvelden kunnen gaan wanneer u Excel verbindt met een Power BI-service-gegevensset.

  4. Klik met de rechtermuisknop op de draaitabel en selecteer de opties voor draaitabellen...

    Schermopname van het menu Draaitabel met de menuopdracht Opties voor draaitabel.

  5. Selecteer Weergeven en schakel vervolgens het selectievakje in om de rij Waarden weer te geven.

    Schermopname van het venster Opties voor draaitabellen met het selectievakje De rij Waarden weergeven uitgeschakeld.

    Notitie

    Dit wordt gedaan voor esthetische doeleinden om de rij met Waarden in de kop te verwijderen. Dit gebeurt standaard wanneer u meer dan één meting toevoegt aan de sectie Waarden van de draaitabelvelden.

Taak 2: Velden toevoegen aan de rijen met draaitabelvelden

In deze taak vult u de draaitabel met opzoekvelden uit de verbinding met de Power BI-gegevensset.

  1. Sleep vanuit de veldtabel Kantoren de kolommen [Regio] en [District] naar de sectie Rijen in de lijst met draaitabelvelden.

    Schermopname van het venster Lijst met draaitabelvelden met de velden uit de tabel Kantoren in de sectie Rijen.

  2. Gebruik de muis om de cursor in cel A1 te plaatsen en typ de naam Regio & District in de cel om de standaardkopnaam te wijzigen.

    Schermopname van close-up van de kop van de draaitabel om het label weer te geven in kolom A rij 1.

Taak 3: Een draaigrafiek invoegen

In deze taak voegt u een draaigrafiekwerkruimte in het Excel-werkblad rechts van de draaitabel in. Vervolgens voegt u velden toe aan de secties As en Waarden.

  1. Gebruik de muis om Cel E1 in het werkblad te selecteren. Hiermee selecteert u de locatie voor de draaigrafiek.

    Schermopname van Werkblad met kolom E rij 1 geselecteerd voor de locatie van het nieuwe draaidiagram.

  2. Selecteer het tabblad Invoegen in het hoofdmenu en selecteer de optie Draaigrafiek in de vervolgkeuzelijst met de knop Draaigrafiek .

    Schermopname van het tabblad Invoegen in het hoofdmenu met de vervolgkeuzelijst Draaigrafiek geselecteerd en de optie Draaigrafiek.

  3. Selecteer in het venster Draaigrafiek maken het keuzerondje Een externe gegevensbron gebruiken .

  4. Selecteer Verbinding kiezen... Knop.

    Schermopname van het venster Draaigrafiek maken met het keuzerondje Een externe gegevensbron gebruiken geselecteerd en de knop Verbinding kiezen.

  5. Selecteer vervolgens op het tabblad Verbindingen en de sectie Verbindingen in deze werkmap de naam van het pbiazure//api.powerbi.com connection string pad om de draaigrafiek te verbinden met de externe gegevensbron van de Power BI-gegevensset.

    Schermopname van het venster Bestaande verbindingen met het tabblad Verbindingen geselecteerd, sectie Verbindingen in deze werkmap met het Azure-verbindingspad van de Power BI-service.

    Notitie

    De exacte naam van uw pbiazure://api.powerbi.com connection string is anders dan de naam die in de bovenstaande afbeelding wordt weergegeven. Dit is de unieke verbindingslocatie-id voor een gepubliceerde Power BI-gegevenssetartefact.

  6. Klik op OK.

  7. Klik in de meettabel Offertes op het selectievakje naast de meting [Gewonnen versus Potentiële MRR] om de meting te verplaatsen naar de sectie Waarden in de lijst met draaitabelvelden.

  8. Sleep vanuit de veldtabel Kantoren de [Regio] naar de sectie As (categorieën) in de lijst met draaitabelvelden.

    Schermopname van draaitabelvelden met meting uit de tabel Aanhalingstekens in de waarden.

Taak 4: Draaigrafiek opmaken

In deze taak maakt u de draaigrafiek op met behulp van enkele van de vertrouwde opmaakopties in Excel.

  1. Selecteer op het tabblad Ontwerpen in het hoofdmenu stijl 4.

    Schermafbeelding van het tabblad Ontwerpen in het hoofdmenu met Stijl 4 geselecteerd.

  2. Dubbelklik op de grafiektitel en wijzig de standaardtekst titel in MMR Gewonnen % per regio.

  3. Beweeg de muisaanwijzer over de rechterbovenhoek van het draaidiagram om de opties voor Grafiekelementen weer te geven en schakel het selectievakje Legenda uit om de Legenda te verwijderen.

    Schermopname van draaigrafiekgrafiekelementen met het selectievakje Legenda uitgeschakeld.

Taak 5: KPI's toevoegen met KUBUSWAARDE

In deze taak gebruikt u KUBUSformules om KPI's op hoog niveau voor het rapport te maken.

  1. Wijzig de naam van de gegevensverbinding in een beschrijvende naam. Klik op Gegevens -> Query's & op verbindingen om de queryverbindingen & aan de rechterkant te openen.

    Schermopname van de knop Query's en verbindingen op het tabblad Gegevens van Excel met een visual van Verbindingen geselecteerd in het deelvenster.

    Notitie

    De exacte naam van uw pbiazure://api.powerbi.com connection string is anders dan de naam die in de bovenstaande afbeelding wordt weergegeven. Dit is de unieke verbindingslocatie-id voor een gepubliceerde Power BI-gegevenssetartefact.

  2. Selecteer Verbindingen, klik met de rechtermuisknop, kies Eigenschappen, wijzig de naam van de verbinding in Power BI - MAIAD Lab 03A – Power BI-model en druk vervolgens op OK.

    Schermopname van Eigenschappen van Excel-gegevensverbinding met nieuwe naam in het vak Verbindingsnaam naast afbeelding van de knop Eigenschappen.

    Notitie

    De aanbevolen procedure bij het verwijzen naar gegevensmodellen in Excel is het opgeven van gebruiksvriendelijke namen ter referentie en het verstrekken van een gedetailleerde beschrijving van de gegevensverbinding.

  3. Klik met de rechtermuisknop op rij 1 om een rij boven de draaitabel en het draaidiagram in te voegen .

  4. Gebruik Ctrl+Y om de laatste stap te herhalen en voeg nog een rij toe boven de draaitabel en het draaidiagram.

  5. Klik met de rechtermuisknop op kolom A om een kolom in te voegen vóór de draaitabel.

    Notitie

    Dit biedt een rij- en kolombuffer voor esthetische doeleinden. En biedt een rij voor een rapportkop en de KPI's met behulp van KUBUSWAARDE-formules.

  6. Klik met de rechtermuisknop op kolom A en stel de kolom in op 1.

  7. Gebruik Opvulkleur = Zwart op het tabblad Start in het hoofdmenu om een rapportkop te maken in rij 2.

  8. Gebruik Tekstkleur = Goud, Accent 4 voor rij 2.

  9. Selecteer Cel I2 en voer de tekst 'Potentiële MRR:' in. Dit dient als de KPI-beschrijving.

  10. Voer in cel J2 de volgende formule KUBUSWAARDE in en druk op Enter:

    =KUBUSWAARDE("Power BI - MAIAD Lab 03A – Power BI-model","[Metingen].[ Mogelijke MRR]")

    Schermopname van formulebalk met toegang tot meting.

    Tip

    Terwijl u de formule KUBUSWAARDE typt, ziet u dat IntelliSense wordt weergegeven om u te helpen bij de syntaxis die nodig is om de formule te voltooien. Een KUBUSWAARDE-formule kan worden gecombineerd voor gebruik met slicers.

  11. Selecteer Cel K2 en voer de tekst 'Gewonnen MRR:' in. Dit dient als de KPI-beschrijving.

  12. Voer in cel L2 de volgende formule KUBUSWAARDE in en druk op Enter:

    =KUBUSWAARDE("Power BI - MAIAD Lab 03A – Power BI-model","[Metingen].[ MRR Gewonnen - Contracten]")

    Schermopname van formulebalk met kubuswaardefunctie voor berekening met behulp van een meting uit het gegevensmodel.

    Selecteer Cel M2 en voer de tekst %Won:" in. Dit dient als de KPI-beschrijving.

  13. Voer in cel N2 de volgende Excel-formule in en druk op Enter:

    =L2/J2

    Schermopname van de formulebalk met een Excel-formule voor celdeling.

    Tip

    U kunt de bekendheid en functies van Excel combineren met gegevenssets die zijn gepubliceerd naar Power BI.

  14. Klik met de rechtermuisknop en selecteer Celeigenschappen... naar percentage.

  15. Selecteer Bestand in het hoofdmenu van het Excel-lint en vervolgens Opslaan als.

  16. Navigeer naar de map C:\ANALYST-LABS\Lab 03A .

  17. Sla het bestand op als MAIAD Lab 03A - Power BI-model - Mijn Solution.xlsx.

In deze oefening hebt u een Power BI Desktop gegevensset en rapport gepubliceerd naar de Power BI-service. Vervolgens hebt u een rapport gemaakt in Excel met een draaitabel, draaigrafiek en kubusfuncties die zijn verbonden met een Power BI-gegevensset. In deze laatste oefening ziet u wat er mogelijk is wanneer u Power BI in combinatie met Excel gebruikt.

Schermopname van het uiteindelijke Excel-rapport met formules voor draaitabel, draaigrafiek en kubuswaarde.

Belangrijk

Nu u het rapport hebt gemaakt, wilt u het bijgewerkt houden. Maar maakt u zich geen zorgen, het kost slechts twee klikken op de knop: Alles vernieuwen van gegevens>.

Schermopname van het tabblad Gegevens in het hoofdmenu met de knop Alles vernieuwen weergegeven.